1. Tablet future looks bright! Read more about: Alcatel Xess | Samsung Galaxy View
    New Forums: Alcatel Xess | Samsung Galaxy View
    Dismiss Notice

GMAIL notification not working ...... >>>>Support


Last Updated:

  1. LesDrive

    LesDrive Member

    Just wondering if anyone else has this issue....

    As long as I`m on the mobile network, my Gmail doesn`t notify me of any new emails. I have downloaded updates for the gmail account, rebooted the phone, I made sure the Sync Gmail account is on, background data is on, sound is on, notification for every new email is on.... what am I missing???? The only time I get notified is when I actually open the Gmail app.

    However, when I switch over to Wi-Fi, the test emails I send from my Yahoo email account, are showing up within seconds.

    I have a Samsung Galaxy S II i727 running 4.0.4
    Any suggestions or ideas you may have would be appreciated.

    Thanks

    Advertisement
  2. olbriar

    olbriar Moderator Moderator

    You might want to check the interval that you have it checking for new mail. If you open the gmail account and do a menu you will likely find that setting. Perhaps the interval is such that you aren't syncing in the time frame you are checking. Most email accounts will auto check when you open the mail account. Good luck.
  3. LesDrive

    LesDrive Member

    OK... I tried looking for a time interval setting but couldn`t find one.

    I open the Gmail app ---> menu ---> setings ---> and then I have ---> "general settings", "myemail@gmail.com" and "about Gmail". Under "General settings" I have 3 confirmation boxes: delete, archive and send, swiping conversation list, replay all, auto fit, auto advance, hide checkboxes and message action. Nothing about a time interval setting.

    Under "myemail@gmail.com" I have: "Priority Inbox", "notifications" (checked), "Inbox sound & vibrate" (ON), "Signature", "Sync Gmail" (checked), "Days of mail to sync" (30 days), "Manage labels" (that`s where I have turned on the sound & sync to various labels), "Download attachments" (checked). Again, I found no time interval settings. That means that the app will automatically check for new messages ???

    The thing is that all this settings work just fine when I`m on wifi and like I said: test email are showing up within seconds after being sent. Wonder if there may be some settings of the gmail app when its off wifi - on mobile network? I also checked under "Settings" ---> "Data usage" ---> "Gmail" and the "Restrict backgroung data" box it is not checked so I should be getting the notifications.

    I also checked under "Settings" ---> "Applications" ---> "All" ---> "Gmail". There is a "Launch by default" which it says "No defaults set" but I also can not change that... or at least I don`t know where to change it from. Also not sure if that would do anything to solve the issue I have.
  4. LesDrive

    LesDrive Member

    So far I didn`t get it to work. I also uninstalled all the gmail updated and now the gmail app is at least checking for new msgs when the app is being opened. Totally deleted my gmail account from the phone then re-installed it.... same thing.... Gmail doesnt notify me of new msgs only when its on wifi.... not sure where else to look to fix this
  5. LesDrive

    LesDrive Member

    OK.... I found the problem!

    My "Social hub" app was disabled. Not sure how the heck that happened since I didn`t do it knowingly but I was checking my list of Applications and at the bottom of the list there are the disabled apps. Some apps i disabled myself a while ago but somehow, the list grew. The email app was on that list as well but even when I enabled it, my Gmail wasn`t notifying me of new msgs. And then I found the "Social Hub" app that was disabled. 2 seconds after I enabled the Social hub, all my test emails sent to my Gmail account started to come thru.

    So there you go. If anyone else has a problem with Gmail notifications not coming thru, this may be one other thing to ad to the check list: check if your Social Hub app is enabled.

Share This Page