gmail push behaving erratically on my htc incredibleSupport


Last Updated:

  1. carylev

    carylev Well-Known Member This Topic's Starter

    Joined:
    May 14, 2010
    Messages:
    55
    Likes Received:
    11
    im not an expert on how push email works, but my understanding is that gmail messages should appear on my phone without me having to refresh or manually sync the gmail app. for a reason unknown to me, sometimes this works and sometimes it doesnt. at night, i shut down wifi and the mobile network to conserve battery and start up the mobile network when i leave for work in the morning. i get notification of new yahoo email, thru the htc widget, almost instantaneously, yet gmail doesnt come thru until i manually sync the gmail app. then during the course of the day, sometimes gmail messages get pushed right thru and other times not at all until i manually sync the app. meanwhile my yahoo mail comes thru flawlessly.

    considering gmail is supposed to push and the htc widget does not, this is the opposite of what i expect. as far as settings, i have auto sync enabled for both the device and for the gmail app. while i always assume user error until proven otherwise, in this instance i think i have all the correct settings, which makes sense considering sometimes gmail does get pushed. its just erratic and unpredictable. anybody got any ideas what's going on here? thanks for your help!
     

    Advertisement
  2. JulieJHawk

    JulieJHawk Active Member

    Joined:
    Apr 22, 2010
    Messages:
    38
    Likes Received:
    5
    i am experiencing weird gmail issues, too. yesterday my gmail was being pushed and would show up (with notification) on my inc instantly, sometimes even before it got to the inbox on my laptop. this morning when i turned the mobile network back on, i got two emails right away but since then NOTHING! i have had to manually sync several times to get anything to show up on my phone. i didn't change any settings from yesterday to today but the phone is behaving in a completely different way today! i have no idea what is going on!
     
  3. elrabin

    elrabin Well-Known Member

    Joined:
    Apr 3, 2010
    Messages:
    203
    Likes Received:
    50
    Question to you both:

    Are you using the integrated gmail app or the HTC mail app?

    The integrated gmail app, for your phone-linked gmail account, is push email. No need to sync.

    The HTC mail app is sync based, as quick as every 15 min as long as once a day.

    Also, if you are shutting off mobile network at night, did you perchance check your gmail on a computer before turning the phone back on?

    New emails would come to the phone, but wouldn't be "new" because you already read them. So you wouldn't get notification.
     
  4. JulieJHawk

    JulieJHawk Active Member

    Joined:
    Apr 22, 2010
    Messages:
    38
    Likes Received:
    5
    i am using the gmail app.
    i did not check my email on computer before i turned the mobile network back on. i did like i do every morning, wake up and turn mobile network on, emails come in, i go about my day, gmail push alerts when i get new mail.
    today: wake up, turn on mobile network, get two new emails, go about my day, look at laptop and see that i have four new emails, check phone- nothing, click on refresh button in gmail app and mails come.
    yesterday they pushed, today i have to sync. no setting changes from yesterday to today!!
     
  5. elrabin

    elrabin Well-Known Member

    Joined:
    Apr 3, 2010
    Messages:
    203
    Likes Received:
    50
    i never turn the mobile network off and i never have push mail issues. Perhaps that is the issue?

    I might recommend that you restart your phone. I used to have weird data connection issues on my blackberry and Touch Pro 2 when turning mobile data off/on or going into airplane mode.

    Don't know what else to suggest. Sorry.
     
  6. JulieJHawk

    JulieJHawk Active Member

    Joined:
    Apr 22, 2010
    Messages:
    38
    Likes Received:
    5
    i will try not turning off the mobile network from now on. is there a way to leave the phone on all night but only allowing texts and/or phone calls to come through? is the only way to turn off the notification in the gmail app?
     
  7. carylev

    carylev Well-Known Member This Topic's Starter

    Joined:
    May 14, 2010
    Messages:
    55
    Likes Received:
    11
    i too am using the integrated gmail app, and its definitely not working. the whole purpose of push email is so the phone will tell me when i have mail to review, if i have to proactively check for new messages i might as well go back to my old lg voyager. ok, obviously im being hyperbolic but nonetheless this should be working. one would think a google operating system with an integrated app for pushing google mail to the device would work better than the htc email widget, but it doesnt. and that's inexcusable. big disappointment, and tie that to the less than stellar battery performance and i'm glad i still have two weeks to decide whether to keep this phone or wait out the verizon iphone which is looking more and more likely by the day.
     
  8. carylev

    carylev Well-Known Member This Topic's Starter

    Joined:
    May 14, 2010
    Messages:
    55
    Likes Received:
    11
    so basically we have to choose between leaving the mobile connection on all night and unnecessarily draining the unacceptably weak battery in order to have the email function work correctly, or shutting down the data connection to conserve battery and have the email function not work the next day after the connection is restarted. am i crazy or is that unacceptable for an ostensibly advanced mobile device that was branded "incredible"???
     
  9. elrabin

    elrabin Well-Known Member

    Joined:
    Apr 3, 2010
    Messages:
    203
    Likes Received:
    50
    The phone leaves the data connection dormant unless something is actively requiring data usage. I am getting between 24 and 30 hrs of battery life and i leave mobile connection on, gps location on, brightness on auto. The only things off are Bluetooth and Wi-fi. I do quite a bit of surfing and IM during the day and a good number of emails and calls as well.

    The battery isn't weak, its either your application loadout(poorly coded apps that don't shut down and suck down battery) or you've got your sync options turned up to very high frequency.

    Last, push email doesn't use battery power like sync does. Gmail "pushes" the email to you instead of the phone actively waking up, turning up the mobile data and going out to search for it ala sync. So the only data / battery usage is when the actual email is downloaded.
     
  10. elrabin

    elrabin Well-Known Member

    Joined:
    Apr 3, 2010
    Messages:
    203
    Likes Received:
    50
    I haven't needed it, but people keep recommending an app in the market called "Profile" that can automatically mute/vibrate any type of notification according to a schedule that you set.

    So, for you, you'd create a profile from say, 10pm - 7am where the texts and voice calls ring normally, but it mutes the gmail notification.

    And your default profile would be everything on.
     
    JulieJHawk likes this.
  11. dylo22

    dylo22 Well-Known Member

    Joined:
    Apr 19, 2010
    Messages:
    743
    Likes Received:
    119

    You can try uninstalling gmail app and reinstalling to see if it fixes the issue. There should be no reason for you to miss emails from the app. I've had it installed on day one and never missed any emails.

    As for as mobile connection is concerned, I always leave it on. I also always leave GPS on and I get about a day's worth (14hrs) of battery on moderate usage. Of course this all varies depending on usage, apps your have installed, # of widgets on screen, signal strength, settings and more. I suggest playing around with settings/apps and try to find right balance to give you the most amount of power.
     
  12. JulieJHawk

    JulieJHawk Active Member

    Joined:
    Apr 22, 2010
    Messages:
    38
    Likes Received:
    5
    elrabin, i'll check that out. thanks.
     
  13. axel_2078

    axel_2078 Well-Known Member

    Joined:
    Feb 26, 2010
    Messages:
    568
    Likes Received:
    102
    I am having the same problem. From what I can tell, there is no true push capability on this device. Sometimes emails are received a few seconds after they are sent and sometimes it's 15 minutes or more after it was sent. That's not push email. If I have WiFi turned on, emails don't get pushed to the device at all and I have to do a manual refresh to get them. FAIL.
     
  14. dm33

    dm33 Well-Known Member

    Joined:
    Mar 23, 2010
    Messages:
    320
    Likes Received:
    56
    Push IMAP email does work with the GMail app or K-9. HTC Mail does not support Push email. Yahoo doesn't support IMAP Push email.
     
  15. carylev

    carylev Well-Known Member This Topic's Starter

    Joined:
    May 14, 2010
    Messages:
    55
    Likes Received:
    11
    i think i just figured it out. i shut down and rebooted the phone and tested a few msgs and they immediately got pushed. im pretty sure the problem is you need to keep gtalk service running in order to get the phone to receive pushed mail. previously i shut gtalk service down to conserve battery power under settings>applications>running services, but now that its back up and running mail is coming thru like a champ. to anybody having the same problem i had, give this a shot and let me know if it solves your problem.
     
  16. huyle23

    huyle23 New Member

    Joined:
    Jun 2, 2010
    Messages:
    1
    Likes Received:
    0
    I had the same problem and this fixed it for me. Hope it helps.

    Thanks to ShelbyHanneman: You have to change your sync to auto-sync.
    Settings > Account & Sync > make sure you've got Auto-Sync checked, then also make sure exchange icon is green. That will enable it to sync.
     
  17. Rosso

    Rosso Member

    Joined:
    Oct 27, 2009
    Messages:
    8
    Likes Received:
    0
    Thank you so much. I was having the same problem, the auto sync solved it. It was driving me crazy. I dont know why but my phone is having trouble "remembering" some of the settings and unchecks itself etc.
     
  18. shaggymatt

    shaggymatt Well-Known Member

    Joined:
    Oct 29, 2009
    Messages:
    105
    Likes Received:
    4
    My Droid actually stopped syncing to my Gmail account for ~30 hours a couple months ago. The cache had to be dumped:

    Press your device's < Home > button, then press < Menu >. Select Settings. Select Applications, then Manage applications. Select Gmail Storage.

    Note: If you don't see 'Gmail Storage,' press < Menu > again, then select Filter > All. Select Clear data. Answer OK when prompted. Return to the list of applications by pressing the < Back > button on your device. Select Gmail and then select Clear data. Answer OK when prompted.To restart your device, press and hold the < Power > or < End call > button, then select Power off. Press the < Power > or < End call > button to power on.

    Your device will re-sync with the server after restarting (this may take several minutes).


    In my case it didn't start syncing immediately. I ended up putting K-9 Mail on, which was pretty cool. About a day later, it began working again.
     
    mikeyursomny and DC2_408 like this.
  19. rcrott1

    rcrott1 Well-Known Member

    Joined:
    May 23, 2010
    Messages:
    730
    Likes Received:
    87
    Try using Foxyring, it has some options in it to allow phone calls and txts to come through but quiet everything else.
     
  20. elrabin

    elrabin Well-Known Member

    Joined:
    Apr 3, 2010
    Messages:
    203
    Likes Received:
    50
    Don't feed the troll, just report his post. He'll be gone soon enough.
     
  21. DUVTony

    DUVTony New Member

    Joined:
    Jul 1, 2010
    Messages:
    1
    Likes Received:
    0
    Having the same problem. some days, i get gmail notifications as the mail arrives, some days i have to refresh the system when inside the gmail account to get emails. i have mail in there for 8 hours without receiving a notice.
    I spoke to Verizon 2x and they went through settings, battery pull, netwrok settings etc... could find nothing wrong.
    Verizon sent me to HTC support and they just said that maybe an app i loaded was interfering with the gmail.
    I have had this phone for less than 2 weeks and the only apps i loaded (maybe 7) came from reviews of must have droid apps from CNET. So i do not know if this is the real reason for this.
    Their suggestion was to reset the phone to original factory state and start fresh. that seems unacceptable to me for a system that boasts 10000 apps. Can you imagine doing this when i load 50! And i have to reload enterprise mail, contacts, photos, music etc. they said that i have to first copy everything over from the SD card to a computer because doing a factory reset may render the SD card unreadable after power up.

    THis looks like a work in progress to me.
    BTW< i get notification of my earthlink mail and my enterprise mail in secods every time. Just gmail notices are not coming though.
     
  22. mikeyursomny

    mikeyursomny New Member

    Joined:
    Aug 8, 2010
    Messages:
    3
    Likes Received:
    0
    Press your device's < Home > button, then press < Menu >. Select Settings. Select Applications, then Manage applications. Select Gmail Storage.

    Note: If you don't see 'Gmail Storage,' press < Menu > again, then select Filter > All. Select Clear data. Answer OK when prompted. Return to the list of applications by pressing the < Back > button on your device. Select Gmail and then select Clear data. Answer OK when prompted.To restart your device, press and hold the < Power > or < End call > button, then select Power off. Press the < Power > or < End call > button to power on.

    This "solve: worked perfectly for me. I would suggest trying it for anyone having this problem! Thanks Shaggymatt
     
  23. buck flicks

    buck flicks Member

    Joined:
    May 6, 2010
    Messages:
    14
    Likes Received:
    2
    I was having a similar issue - having to manually refresh to get my emails. I went to the sync control panel, unchecked all my google options, turned off the phone, then went back to sync, and rechecked the gmail and contacts boxes and hit the sync button. Then I checked the calendar box and tried to sync and it got hung up. So I unchecked calendar and just left it unchecked, and everything is pushing fine.

    I don't know if the calendar is what is causing everyone's problems, but that process did the trick for me.
     

Share This Page

Loading...