Gmail Push Not Working!!General


Thread Status:
Not open for further replies.

Last Updated:

  1. 1967ls2

    1967ls2 Well-Known Member This Topic's Starter

    Joined:
    Apr 29, 2010
    Messages:
    197
    Likes Received:
    25
    So I am having issues with my Gmail push feature. I opted for the Gmail app instead of the HTC mail app. The only issue is my emails aren't being pushed to my phone. When I go into the Gmail app and click on accounts & check the settings it has Auto Sync checked and also the correct Gmail account. When I go to settings>Accounts & Sync> Auto Sync is checked there as well along with my Gmail account.
    I have sent numerous test emails from my work PC to my personal Gmail account but the emails aren't popping up as new notifications or even in the Gmail app until I actually open the Gmail app several minutes later.
    What is going on here? I thought Gmail was supposed to be a true "Push" mail client that worked on the Incredible...
    Thanks for any help or advice.
     

    Advertisement
  2. mister_tu

    mister_tu Well-Known Member

    Joined:
    Nov 11, 2009
    Messages:
    199
    Likes Received:
    38
    Sounds like your phone is infected...with the hiv.
     
  3. mister_tu

    mister_tu Well-Known Member

    Joined:
    Nov 11, 2009
    Messages:
    199
    Likes Received:
    38
    Sounds like your phone is infected...with the hiv.
     
  4. 1967ls2

    1967ls2 Well-Known Member This Topic's Starter

    Joined:
    Apr 29, 2010
    Messages:
    197
    Likes Received:
    25
    Well that was very insightful and helpful. Thanks for wasting my time.
     
  5. mister_tu

    mister_tu Well-Known Member

    Joined:
    Nov 11, 2009
    Messages:
    199
    Likes Received:
    38
    It took you 12 seconds to read and write a response, if that's 'wasting your time' then you might as well just quit at life now.
     
  6. 1967ls2

    1967ls2 Well-Known Member This Topic's Starter

    Joined:
    Apr 29, 2010
    Messages:
    197
    Likes Received:
    25
    Well what's your deal to begin with? I posted this thread asking for help about a specific problem and you posted some stupid coment about nothing. Why even respond if you have nothing to add to the topic or specific help to provide.
    This is my first thread in the Android Forum and this is the response that I get from the community. Please lets just leave this at you obviously have no helpful information to provide or add so just don't respond to this thread anymore. Thanks for nothing...
     
  7. kimf

    kimf Active Member

    Joined:
    Mar 3, 2010
    Messages:
    38
    Likes Received:
    2
    1967, I have had times my push email doesn't seem to be working but then it starts again. Sometimes emails come through instantly, sometimes it takes a while. I wonder if it is a gmail server issue?
     
  8. mister_tu

    mister_tu Well-Known Member

    Joined:
    Nov 11, 2009
    Messages:
    199
    Likes Received:
    38
    Someone will eventually help you, I'm hear for comic relief, so calm down, buddy. If this is your first time on an online forum, get used to it. There is useless/humorous banter that happens ALL THE TIME.
     
  9. 1967ls2

    1967ls2 Well-Known Member This Topic's Starter

    Joined:
    Apr 29, 2010
    Messages:
    197
    Likes Received:
    25
    It's not my first time on an online forum. I am a member of plenty of other forums. Generally the community is very helpful and receptive to threads asking for help. I was just hoping this community would be as helpful as others that I frequent but I am sadly dissapointed.
    I understand comic relief and humerous anecdotes but when someone is asking for help and the only reply that they get is BS they aren't going to feel very good about the online forum or the users that frequent it. Enough said.
    Looking for help and if anyone has any ideas/solutions please, I'm all ears. Thanks in advance.
     
  10. jfunk

    jfunk Well-Known Member

    Joined:
    Apr 20, 2010
    Messages:
    305
    Likes Received:
    78
    First piece of advice: Don't converse with people trolling if they bother you.

    As for your gmail issue, make sure you have always-on mobile data enabled:
    Menu--->Settings--->Wireless & Networks--->Mobile Networks--->Enable Always-On

    If this is off, data being pushed to your phone will be received. You will only get updates when something actively starts your network connection.

    Also, are you running any task killers?
     
  11. 1967ls2

    1967ls2 Well-Known Member This Topic's Starter

    Joined:
    Apr 29, 2010
    Messages:
    197
    Likes Received:
    25
    The Enable Always on is selected. When I purchased the phone the VZW rep downloaded "Advanced Task Killer" for the phone. Should I delete it?
     
  12. jfunk

    jfunk Well-Known Member

    Joined:
    Apr 20, 2010
    Messages:
    305
    Likes Received:
    78
    Absolutely. This program kills background tasks at its own discretion. You can't troubleshoot pretty much any "this program isn't doing what it appears it should be doing" type of problem as long as you have an app running that is closing tasks. It could be closing a task that is necessary for this function to work.

    IMO, automated task killers should NEVER be used. Manual task killing/monitoring can be useful for troubleshooting when something isn't working right, but automated task killing is always going to lead to problems. Just because a program a task has been idle for a little while doesn't mean it doesn't need to be available.

    That's not to say that ATK is definitely causing your problem, but it must absolutely be gone before we can even begin to wonder what else it could be.
     
  13. 1967ls2

    1967ls2 Well-Known Member This Topic's Starter

    Joined:
    Apr 29, 2010
    Messages:
    197
    Likes Received:
    25
    Thanks for the help. I already uninstalled ATK. I have sent multiple email tests to my phone but still nothing. The only way I can get them is to open up the gmail app and refresh it.
    I also read that I should go onto my PC and change the settings for the GMail itself from POP to IMAP which i did already.
     
  14. mister_tu

    mister_tu Well-Known Member

    Joined:
    Nov 11, 2009
    Messages:
    199
    Likes Received:
    38
    Very wise padawan.
     
  15. Justin89t

    Justin89t Well-Known Member

    Joined:
    Apr 10, 2010
    Messages:
    63
    Likes Received:
    3
    First off, dont' feed the troll, its not worth the effort. Just ignore him and he'll realize how ****ing ******ed he is and stop making a fool of himself.

    edit: I love the forum blocks out ******ed but leaves ****ing. Now that's funny :)



    Second, I'm having this same issue. I'm always connected to the network and do not have any task killers installed/running.

    On my BB which didn't have push I'd still get gmail instantly, even before they showed up in gmail sometimes. In the gmail app I have to hit refresh to get them at all.
     
  16. mister_tu

    mister_tu Well-Known Member

    Joined:
    Nov 11, 2009
    Messages:
    199
    Likes Received:
    38
    Or you say ish like this which feeds the troll even more, so who's being hypocritical? Just saying.
     
  17. bryn987

    bryn987 Well-Known Member

    Joined:
    Apr 8, 2010
    Messages:
    120
    Likes Received:
    5
    same issue here. I have the gamil unread messages app installed and sometimes it works, sometimes it doesn't. y
     
  18. 1967ls2

    1967ls2 Well-Known Member This Topic's Starter

    Joined:
    Apr 29, 2010
    Messages:
    197
    Likes Received:
    25
    HA! That is funny that it left ****!ng but blocked the other. Yeah this is p!ssing me off. I am also coming from a BB and emails were instantaneous. I have my sync settings turned on in the settings and the email settings. I deleted the advanced task killer just in case, I have manually changed my Gmail account from POP to IMAP. What is going on here?
    How hard is it to have the Gmail push email function actually work properly. They said that Gmail was the only true push function that would work on the Incredible and thats the email I have so what gives???
     
  19. axel_2078

    axel_2078 Well-Known Member

    Joined:
    Feb 26, 2010
    Messages:
    568
    Likes Received:
    102
    Same here. Sometimes it takes 3-5 minutes for emails to arrive in the Gmail app and sometimes they don't arrive at all and I have to do a manual refresh to get them. Not really "push" email.
     
  20. axel_2078

    axel_2078 Well-Known Member

    Joined:
    Feb 26, 2010
    Messages:
    568
    Likes Received:
    102
    I'm wondering the exact same thing. There is no genuine "push" capability on this device from what I've seen so far. I have also come from a Blackberry where push email was instant. It seems to be sporadic at best on the Incredible.
     
  21. 1967ls2

    1967ls2 Well-Known Member This Topic's Starter

    Joined:
    Apr 29, 2010
    Messages:
    197
    Likes Received:
    25
    Well I guess it is comforting to know that I am not alone on this one but still what the hell is going on? This is ridiculous. I can't get Facebook notifications on the app itself because they only arrive via email notifications, I can't get email notifications for any emails because they arrive via the gmail app and this thing wont push my emails!
    So I am constantly checking my gmail and refreshing. This is ******ed!!
     
  22. axel_2078

    axel_2078 Well-Known Member

    Joined:
    Feb 26, 2010
    Messages:
    568
    Likes Received:
    102
    I share your frustration. I couldn't stand my Blackberry Curve 8330 because it was slow as hell and the browser was worthless. However, it was great at a couple of things....push email and facebook integration/notifications. The Incredible excels in just about every area, but falls way short in those.
     
  23. jfunk

    jfunk Well-Known Member

    Joined:
    Apr 20, 2010
    Messages:
    305
    Likes Received:
    78
    Messing with the POP/IMAP settings shouldn't make a difference in this case (since you aren't actually accessing gmail via one of those protocols here...this would matter if you were accessing gmail via a third party application).

    Make sure you do a shutdown and restart since removing the task killer too. Just uninstalling it won't necessarily restart any services it may have already stopped.

    I can't be 100% certain how quickly this is "supposed" to work. I can't say that I've ever noticed a delay of more than a minute, but I haven' been paying that close of attention either. Just sitting at my desk now, I haven't had one take as much as a minute and sometimes it shows up on the phone before it does on the website.

    One thing I will clarify, you aren't looking for stuff you have auto-archived are you? I have quite a few things auto-label and auto-archive (like email notifications about forum posts here for example)...these things won't set off an alert on the phone, they'll just be sitting in the label folder when you look. You have to have stuff staying in the inbox for the alert to happen.

    Unfortunately, that's probably about all the help I can give you. Mine SEEMS to be working much better than yours, but I'll try to pay attention a little better to see if I notice any longer delays any time.
     
  24. Trident

    Trident VIP Member VIP Member

    Joined:
    Jan 20, 2010
    Messages:
    3,035
    Likes Received:
    2,307
    Grow up. I will be issuing infractions.
    Thread closed.
     
Thread Status:
Not open for further replies.

Share This Page

Loading...