Gmail push on Corporate WiFiSupport

Last Updated:

  1. shami_dude

    shami_dude New Member This Topic's Starter

    May 5, 2010
    Likes Received:
    I noticed today that I am not receiving push emails via Gmail when I am connected to our corporate WiFi. I can still use the "refresh" menu command to fetch new emails, but this is a step backward, given that I receive instantaneous alerts when the phone is on 3G.

    I am able to receive push emails when I am using my home WiFi, or when I am using the 3G network. I haven't thoroughly tested the 3G part, because I use WiFi most of the time at home/work to conserve battery (I assumed this).

    I did couple searches on the topic in the forums, and I noticed in one post some references to GTalk, and how it is being used behind the scenes for the push emails. So I tried connecting to GTalk at work on my cell phone, and the thing timed out.

    So now I am guessing that maybe our corporate WiFi is restricting access to GTalk ports/IP, and as a result, the push email delivery is effectively disabled.

    Does this sounds plausible? Is there a way to force GMail to switch into Pull mode on a regular basis? (I am OK with auto-checking every 5-10 mins, as opposed to having to check my emails manually).


    p.s. I looked in the possible GMail settings, but couldn't find anything relevant there. But I am wondering if there is some API for the GMail App that I can use in another App? If that is true, then maybe I should write/find an app that would wake up on a regular basis and triggers GMail to check the remote server.

    p.p.s. It just happens that out of all the places, the Verizon signal is zero/missing in my cube at work, hence I have no options other than using corporate WiFi (and Google Voice).


    VTENGR Well-Known Member

    Apr 30, 2010
    Likes Received:
    I'm having this exact same issue. When i'm on my work wifi i don't get gmail updates and can't log on to gtalk, when i use 3g, gtalk works fine and i get emails just fine. It must have something to do with the wifi settings. Did you ever find a work around?

Share This Page