GNex no wifi at home /w full strengthSupport


  1. larry42

    larry42 Member

    Hi,

    I have a strange problem here: my VZW GNex is unable to access the internet when it's connected to my home wifi, despite having a full (albeit grey) wifi signal indicator. By all indications, things should be fine:The phone gets an IP via DHCP just fine, and the gateway & subnet info are correct (checked /w Network Info 2)

    The specifics (updated after suggestions):

    1. The wireless router sees the mac address in its DHCP table, and no MAC filtering is configured on the router.
    2. Other wireless devices (ipad/iphone/laptops) all work fine.
    3. I have changed encryption mode from WPA/WEP/disabled and all behave the same: the wifi indicator briefly is full and blue, then about 3s later it becomes full and grey. Signal strength is -46 dBm
    4. This GNex has connected fine to 2 other Wifi's - a friend's and my office.
    5. Router is a Linksys WRTGL54, firmware 4.30.7
    6. I've tried changing wifi channels to 1, 6, and 11
    7. For sure, no MAC filtering exists on the router (and it gets an IP from the router, as well)
    8. When I say "full but grey" I mean that - I can walk far away and the top couple grey bars disappear - so it's definitely getting wifi signal, IP, gateway, etc -- but no internet connection.
    9. I've tried "B only," "G only," and "Mixed" on my wifi. None of these work any better than the others (in terms of fixing this problem)

    Regardless of my tweaks, the result is the same: after connecting, the wifi indicator is "full" and blue for ~3s before it becomes "full" but grey -- with no internets.

    What else should I try?

    Thanks.
    larry

    Advertisement
  2. Evilgrin

    Evilgrin Active Member


    1. make sure you have enough free ip's available on your router should be in the settings.

    2. if the wifi meter is grey you have no signal it should be blue.

    3. Try shutting off the wifi on the phone and turning it back on if that don't work try resetting your wireless router.

    Other then that I'm all out of ideas.
  3. kg2128

    kg2128 Well-Known Member

    One thing I've found is that the wifi in phones can be picky about what router you have. My droid x was dropping the signal and going out of sync with my old router constantly, when I got a new docsis modem with wifi built in it worked flawlessly. Also try switching the WPA encryptions, AES only seems to work better for some people.
  4. larry42

    larry42 Member

    Thanks for the thoughts. To respond directly:

    1. Yes plenty of IPs free. Phone gets a valid IP from the DHCP.
    2. The phone's wifi signal strength shows as "Excellent" or "Good" - and given that I get an IP from it w/o issue, clearly I have the ability to talk to the router (and hence have signal strength).
    3. Have done that many, many times. ;)
  5. larry42

    larry42 Member

    Yeah it's very strange. This is a common and relatively modern router (Linksys WRTGL54, firmware 4.30.7).

    And yeah, I've tried multiple types of authentication (none/WEP/WPA) with the same result each time.

    Mega frustrating.
  6. trophynuts

    trophynuts Well-Known Member

    you don't have a mac filter set up on your router do you?

    also you may could try changing the channels on your router. Either 1, 6 or 11. Those three don't overlap.
    larry42 likes this.
  7. SamMax

    SamMax Well-Known Member

    Make sure you have you phone set to 2.4 ghz
  8. syntrix

    syntrix Well-Known Member

    as opposed to auto or 5.0... these are options for the connection.

    What router are you connecting to, specifically?
  9. larry42

    larry42 Member

    Thanks for the suggestions. Have tried each of these channels with no change: ~3s of full blue wifi indicator then it becomes full but grey.

    And no, no MAC filtering on the router.
  10. larry42

    larry42 Member

    Phone is connecting on 2.4 (2412 mhz/channel 1) @ 54mbps. It's connecting to a Linksys WRTGL54 /w firmware 4.30.7.

    I haven't found the setting to change the auto/5.0/2.4 on the phone - doesn't appears to be in the wifi/advanced wifi options for my connection. Do you know where I find this setting?

    Thanks.
  11. tbever

    tbever New Member

    I am having exactly the same problem. Mine worked fine for the first 2 days, now it will not connect, otherwise identical problem. I also have a linksys router w54g, flashed to the latest firmware. I tried the 2.4/5 /auto no help. I states that I am connected but the icon is grey instead of blue with no data connectivity. Running stock 4.0.2
  12. dawnierae

    dawnierae Well-Known Member

    I had a similar issue, intermittently not being able to connect to wi-fi. I exchanged it after 5 days. That was on Thursday, and I haven't had any problems since.
  13. alostpacket

    alostpacket Over Macho Grande? VIP Member

    I have a 54GL also and mine connects fine - It seems you went through most of the proper troubleshooting- other than rebooting the router (though some mentioned resetting, this should have basically the same effect)

    I'd say for anyone who has done all this, the only other thing to test would be to see if you can get it to connect to some starbucks wifi or something, but it sounds like it might have to be swapped out as dawnierae did.

Share This Page