Go SMS Pro/Handcent SMS/non-stock messaging apps sending problem?

Discussion in 'Android Apps & Games' started by duno, Jan 12, 2012.

  1. duno

    duno Member
    15

    Jan 11, 2012
    13
    0
    15
    Male
    Student
    Malaysia
    Hi all. I am new to Android and this forum, so first of all, I would like to say "Hi there! Please to meet you all." :D

    Recently I have installed Go SMS Pro to replace my stock messaging on HTC Sensation. Everything looks good. :)

    However, I am facing one problem. When trying to send a message to a friend, most of the time the message comes back with a "message failed to send" notification. Yet after a couple of seconds, a toast message comes up saying "message received by (my friend's name)" (I turned on delivery report). She does received the message. After that the problematic message is marked as "sent" (a tick). :thinking:

    It doesn't happen all the time, but it kind of annoys me. Sometimes I thought my message was not sent successfully and tried to resend, but my friend ended up receiving two copies of the same SMS, and also deducting my credit twice. :eek:

    I have tried Handcent SMS, and if I remember right it too has this problem. My stock messaging app works perfectly.

    In all cases, receiving messages is perfectly fine. I doubt it is my network problem.

    Is anyone using Go SMS Pro or any other non-stock messaging apps having the same problem?

    Any help/advice is greatly appreciated. Thank you very much. :)
     

    Advertisement
  2. pool_shark

    pool_shark Well-Known Member
    243

    Aug 21, 2010
    2,488
    541
    243
    Male
    Enterprise Server Engineer
    Ohio
    I use handcent and sending messages works every time.
     
  3. duno

    duno Member
    15

    Jan 11, 2012
    13
    0
    15
    Male
    Student
    Malaysia
    Well, that's good to hear. :)
    I will try to test it for a couple more days. It seems to work pretty fine as of now.
     
  4. Crashdamage

    Crashdamage Well-Known Member
    643

    Feb 25, 2011
    4,451
    2,745
    643
    Mostly retired
    Kansas City, Mo.
    Never had any problem with GoSMSPro.
     
  5. mikeymileos

    mikeymileos Member
    5

    Aug 15, 2010
    5
    0
    5
    I'm having the same problem on a Samsung Galaxy SII HD LTE. Stock app sends SMS fine, Handcent and Go SMS Pro don't.:thinking:

    p.s.

    To the people who just said "It's working fine for me", that doesn't actually help.
     
  6. duno

    duno Member
    15

    Jan 11, 2012
    13
    0
    15
    Male
    Student
    Malaysia
    Lol, true. Those comments didn't really help. :p

    Well for one thing, I am glad I am not the only one with this problem. However, I do not think it is due to network coverage (I am in Australia now). The problem seems to be more rare nowadays though. I guess I will just leave it be. Not that I am looking forward to any solutions after all this time anyway. :rolleyes:
     
  7. Adauth

    Adauth Well-Known Member
    153

    Feb 7, 2011
    1,664
    204
    153
    Male
    Oil and gas industry.
    New Orleans
    Handcent works great for me. Two suggestions. Have you turned off the stock messaging app when using handcent/gosms? Also try uninstalling and reinstalling handcent/gosms.
     
  8. duno

    duno Member
    15

    Jan 11, 2012
    13
    0
    15
    Male
    Student
    Malaysia
    Thank you for your suggestion. :)

    I cannot turn off stock messaging app per se, but I have disabled the notification for it. That unfortunately does not solve the problem, although as I have mentioned, the problem seems to occur lesser now.

    I tried re-installing too. But that did not help either.

    For your information, my phone is not rooted. :)
     
  9. mikeymileos

    mikeymileos Member
    5

    Aug 15, 2010
    5
    0
    5
    Ok, I've figured out the problem. At least on my phone.

    Problem:
    My SIM card didn't have my phone number stored on it, and so the SMS programs didn't know what the outgoing sender number was. When I'd use the stock SMS program, sometimes it would ask me to enter an outgoing phone number as well.

    Solution:
    If you have access to an iPhone, put your SIM in it, and go to Settings > Phone > My Number. Then enter and save your number and when it does that it saves it to the SIM. Put the SIM back in your phone and it should be working now. If you travel, I suggest putting your phone number starting with +614xxxxxxxx

    Cheers,
    Mikey

    p.s. I'm in Australia too. I bought a phone off ebay and it is from Korea.
     
  10. chanchan05

    chanchan05 The Doctor
    Guide
    1,008

    Jun 30, 2011
    14,740
    4,508
    1,008
    Male
    On a Samsung, not sure if this works but: Contacts>Menu>Settings>My Profile>put your number, email add, whatever in there.
     

Share This Page

Loading...