1. In regards to recently combined carrier specific root forums, if your device forum was affected, please see this poll/thread!

Go sms pro private box: not working cause of the +1 area code


  1. veniceboy

    veniceboy Member

    Dear all,

    I am having some big trouble with go sms pro private box. I have the paid version. I added from my contacts all the contacts that I want to be private. It happened that when some of those contacts text me the message and notification are correctly private, while for others they are received in the normal folder (and have a standard notification). I double checked and the contact name and number were correctly displayed on the list of private contacts but the text appears in the normal received text message list. Only one slight difference: the number saved in the contact list is always different from the number on the received text underneath the name, and the difference is related to the international american area code. I was not able to figure out exactly which is the problem but basically sometimes I receive messages with the right name but the number (lets say 999-999-9999) shows up as any of these three

    999-999-9999
    1999-999-9999
    +1999-999-9999

    So basically if I save my number as 999-999-9999 sometimes I dont get it on the private box and it shows up with the rite name and with 1999-999-9999 or +1999-999-9999. Very wierd. And things got more complicated: I did a trial with my roomie: if I save his number as 999-999-9999 his texts do not go into the private box, and they show up with his name and 1-999-999-9999 underneath it. If I save instead my roommate number in my contacts as +1999-999-9999, in that case his text shows correctly up in the private box but with NO NAME on it!! So I cant do this since I have no clue who is texting me and I have to search everytime who that text refers to. I am driving crazy. Nobody had experience with this?
    Thanks
    A.

    Advertisement
  2. Rukbat

    Rukbat Well-Known Member

    Whether the 1 (or +1) shows on incoming calls is determined by the carrier making the call. (And for cellphones that would change if the person making the call is roaming.) Maybe the authors of GoSMS can modify the program to ignore 1 as the first character or +1 as the first 2 characters. (Probably as an option the user can enable or disable.)
  3. mikedt

    mikedt 你好 Guide

    I'm not familiar with "Private Box". I know GO SMS Pro, and I know it doesn't have any problems with country code +86, which is actually where GO comes from. I've found the carrier sometimes appends the country code and sometimes they don't for incoming SMS, same for incoming calls as well, although an SMS app should be able to deal with that. I'd raise it as an issue and contact GO about it. It sounds very much like it's having difficulty with the various US number formats and putting names to the numbers. But AFAIK it doesn't have a problem with Chinese phone numbers..such as..

    landline
    010 xxxxxxxx (Beijing)
    0755 xxxxxxxx (Shenzhen)
    0479 xxxxxxx (Xilinhot)
    +86 10 xxxxxxxx
    +86 755 xxxxxxxx
    +86 479 xxxxxxx
    mobile phone
    150xxxxxxxx
    +86 150xxxxxxxx
  4. veniceboy

    veniceboy Member

    Thanks...the weird thing is that with my Sony Xperia ZL it was working flawless. Then I broke it and I bought a Blu Quattro 4.5, and with the latter it gives me the above mentioned problems. The real wierd thing is that my roommate shows up as 1-999-999-9999 but If I save it in my contacts in that way the message shows up in the private box with no name. And I have no double contacts, I only have google contacts and I merged all the double contacts. I was thinking it could depend on the contact manager, should I maybe install the Sony xperia stock contact manager in my Blu phone? I did a search but I have no clue whats the name of that. Any help appreciated!

Share This Page