Golden Sun Problem - Mercury Lighthouse


  1. RaikoX92

    RaikoX92 New Member

    Dear Forum-users,

    I have been playing Golden Sun fanatically on my PC, but now I thought it was time to move on with my phone as well. So, I downloaded GameBoid and a fresh copy of Golden Sun, and started playing. Everything went well upto the first 'catchable' Mercury Djinni in the first lighthouse. The battle is possible, and after beating him, he should join my party.

    However, after the water drops have ended hitting my head in the cutscene following the battle, the game crashes every single time.

    I hear its a common problem, and there have been 2 suggestions: Leave the Djinni (but I want 'em all!) or try to play further on PC. The transferring to PC doesn't work, or at least I can't get it to work.

    Can anyone help me with this problem? Other threads were inconclusive...

    Kind regards,
    RaikoX92

    Advertisement
  2. okstate707

    okstate707 Member

    Yea, I ran into the same problem, so I skipped that one for now, but it seems to happen on every single Mercury Djinni. I emailed the dev about 3 weeks ago telling him about this glitch and recently, he told me that he had found what was causing the problem, but hadn't found a solution to it yet.

    He should get it fixed soon-ish I would think though. So for now, I have stopped playing the game because I want every Djinni too ;).

    All we can do is wait now..
  3. topmcat

    topmcat New Member

    Ok so I had the same problem. I'm using gameboid and Rom buddy. What I did was save the game, switch MIA to the lead character, remove her mercury djinn, assign them to the main character, and put the mercury djinn on standby. This time, when I defeated the djinn to the right of tolbi, it didnt freeze. I'm not saying you have to do this all exactly this way, but my hunch was that the glitch was coming from the game adding additional mercury djinn to MIA being that she was last in my character order. The game tries to even out djinn as you capture them so I put her first so it would go directly to her and not try to skip over other characters to add it. and I removed them so it would be the only mecury djinn attached to her in case the problem comes from adding multiple mercury djinn. Like I said I don't know if my reasoning is right, but it worked. Finally... now to go try with the other mercury djinn! Hope this helps everyone! Feedback if it does please. J joined this forum just to share. So i wanna know if it works.
  4. okstate707

    okstate707 Member

    Actually, the dev put out an update that fixed the glitch causing the game to crash. So you don't need to do all of that djinni switching and everything, just fight it and it will all work now.
  5. sublimesoccer

    sublimesoccer New Member

    i was using the free version of gameboid playing golden sun and i couldnt get past one of the opening cut scenes. it either froze or restarted itself, do i have to buy the full version for it to work properly?
  6. KonradZuse

    KonradZuse New Member

    I tried it, didn't work. I did standby for the djinn for every test, the firs time I used mercury in battle, the rest I did not. I tried different angles of fighting, but nothing, MIA was my first, main was 2nd, etc. I did this in the Mercury Lighthouse.

Share This Page