Gonna need the pros on this one...General

Last Updated:

  1. thefowlerfam

    thefowlerfam Well-Known Member Contributor

    Ok so I've been having a problem with my 4G the last few months. I have another post on here about that. Yesterday I lost data all together. The 1st thing I noticed was I went to make a phone call and I got a message "if you would like to make a collect call"...I call Metro's customer svc and they had to reprogram the phone. At that point I could make calls but no data. I can't send pic messages, Internet, ect...there's no 1x, 3G icons just the signal bars. In the phone settings my baseband is CDMA : R910.0.4M.EE07 & LTE : SCH-R910.ED15, the mobile network type is CDMA-EvDo rev 0 & the mobile network state will stay on connecting until I toggle the airplane mode, then it will say disconnected. The phone was rooted with basix 1.0 & electric sheep. I Odin the phone back to stock yesterday and it's still the same. No matter what I try I cannot get any sort of data connection. MetroPcs said that from what they can tell the phones data should be working. I'm going to try to update the radios today using Odin & maybe update to 2.2.2 & see if that works. I'm really stumped on this. I'm no pro by any sense but most of the time I'm able to figure it out. Please if anyone has any ideas , or anything I can try to see if I can get the data to work, please post them. MetroPcs is not able to help so you guys are my last hope. I'm very positive I can find a solution with the help of everyone on here. I'm amazed at the amount of info I've learned on here. I want to thank everyone in advance for any and all help....Jeremy

  2. thefowlerfam

    thefowlerfam Well-Known Member Contributor

    Ok well ive updated it to 2.2.2 with the EF06 & EG23, I rooted it again and it still has the EF06 & EG23 and still no data. I was wondering about changing the prl's back to some older ones using qpst, but I cant get my phone to connect to qpst for some reason. I really dont think it would make a difference though seeing how nothing so far has. Could anything in the hidden menus (the dialer codes) cause this?? I was playing around with them when I lost data. I dont think I changed anything, but could have on accident. Maybe the APN or something. Man having no 4G was frustrating enough, but no data at all is driving me insane. I would dance the jig in the middle of the hwy right now just to see that 1X or 3G icon pop up lol. Im still open to try any ideas anyone may have. I know its time for a new phone, but I just had my 4th kid and $$ wont allow it until Jan. or Feb. so if anyone can help me figure this out ill be in your debt....as always thank you, Jeremy
  3. tiede

    tiede Well-Known Member

    which files did you use to get eg06+ef23?
    Have you tried the ultra complete heimdall tar package to reset the device completely to stock?
    No need, of course, to remind you to clear cache+data+dbdata when you're doing this...
    Also, have you tried to force the phone into LTE only mode through **583385## and see if it grabs a hold of the 4G signal in your area? (warning: your phone will not be able to make and/or receive calls or texts while in this mode
    Then use the same shortcut to get it back to normal.
    Also, try checking your current modem API mode using the LTE Functionality Test hidden menu, found using Any/Better Cut, or any program which allows you to create a shortcut to a hidden Activity. Scroll down to API CHECK and ensure it says DATA_TYPE_LTE
    Another thing you can do is make sure you did not disable data through widgetsoid or some other data disabling application (although i doubt the changes they make can persist a ROM flash/factory reset... but who knows, right?)
    Hopefully one of those steps fix your issue. Good luck!
    thefowlerfam likes this.
  4. tiede

    tiede Well-Known Member

    oh, and try this link for the ultracomplete tar.
    (let me know if it's okay. it's a large file, so i wanna make sure it's not corrupted when up/downloading...)
    thefowlerfam likes this.
  5. thefowlerfam

    thefowlerfam Well-Known Member Contributor

    Thank you for replying back to me. I used the download link the was in KOnane's post. At the time I ask you for a link, none of the ones in the posts would work on the computer I was using. I got the link to work on a different computer. I used odin & flashed the phone back to stock & then installed the EG06 tar file. It updated the phone to 2.2.2 w/o root. Still no data. I then reinstalled basix and the phone went back to 2.2.1 but had the updated EG06 & EF23. But still no data. At that point I was ready to give up. I went into the cwm & used the advance restore and flashed just the system of a backup I had. Then I just left the phone. Frustration got the better of me. This morning my data was back, data type was LTE, had 4G (which I haven't had in 3 months)...I did a speed test & was getting 4.8mbs down & 3.1mbs up which was a lot better than before. Needless to say I was very happy. Then my wife makes a call & no more data. Went back to the "Mobile Network Type: CDMA EvDo rev o" & "Mobile Network State: Connecting". The whole time I've been without data this is what its said. Just a few mins ago I was back in root browser going through some sys files. I was deleting the .nomedia files because I read that would let the notification sounds work & I noticed that I had data again. I'm on the phone right now. Sorry for the long post, but I want to make sure I say exactly what I've done so hopefully I can figure out what's going on. I don't want to make a call cause I'm afraid ill lose data again. Anyways that's it so far. I'm going to write down every setting or file I mess with to try & narrow it down. I really appreciate any ideas. Id never be able to figure this out without the help from everyone here. I will post up all progress I have & hopefully if I do find out what's going on with the phone, it will help anyone who may be having this problem...
  6. skrapmetal

    skrapmetal Well-Known Member

    I've gotta hand it to you, this is a whole lot of work to go through to get that old phone working right, especially since its not a high end phone. This may or may not be worth trying out but have you ever experimented with changing the battery? I've seen half bad batteries do some weird things.

Share This Page