Good for Enterprise App keeping Incredible Awake 100%Support


Last Updated:

  1. StaggerLee

    StaggerLee Well-Known Member This Topic's Starter

    Joined:
    May 10, 2010
    Messages:
    112
    Likes Received:
    24
    I think I've found the battery culprit on my wife's new Incredible. We both got new Incredibles and pretty much set them up the same, except she has to use Good for Enterprise to manage her company email/calender. My phone sleeps like it should, but her phone has been awake 100% of the time since she downloaded Good. After a week of trying to figure out what is keeping her phone from sleeping, I think I have found the answer (and developed a mild case of OCD).
    My question is, does anyone know how to set the sync interval for Good? The problem seems to be that it is constantly syncing, which never allows the phone to go to sleep (Up time = Awake time).
     

    Advertisement
  2. michaelkahl

    michaelkahl Well-Known Member

    Joined:
    Oct 20, 2009
    Messages:
    364
    Likes Received:
    95
    I'm not familiar with your application, but I know I had your wife's issue the first day or two. I pulled the battery, rebooted, and never saw the issue again. Maybe worth a try.
     
  3. StaggerLee

    StaggerLee Well-Known Member This Topic's Starter

    Joined:
    May 10, 2010
    Messages:
    112
    Likes Received:
    24
    Tried it several times. I've tried everything I could think of as well as all of the tips and tricks posted. Now it's become a mission for me! The only thing I haven't done was remove the Good for Enterprise App from her phone because she needs a constant connection to her email and her company hasn't provided an alternative to Good.:confused:

    It's nuts...I get a full day (14 hours +) and end up having like 50% battery at night. She's charging twice a day and never getting more than approx 6 hours. Again, her phone hasn't slept since she installed the Good app.
     
  4. kfrazer

    kfrazer Member

    Joined:
    Apr 15, 2010
    Messages:
    8
    Likes Received:
    0
    I am in the same boat. I obsessed over what was preventing my Inc from sleeping, and concluded that it has to be Good. Hopefully others here have experience with Good Enterprise and can help us. I switched from BB so I am learning as I go.
     
  5. eyc

    eyc Well-Known Member

    Joined:
    May 2, 2010
    Messages:
    177
    Likes Received:
    97
    I'm sure you've already tried this, but have you gone into the screen timeout options and simply toggled the timeout to a different amount of seconds? For example, if it is set on 30 seconds, have you tried changing it to 15 seconds and then backing out to the main homepage?

    I had the same issue after setting up HTC's ActiveSync. Battery pulls made no difference. But, simply changing to 15 seconds, letting it time out, then switching it back to 30 seconds did the trick.
     
  6. Darthkim

    Darthkim Member

    Joined:
    May 11, 2010
    Messages:
    9
    Likes Received:
    0
    There isn't a sync interval for GFE, since its designed to be connected at all times.

    How are you determing that GFE is keeping the Inc "awake"?

    I'm running GFE and can push it to 12 hours (about 20% left). I'm on day 5 from acquiring my Inc.
     
  7. kfrazer

    kfrazer Member

    Joined:
    Apr 15, 2010
    Messages:
    8
    Likes Received:
    0
    Go to settings, about, battery and you'll see awake time and up time. Mine times are the same. Always have been since I installed GFE.
     
  8. kwatz

    kwatz New Member

    Joined:
    May 11, 2010
    Messages:
    1
    Likes Received:
    0
    I am seeing the same issue, although I can say that While Good is one app that causes the problem, it doesn't look to be the only one.

    I did a factory reset, installed all my other apps and enabled none of the social meda features during setup, just sync with GMail. Everything was working fine for 2 days.

    I then went back through setup and enabled sync with Facebook for HTC, phone would not go to sleep.

    Disabled Facebook and it was back to what I would call expected usage for a day or so.

    Installed Good, and again the phone would not sleep.

    Removed Good, back to expected usage.

    IMO - this Looks to be more of an issue with how auto-sync accounts are handled on the Incredible as opposed to an issue with any 1 particular app.

    I opened a case with HTC through their site/webform, but haven't received a response as of yet.
     
  9. Darthkim

    Darthkim Member

    Joined:
    May 11, 2010
    Messages:
    9
    Likes Received:
    0
    I see. Mine times are also the same and I'm able to get about 12 hours out of my phone.

    The only sync process that I have are GFE and Gmail. For twitter and Facebook, I use the actual app, rather than use the HTC integration.

    Though the HTC Inc is "officially" supported on GFE, there are numerous bugs (particularly with the HTC branded apps) that they are working to resolve. I'm hoping 1.4 will address a variety of issues.

    Hope this helps.
     
  10. StaggerLee

    StaggerLee Well-Known Member This Topic's Starter

    Joined:
    May 10, 2010
    Messages:
    112
    Likes Received:
    24
    Same here. I haven't had time to sign up yet, but GFE has a forum on their website where people are posting about this. You can see previews of their posts (one of which is Battery Drain), but cannot access the forum until you sign up. Apparently there are others with this issue.
     
  11. Darthkim

    Darthkim Member

    Joined:
    May 11, 2010
    Messages:
    9
    Likes Received:
    0
    Yup, the site is be.good.com. I'm familiar with this issue, having been running and managing GMM for 5 years now.

    Good has historically had an impact on various battery life. Blackberry rules in this area and there is no other push technology that is as efficient as BB.

    Keep bugging your IT group and have them work with their Good Account managers to get this to the right people.
     
  12. Iria

    Iria Member

    Joined:
    May 19, 2010
    Messages:
    12
    Likes Received:
    1
    [FONT=&quot]On the Incredible, you have to type *#*#4636#*#* to see a detailed view of the battery usage. Just as on other Android devices it looks like Good is using 2-3 percent.[/FONT]
     
    FlyPenFly likes this.
  13. kyle1745

    kyle1745 Well-Known Member

    Joined:
    Feb 12, 2010
    Messages:
    118
    Likes Received:
    3
    Any updates from GOOD? I have sent feedback about the issue as I am noticing it as well.
     
  14. jhyman

    jhyman Member

    Joined:
    Jun 28, 2010
    Messages:
    6
    Likes Received:
    0
    The issue is currently being discussed on Good's Android group. Looks like Good is aware of the problem and working on a solution.
     
  15. kyle1745

    kyle1745 Well-Known Member

    Joined:
    Feb 12, 2010
    Messages:
    118
    Likes Received:
    3
    Any ETA? 6 hour of battery is not fun. I have to wait for my account to be approved on begood.

    It would be nice if they expanded their syn options to allow something like:
    Manual
    1 hour
    2 hour
    4 hour
    8 hour
    12 hour
    day
     
  16. Flavy

    Flavy Active Member

    Joined:
    May 10, 2010
    Messages:
    27
    Likes Received:
    1
    It is an issue with good. Download spare parts app and check your partial awake lock. You'll notice that good doesn't let your phone go to sleep. I'm having the same issue with my phone.
     
  17. jhyman

    jhyman Member

    Joined:
    Jun 28, 2010
    Messages:
    6
    Likes Received:
    0
    For what it's worth, with Good running, I'm getting between 14 - 16 hours of battery life. I unplug at 7 am, and get to between 9 and 11 pm at night, which is perfectly acceptable. I'm also using the Seidio 1750mAh battery, which has made a hugh difference for me.
     
  18. kyle1745

    kyle1745 Well-Known Member

    Joined:
    Feb 12, 2010
    Messages:
    118
    Likes Received:
    3
    I was getting roughly over a day on my Seidio 1750mAh before good, and now its down to 6-8 hours. If I remove GOOD it goes right back to normal.

    On the battery information screen you can prove it does not allow the phone to sleep as the up time and awake time match. After removing GOOD awake shows accurate usage.

    I have even tested with the GOOD in offline mod and it still does not allow the phone to sleep.
     

Share This Page

Loading...