1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

Google calendar disappeared


  1. Pattie

    Pattie Active Member

    Help! My google calendar disappeared from my phone. The only calendar that is syncing is the Jewish Holidays calendar. Mine, my husbands, holidays not appearing on the phone. Tried adjusting settings, etc, will not sync. Complete calendar still appears online. Calendar was working fine until about two hours ago.

    Saw this in another thread: "Well, I saved the calendar from Google, deleted it on Google, then reimported back to my Google account, and whala, it showed up with all the appointments intact. Kind of a roundabout way to get the calendar back but it worked."

    What does "saved the calendar from Google" and "deleted it on Google" mean? I have no idea how to do any of that. Can anyone help? I'm lost without my calendar and reminders on my phone!

    Thanks,
    Pattie

    Advertisement
  2. doogald

    doogald Guides Guide


    Edit, January 28, 2014: Please note that the following procedure is only if you are syncing your Calendar with your Google calendar account. If you are not syncing your calendar, and have calendar events stored only on the phone, DO NOT DO THE FOLLOWING PROCEDURE. If you do, you will lose all of your calendar events.

    original post

    Try this:

    From home:

    - settings->accounts & sync. Tap on your Google account and uncheck the calendar sync. Back out to:

    - settings->applications->manage applications. Wait for the list to refresh, then tap on "Calendar Storage" (that may be easier to find if you press menu->sort by size and then menu->sort a-z.) For people running Sense on Android 2.1, note that this is "calendar storage" and not "calendar" (there is one of those, too.)

    - In "Calendar Storage", tap on "clear data".

    - back to settings->accounts & sync. Tap on the Google account and re-check Calendar syncing.

    You can then go back home. This will cause background sync services to repopulate all of your calendar data. Wait for the sync to finish (you should see an icon that looks something like a circle in the status bar, near the signal strength meter). When the sync is complete, hopefully all of your calendars will be repopulated.

    Google discovered a problem with security with calendar and contact data and they said that they were patching it, and I wonder if that's what caused this problem (because others have reported the same)? See Google is patching the Android security hole | ZDNet for more info about that security issue.

    Anyway, let us know if this procedure works.


    [EDIT] - I am adding this info from post #27 below, because this started happening to me yesterday as well. And, to recap the problem, what seems to be happening is that the events on your primary Google calendar are not showing up in the Calendar app in your phone if you are running, in particular, the stock Eris software, though this appears to be affecting other 2.1 based phones and some of the rooted custom ROMs for the Eris that are also close to stock. However, any other calendars that you create in your Google Calendar account - you can have many, not just the primary calendar for your account - and any subscribed calendars do not have this particular issue. So, the solution I post below will walk you through exporting your current calendar from Google Calendar, creating a new secondary calendar, importing the events from your old primary calendar, and the deleting the events from your primary calendar - to avoid duplication when you look at your Google Calendar on the web - in a few simple steps.


    BobW, alan_s, Baccha and 3 others like this.
  3. TeaArra

    TeaArra Member

    The same thing happened to me today and I spent several hours trying all kinds of things and going nuts. Thanks, Doogald, for the solution! You are always there to help everyone out. I've learned so much from you and others on this forum and especially appreciate the rooting information and encouragement.
  4. Pattie

    Pattie Active Member

    Thank you so much! It worked perfectly! I was nervous because there were many older posts with no solutions.

    I agree, it must be that patch, it makes sense and it's too much of a coincidence that such a thing would happen to so many people in one day.

    Whew, I'm so relieved.
    :)
  5. prosan98

    prosan98 Active Member

    In case anyone using a Motorola Cliq finds this, after I hit Clear Data in Calendar Storage, nothing happened. I had to go to Menu> Settings> Google Synchronization, uncheck Auto-sync, manually sync the calendar, then re-check auto-sync, and it FINALLY started working again. What a frustrating few days!
    alan_s likes this.
  6. doogald

    doogald Guides Guide

    I actually added a couple of steps to my post above which should fix that. Thanks for pointing that out. It's generally not needed for the Eris, but it doesn't hurt to do those extra two steps.
  7. dnettles

    dnettles New Member

    I'm relieved this problem isn't just with my phone!

    doogald, I used your steps and was able to retrieve 10 work related shared calendars... but still have no luck retrieving the events on my own personal calendar after 5 or 6 attempts.
    fotroofgrl likes this.
  8. MiddleAged

    MiddleAged New Member

    THANK YOU, THANK YOU, THANK YOU!!!! Such a life saver . . . . . should have checked here first before I wasted a couple of hours trying to fix it myself!!
  9. doogald

    doogald Guides Guide

    Hmm, not sure what's next. The extreme thing to do is to export your calendars (in Google Calendar - settings->calendars->export calendars), delete all of them that are under "My calendars", and then import them back in. But, again, that's extreme.

    I suppose first you could uncheck your calendar from the list of calendars in the settings for the calendar app, restart the phone, put the check back for your personal calendar again and see if the events repopulate.

    As I said, I never had the issue with my calendars for a long, long time (this happened to me once last fall, I think), but this is the typical fix procedure. Best of luck.
  10. 172driver

    172driver Well-Known Member

    Not working for me either. I've followed the steps above three separate times.

    I've now added the additional step of a reboot and after the Eris starts up again the events in question do show up on my calendar until auto-syncing is enabled (box ckecked under Google account). When it syncs, the calendar events are removed, leaving only the weather forecasts.

    Doh!
  11. (G)

    (G) Well-Known Member

    This happened to my wife's Eris today. After fooling around with it for an hour, I figured out that if I get on Google Calendar via her desktop, then double-click an event and change it from "Default" to "PRIVATE" it will show up in her Eris's calendar during the next sync.

    I haven't tried the fix mentioned above (just discovered it), so hopefully that'll work for her.
    doogald likes this.
  12. doogald

    doogald Guides Guide

    Good info. Thanks.
  13. 172driver

    172driver Well-Known Member

    Confirmed. I did a test on a couple calendar events. After changing their security setting from 'default' to 'private' they do appear after the next sync or sooner if the calendar is refreshed.

    This is bittersweet because the prospect of having to go through all my calendar events and manually changing each one is daunting.

    Anybody know a way of doing this globally?

    Also, why the heck should this be necessary at all?

    And what changed to cause this problem; shouldn't all the calendar events show up on the Eris regardless of whether their individual setting is 'default' or 'private' or 'public'?

    Frustrating.
  14. gone down sout

    gone down sout Well-Known Member

    Doing a quick search through the recent posts, this looks like a pretty widespread problem. I'm still stumped.
  15. jcsgsheesley

    jcsgsheesley Member

    I too tried the above fix on my Eris with no success. Changing some of the events to private seems to work, but a global change would be helpful! Also, it seems like NEW events that I add will show up, but none of the existing ones.

    Others in my office with fascinate and incredible are not having this problem.

    Setting all calendar items to private is also not helpful when you use shared calendars.

    Anyone else have a solution??

    ***for lack of a faster solution, I used google sync, dumped my calendar onto my outlook, deleted it in google, then uploaded it back to google, and then it showed up on my phone. Any new events I added to the calendar would sync, that's why I tried this.

    Really curious to know why it only happened to the Eris. Can't wait to get rid of it!
  16. jimmydahead

    jimmydahead New Member

    This must be an Eris issue big time... same issue happened with my phone and my wife's literally about a day apart (both have HTC Eris). I spent over 45 minutes on the phone with Verizon yesterday...their solution.. send out a replacement.

    I did go through the steps above of unchecking, clearing data, etc... and it seemed to work...fingers are crossed though.

    Jimmy
  17. KennyB07

    KennyB07 New Member

    I have a galaxy s Fascinate with Verizon. This problem showed up for me yesterday. Followed the step listed above and nothing happened. Then I did it again, but rebooted phone before clicking the sync button, then I had all my info back. What sucks though, it only lasted for about 30 minutes and all dissappeared again. This is aggrivating.
  18. 172driver

    172driver Well-Known Member

    The default-to-private fix only gives temporary relief for me. It seems I have to keep canlendar sync turned off too.

    This stinks!

    I've resorted to viewing my calendar (on the phone) with the browser, via Google Mobile Products.

    If Google doesn't do something about this, none of my calendar apps will work until I change phones (hopefully in the fall).

    It's gonna be a long summer...

    --FR
  19. alan_s

    alan_s Member

    Hi all

    I too have this problem (SE Xperia X10 phone, in the UK). I have tried clearing data without success. I created an event on my phone which went to the calendar (which is intact when viewing from the web), and created an event on the web which did get to my phone. The idea of changing from default to private I suspect works just because you've edited the event and the phone knows to re-download it, I am sure the same results can be achieved just by editing the title (add a full-stop or something).

    I do need a way to download the whole calendar again. I tried going into accounts and sync, and delete the account to add it again, but my phone wouldn't let me delete it, saying the only way I could would be to do a factory reset. That seems rather extreme.

    Hopefully if this is a problem recently introduced by google, it will get fixed. But for now my calendar is useless!! (like the OP, it still has entries in from the UK Holidays calendar; and a couple of events that I've added or tweaked today)

    Alan
  20. bberryhill0

    bberryhill0 Well-Known Member

    No luck here. I can get moon phases, which I don't want, but not my calendar. :(
  21. (G)

    (G) Well-Known Member

    My wife is ready to toss her Eris in the trash, and I don't blame her.

    Whatever happened didn't affect my Droid 1, but I don't get why it's unique to Erises.
  22. alan_s

    alan_s Member

    It's not only Eris - as I said I am having exactly the same problem with xperia x10. I have not managed to re-download my events but have confirmed any edit on the web will force an event to appear on the phone. I have too many to go through manually. I'm hoping that a fix is forthcoming from Google as Doing a factory reset on my phone, or deleting all entries and reloading them seems rather extreme.

    Alan
  23. 172driver

    172driver Well-Known Member

    It's even weirder than that.

    Not only is it more models than just the Eris, but not 'every' Eris is affected; my wife's Eris is fine. Mine is the one which won't show calendar events.

    Go figure.

    :mad:
  24. KennyB07

    KennyB07 New Member

    If I keep my sync button, unchecked, the whole calander shows up and stays. Once I check the sync button, it dissapears again. For now until they have a fix, I am going to just do these steps once a day to get my currrent dates on my phone.
  25. bberryhill0

    bberryhill0 Well-Known Member

    Since we aren't finding any solutions I thought I might mention that I grew up in Wayzata and my parents still live there.

Share This Page