Google Calendar won't sync since 2.1General


Last Updated:

  1. JoeyH

    JoeyH New Member This Topic's Starter

    Joined:
    May 18, 2010
    Messages:
    2
    Likes Received:
    0
    Since the firmware update, my calendar won't successfully sync. In "settings>accounts and sync>google" the calendar line shows a constantly spinning sync icon. Contacts and gmail sync to the same account just fine.
     

    Advertisement
  2. JoeyH

    JoeyH New Member This Topic's Starter

    Joined:
    May 18, 2010
    Messages:
    2
    Likes Received:
    0
    Found this fix suggested by hondamec on another thread. It worked (except that it's now called "calendar storage":


    1. Go to Settings -> Data Synchronization -> Google and uncheck Calender

    2. Go to Settings -> Applications -> Manage Applications and find
    com.android.providers.calender & Calender, go into both and clear the data.

    3. Go back to Data Synchronization settings and check Calender again.

    It should sync this time without crashing, and you should see all of your calenders with complete data.

    Hope this helps
     

Share This Page

Loading...