Google Chrome browserGeneral


  1. keithscarfe

    keithscarfe Member

    Thought I would give the Chrome browser a try but it says incompatible with this phone. Is this for real or is there something wrong with my phone / set up. I would have thought it would work on any device.
    Ta.

    Advertisement
    :
  2. Weary

    Weary New Member

    You need v4.0 (ICS) loaded to run chrome......
  3. olbriar

    olbriar Moderator Moderator

    Hello Weary and welcome to Android Forums. Thanks for joining and adding to the help force here. Great to have you a part of the community.
Loading...

Share This Page