Google Contacts? Where my .cvs go?


Last Updated:

  1. Terminator87

    Terminator87 Member This Topic's Starter

    Joined:
    May 15, 2010
    Messages:
    5
    Likes Received:
    0
    I got to a thread on this forum through Google and decided that I should put all my contacts on Google (Gmail Contacts). I selected Import/Export > Export to SD > Google and then it asked to make a .cvs file. All cool with that, the file is on my SD I suppose. Couple questions now:

    1. How do I even check what's on my SD? Haven't found this very basic function yet.

    2. Now that I have my contacts in .cvs how will I get them to Google/Gmail? Haven't figured this out so nothing has changed for me, I want my phonenumbers (that are on phone right now!) synced with people in my Gmail and load those on my phone.

    Thanks for any help in advance!
     

    Advertisement
  2. Si Pie

    Si Pie Well-Known Member

    Joined:
    Apr 24, 2010
    Messages:
    189
    Likes Received:
    23
    Are your contacts stored on the phone or sim? You need to select phone or sim and not Google when exporting, depending on where the contactsare currently stored
     
  3. Terminator87

    Terminator87 Member This Topic's Starter

    Joined:
    May 15, 2010
    Messages:
    5
    Likes Received:
    0
    I have contacts on my phone and on my SIM. I selected to export (from phone I guess) to Google 'cause then it creates a .csv on the SD card and I thought that's what I read on this forum to do. lol

    I mean I got all my stuff on my phone, now I wanna get all those numbers in my Gmail. :)
     
  4. Si Pie

    Si Pie Well-Known Member

    Joined:
    Apr 24, 2010
    Messages:
    189
    Likes Received:
    23
    Follow my steps below. You shouldn't be selecting google at the export stage because your contacts are not the google type! The phone doesn't make a csv file, it just stores them on the SD card automatically in my case.

    Follow my steps below, I had the exact same problem and fixed it by doing this.


    To export your contacts to the SD card

    Go to people then select menu>import/export>export to SD card>select phone account.
    Then do exactly the same and select sim account.


    This has backed up all of your contacts from your phone/sim onto the SD card.

    To import the contacts into your google account

    In people you need to then select menu>import/export>import from SD card and greate account under your google account.

    In the home screen select menu>settings>accounts and sync and sync your google account.

    To delete/stop showing duplicate contacts

    Your phone will now hold duplicate contacts, because it has stored the contacts on both the phone and in google. You have two options - stop the phone showing the phone contacts, or remove them from the phone. The first option is easiest and is all you need to do:

    I people select menu>view. Untick 'phone' and 'sim' accounts, make sure 'google' account is ticked. Then select 'done'.
     
    Terminator87 likes this.
  5. Terminator87

    Terminator87 Member This Topic's Starter

    Joined:
    May 15, 2010
    Messages:
    5
    Likes Received:
    0
    Okay nice! One problem: when I go to PHONE now it just shows the contacts that are on phone and SIM, changing the Contacts view to Google contacts does not have any influence on the PHONE list. This is so weird.

    I did hear it's an Android thing and there's no way around this?
     
  6. Si Pie

    Si Pie Well-Known Member

    Joined:
    Apr 24, 2010
    Messages:
    189
    Likes Received:
    23
    Ok I didn't know that, seems you will have to delete the phone/sim contacts. Don't worry, this is easy to do whilst still keeping your google contacts undeleted. I only have google contacts in my phone and in the 'Phone' menu all of these show.

    Go to people>view and untick 'google' and tick both 'phone' and 'sim'

    Then in people select menu>delete>menu>select all>delete.

    Back in people select menu>view>tick 'google' and confirm that there are 0 phone and 0 sim contacts.


    If something goes wrong and everything is wiped don't panic - the contacts are still saved on your SD card and you can import from SD again and all will be well :)
     
  7. Terminator87

    Terminator87 Member This Topic's Starter

    Joined:
    May 15, 2010
    Messages:
    5
    Likes Received:
    0
    Got it. Deleted contacts from SIM and phone and now some Google contacts show up in PHONE but not all lol. Seems there's a problem syncing with Google (that's the error when I look at sync) so I guess I'll have to wait and see if it works. I'll keep you posted or come back if it's not working. :)
     
  8. Si Pie

    Si Pie Well-Known Member

    Joined:
    Apr 24, 2010
    Messages:
    189
    Likes Received:
    23
    Have you logged into Gmail and made sure all of your contacts are in the 'my contacts' group?
     
  9. Terminator87

    Terminator87 Member This Topic's Starter

    Joined:
    May 15, 2010
    Messages:
    5
    Likes Received:
    0
    Yep, now I get it to sync but when I press 'Phone' on the very first menu it doesn't show any contacts. It only shows contacts when I go to Menu > People > and there they are. How can I solve this?

    It's starting to bug me a bit, maybe I'll put my Phone contacts back as they DO show up. :(

    EDIT: I think I know why they don't show, something went wrong and all NUMBERS are deleted now from my contacts. So I will go back to my backup and re-do all your steps and see what happens.

    EDIT 2: Yes I was correct, got it ALL working now thanks to you! One last question, if I edit contacts on my phone will they also be edited (or deleted for example) from Google?
     
  10. Si Pie

    Si Pie Well-Known Member

    Joined:
    Apr 24, 2010
    Messages:
    189
    Likes Received:
    23
    Yep they will be. Glad you sorted it!
     
    Terminator87 likes this.

Share This Page

Loading...