Google Earth


Last Updated:

  1. mwl1119

    mwl1119 Well-Known Member This Topic's Starter

    Joined:
    May 21, 2010
    Messages:
    880
    Likes Received:
    82
    Why can I not install Google Earth on my Slide?

    If it can be ran on the 550MHz Droid with 2.1 why not my 600MHz Slide?
     

    Advertisement
  2. behold_this

    behold_this Well-Known Member

    Joined:
    Nov 18, 2009
    Messages:
    1,419
    Likes Received:
    243
    have you tried manually installing the apk? I have it stored on my pc but never tried to install it to my slide because its just too damn big for an app i'll almost never use.
     
  3. RavenWulf

    RavenWulf Well-Known Member

    Joined:
    Apr 15, 2010
    Messages:
    173
    Likes Received:
    28
    I tried the manual install and every time I tried to open it the screen would go black for a few seconds and then go back to the Home screen
     
  4. behold_this

    behold_this Well-Known Member

    Joined:
    Nov 18, 2009
    Messages:
    1,419
    Likes Received:
    243
    Yeah i kinda figured it was disabled or it'd show up in the market like it does on devices it is actually compatable with. Plus I stand by my statement it is way too big (7MB app plus tons more MB used up with data storage) for an ultimately useless app...just eye candy IMHO
     
  5. RavenWulf

    RavenWulf Well-Known Member

    Joined:
    Apr 15, 2010
    Messages:
    173
    Likes Received:
    28
    yeah it was way too effin huge the 7MB was before instal,l after install it ends up being over 20MB and that's without even connecting and adding even more
     
  6. azav8ter

    azav8ter Member

    Joined:
    Jun 27, 2010
    Messages:
    15
    Likes Received:
    0
    Google Earth wont be usable until we get 2.2 There is something missing in the software of the MTS that will prevent it from working....at least thats what CS says..
     
  7. RavenWulf

    RavenWulf Well-Known Member

    Joined:
    Apr 15, 2010
    Messages:
    173
    Likes Received:
    28
    I doubt we'll even get it then, I am running 2.2 and am over-clocked to 844MHz and it still won't run... it's because it's meant for ARM7 CPU and above compared to our ARM6 CPU.

    edit : here is a link to the requirements page http://earth.google.com/support/bin/answer.py?hl=en&answer=174898
     
  8. penguin42

    penguin42 Member

    Joined:
    Jun 23, 2010
    Messages:
    12
    Likes Received:
    0
    Yeah, Google Earth requires a Cortex processor, which for some reason they skimped out on with the mts (even though the droid, nexus one, etc had one)
     

Share This Page

Loading...