Google Images no longer workingSupport


  1. J S Machine

    J S Machine Well-Known Member

    I regularly use google images throughout the day, especially at work. All the sudden, I can't get them to work. I can go to google, search for something...tap the images tab up top..then the thumbnails come up..When I tap a thumbnail to enlarge it, and possibly save the picture, I can't do it. It will not enlarge, and the screen will not change pages either. If I try to go to the images page two, nothing happens.

    What is going on here? I called Verizon, they don't seem to know.

    My X is not rooted and running 2.3.4, system version 4.5.621

    Browsing history has been cleared and cache has been cleared..I don't know what else to try.

    Advertisement
  2. ylexot

    ylexot Well-Known Member

    Have you tried a different browser?
  3. J S Machine

    J S Machine Well-Known Member

    I have but just not sure which one would be best. I tried dolphin for a short bit, but I didn't care for it. Any recommendations?
  4. thegamper

    thegamper New Member

    Wierd, I am experiencing the exact same problem as of today. Yesterday is all good. I downloaded an app yesterday which I uninstalled. I then pulled battery. Still no dice.

    Help anyone? I am on Droid X2
  5. ylexot

    ylexot Well-Known Member

    I like Boat browser.
  6. IMADJHO

    IMADJHO New Member

    ....and I have the Razr Maxx. Just noticed the problem today. Can look at pics if you change Google view to Classic mode instead of Mobile but the results are not as good, quick, or convenient. Would this be Google problem or an Android problem?
  7. kaiser1888

    kaiser1888 New Member

    Mine stopped working too! Razr
  8. atrios

    atrios New Member

    Started yesterday 5/6/12. I use images daily at work and I'm lost without this capability. Seems like it's all Motorola phones. I have cleared cache, cleared stored data, rebooted phone...nothing. No links or swipe functions work on Google Images.
  9. codster1194

    codster1194 New Member

    Its not just Motorola, my HTC Thunderbolt is giving the same problem which led me to his forum.
  10. teddyastuffed

    teddyastuffed New Member

    Lol same here!!! Was trying to show my girl pics of vacation resort spot, no go on HTC thunderbolt rooted using GBR 3.3 stock kernel -_- I thought it was a Rom issue till i saw this page. Hopefully google fixes soon :D
  11. J S Machine

    J S Machine Well-Known Member

    Don't know what the deal is but mine is still doing this. Glad to know it is really an issue and not just my phone. Talked on the phone with a tech from VZW yesterday for about twenty minutes. His razr was not doing it (of course), but he said he didnt know what the problem was. Said that he checked their internal tech forums (I'm guessing the public doesn't have access to) and said he didn't see anything there either.

    :(
  12. PooPooPeePee

    PooPooPeePee New Member

    I just fixed this, literally by using voice search and saying "google images should ****in' work"

    And, it did.


    This is 100% true, but before I said that I closed all the different browser windows that were open. I didn't even know it had multiple windows open. I don't see why this would affect a website like Google Images, but it makes more sense than literally yelling at it to work.

    Pretty obnoxious. I've been looking like an idiot in front of groups of people lately because I'm trying to bring up images to show my audience, and I'm pressing the thumbnails on my screen like a jackass, trying to show them that it really won't work and it's not just me being an idiot.

    So, try yelling and/or closing extra windows.

    Oh, and I have an HTC Sensation, not a Droid.
  13. robbyfreddy

    robbyfreddy New Member

    Hey guys. I was having same problem and tried everything. I couldnt enlarge thumbnails or change pages. I figured it out and hope this helps. I had too many bookmarks saved. So i went into my bookmarks and started deleting some of them. And bam....images now working normal. Hope this helps!
  14. robbyfreddy

    robbyfreddy New Member

    Nevermind! It worked for a minute! What a bunch of Crap!!
  15. oclost

    oclost New Member

    Brand new Samsung Galaxy S2 Skyrocket worked awesome for a week now google images won't work. Tried a different browser, and my girls exact same phone. Same problem. First image page loads then you cannot click on one, or go to the next page. Problem started sometime last night or this morning. Google search works fine, just images is broken. Amazon says they will send me new phones, but I don't necessarily think its the phones. I see others posting with this issue on Verizon so that rules out ATT being the problem. So now what?
  16. logforney

    logforney New Member

    HTC Thunderbolt doing the same thing, same time frame. That's why I'm here.
  17. Beeradgee

    Beeradgee New Member

    Hmmmm im having the same issue on a moto droid razr maxx. And my iphone and droid bionic. I wonder if google knows anything about it. Mine didnt start doing this until the last OTA update on my 2 droids. Not sure when it started with the iphone (which is not used daily). Kind of messes me up I dl tons of pics from google. Ohh well :(
  18. Arnan540

    Arnan540 New Member

    Here's a solution that has worked for me. locate any apps like skype or photo upload software and uninstall them. And taadaaaa worked on two phones for me. Try it and let me know if I' ve helped ya.
  19. thegamper

    thegamper New Member

    Well, I had issues the first day I posted on forum and happened at least once the second day but havent had a problem since. I have not intentionally done anyting to resolve the issue, just resolved itself I guess. Still annoying. Hopefully its just some sort of google glitch that gets worked out. Droid X2
  20. atrios

    atrios New Member

    Mine is working again. It's worked fine for two days now. Nothing I did would get it to work. It has just been stopping and starting whenever it wants. We're at the mercy of Google on this one.

    As a side note, I checked my iTouch, iPhone, and Acer tablet and all worked ok. For it I've only had problems on my Motorola Atrix.
  21. Akashdeep Singh

    Akashdeep Singh New Member

    Android Browser Not Showing Google Images? Solved!:

Share This Page