Google Maps and GPS Navigation Issues!!!Support


Last Updated:

  1. Itlooksfast

    Itlooksfast Well-Known Member This Topic's Starter

    Joined:
    Apr 25, 2010
    Messages:
    99
    Likes Received:
    3
    Ok I rooted my phone with Unrevoked3 the Unrevoked Forever. I used my GPS and Navigation to a friends house. It worked great! Then I flashed to the OTA official ROM. Didnt change any setting. My GPS is set on. Under the "LOCATION" setting..everything is checked.

    Now I can go to Google Maps and then get my location and then search and stuff. I can even get direction to places. However, when I hit NAVIGATE...all I get is "SEARCHING FOR GPS..." And it would be stuck at the screen for the longest time without going into the Turn-by-turn direction. I turned off my GPS and turned it backed on again...NOTHING! I just adjust the setting...nothing. I even factory reset the phone and getting the same message when I use the navigation feature.

    I also notice that the GPS location is not accurate at all...a lot worst than before. This is very annoying since I can use my turn by turn direction. I tried uninstall but the phone wouldnt let me. Since im rooted is there anything I can do?
     

    Advertisement
  2. gonzoguy24

    gonzoguy24 Well-Known Member

    Joined:
    Nov 11, 2009
    Messages:
    1,104
    Likes Received:
    41
    Try clearing data/cache from your maps app...if this does not help then reflash a new ROM maybe?
     
  3. kmoore11

    kmoore11 Well-Known Member

    Joined:
    Dec 29, 2009
    Messages:
    272
    Likes Received:
    83
    I am having the exact same problem... I am rooted with Virtuous 2.6. I had these problems with SR 3.1, did a factory reset, reinstalled SR 3.1 and still had the problems. I thought it was a SR thing, so I put Virtuous on, and am still having these problems.

    Some people have recommended going to settings > applications > development > make sure allow mock locations is unchecked. Maybe that will work for you, but it didn't for me.
     

Share This Page

Loading...