1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Google Maps Navigation disappeared off my phone!Support


  1. zerozed

    zerozed Active Member

    I performed a hard-reset on my phone this evening, and I just noticed that the Google Maps Navigator program is now missing off my phone. This is a different program than Google Maps (it's far more useful for navigation purposes).

    My Evo isn't rooted or anything. I can't even find the program in the Android Marketplace now. The link from the google site now goes to Google Maps.

    Any ideas????

    Advertisement
    :
  2. acuracing

    acuracing Well-Known Member

    Update your Google Maps app and it should place the Navigation app back.
  3. chrismmm

    chrismmm Well-Known Member

    take a look at all apps page.if its not there go to market and reload it. good luck sir
  4. zerozed

    zerozed Active Member

    Here's a link to the google page with the app I'm looking for..note the icon for the app in the upper left-hand corner of the page.
    LINK TO GOOGLE NAVIGATION

    I cannot find that app in the marketplace. It's not the same app as Google Maps, which lacks the advanced navigation functions.

    I did update the Google Maps I have, but it doesn't change the functionality at all. Any more ideas? I wonder what happened to it? Thanks for any help you guys can offer!
  5. zerozed

    zerozed Active Member

    The issue got fixed, and I figured I'd let you guys know how. First off, the Sprint technical support was horrible. I spoke with 2 different women (both supposedly on 2nd tier CS). The first didn't seem to know anything about the Evo. The 2nd lady who identified herself as a supervisor didn't seem to have a clue either. She was insistent that the Google Maps program was the same interface as the Google Maps Navigation (it absolutely does not).

    Searching a myriad of forums, I finally came across an old thread on Google's developers website where an individual person stated he had the same problem as I did. He described having to reboot his phone a few times and the icon just automagically reappeared. I tried this and it worked. The icon reappeared along with the functionality.

    I should point out that I had done multiple hard-resets of the phone by this point--I have no idea why power cycling the phone would cause a program to reappear, but it did.
  6. kdemar

    kdemar New Member

    I had the same problem after Sprint tech support told me to factory reset my phone, however I did the following and Google Maps Navigation returned.
    1. updated google maps

    2. access google maps and attempted to find a location, it gave me the option to navigate, so I clicked.

    3. I accepted the terms of service. (still no app icon by the way)

    4. I closed the app after accepting the TOS, then power cycled the phone twice. Icon was present after the second power cycle.

    I hope this is helpful to someone out there.
  7. bronzedone

    bronzedone New Member

    I discovered that you have to uninstall updates to get it back to the blue arrow icon... mine disappeared when I updated...and nothing else worked , and, the crap I tried to replace it with was just that... Hope this helps.:rolleyes:
Loading...

Share This Page