Google Maps Navigation Now working in Canada!!! 1.6 and up.


Last Updated:

  1. TriC

    TriC Well-Known Member This Topic's Starter

    Joined:
    Jun 13, 2009
    Messages:
    175
    Likes Received:
    2
    Google Maps Navigation Now working in Canada!!! For Android 1.6 and up... . no more need for a hacked version.

    Thank you GOOGLE!
     

    Advertisement
  2. Silvertag

    Silvertag Well-Known Member

    Joined:
    Dec 16, 2009
    Messages:
    189
    Likes Received:
    19
  3. vikingisson

    vikingisson Well-Known Member

    Joined:
    Nov 13, 2009
    Messages:
    856
    Likes Received:
    24
    I noticed it by chance today. I rarely need it so had removed the hacked version so I could more easily stay up to date. After 6 hours of driving I opened maps for the last part of the drive and was surprised to see the navigation option. It worked perfectly which surprised me. The French pronunciation was funny but good enough to get me I was going. Even accurately gave directions around the big traffic circle.
    :)
    oh, poor 1.5 users. :eek:
     
  4. nicracine

    nicracine Well-Known Member

    Joined:
    Nov 29, 2009
    Messages:
    201
    Likes Received:
    7
    Is it already included in CM 5.0.7? Market does not offer me the upgrade, and I am able to see turn-by-turn directions, but I get a warning that it's still a beta version.
     
  5. GreatBigDog

    GreatBigDog Well-Known Member

    Joined:
    Dec 3, 2009
    Messages:
    495
    Likes Received:
    46
    The ability for turn-by-turn navigation was included in the last update of google maps to 4.2 from the market. It just wasn't enabled for destinations outside of the US. It was the ability to set destinations outside the US that Google enabled for us yesterday.

    If you have the latest version of Google maps already, there is nothing to download. Just go ahead and start using it.
     
  6. nicracine

    nicracine Well-Known Member

    Joined:
    Nov 29, 2009
    Messages:
    201
    Likes Received:
    7
    I see.

    I had it confused with the inability for 1.5 users to download the latest version.

    Thanks for the quick answer!
     

Share This Page

Loading...