Google Now for Samsung Galaxy ReverbGeneral


Last Updated: 2013-01-30 20:28:18
  1. superboy4444

    superboy4444 Well-Known Member Developer

    Here is how i got google now with full functioning voice to work on my galaxy reverb!

    1) Download the M7_Offline.zip from http://forum.xda-developers.com/showthread.php?t=1835199
    2)Extract the files to your extsd
    3)open root explorer go to system/build.prop
    4)change ro.build.version.sdk=15 to ro.build.version.sdk=16
    5)reboot phone
    6)go to your extracted zip/system/app/ and rename velvet.apk to GoogleQuickSearchBox.apk
    7)go to the root menu system/app/ and remove your original googlequicksearchbox.apk as there is not enough partitioned space to do this unless you remove, i recommend moving it to a safe place on your sd card and then saving it to your computer.
    8)copy your newly renamed googlequicksearchbox.apk over to root/system/app
    9)repeat steps 7 and 8 with the googletts.apk
    10)copy your root/system/lib/ to a safe place as you will need to overwrite files in this folder and backup on pc
    11) go to your extracted zip and copy over all files from the system/lib to the root/system/lib and if it asks for overwrite, be sure to do it.
    12) go to root/system/usr/ and back up the srec on your sd
    13) go to extracted zip system/usr and copy srec to root/system/usr/ when asked to merge folders, do it.
    14) go to root/system/build.prop/ and rename ro.build.version.sdk=16 back to ro.build.version.15
    15) reboot phone

    16) you are done! Enjoy!

    here is a video for proof! Google now for SAMSUNG GALAXY REVERB - YouTube

    Advertisement
    dobbs69, sanjuro77 and jgraves12 like this.
  2. Jimmy422

    Jimmy422 Well-Known Member

    Followed the instructions to the T, but it's not working. It opened once and just says "Unfortunately, Google Search has stopped" every time I try to use it.

    By the way, shouldn't this be in the root forum?
  3. KOAM

    KOAM Well-Known Member

    I've been itching to get Google Now on a phone, and I will try it out when I feel comfortable enough to root the Reverb, but I read that Now drains the battery a good amount due to it needing Maps and Calendar to basically run 24/7. It makes sense, so I'm not sure if I really need something automatic like that that bad when I can manually look the info up pretty quickly on demand.
  4. I followed all the steps. Google Now worked but I had problems with Cards not showing and not being able to exit the application with the back key.

    I restored the backed up folders (removed new files installed), and apps but I started getting Google TTS "not working errors". The only way to make it work was to add again the lib files provided by OP.

    I'm sure something else, besides the added files, changed. Now we'll see if this affects OTA updates if we ever get one.

    Just be careful...
  5. superboy4444

    superboy4444 Well-Known Member Developer

    try going into system settings and changing the language and input settings ...also...just try to reboot again..oh, i figured it out go back to the download link i gave you and download the offline zip...then move the offline apk over to the system/app/ after renaming to googlequicksearchbox.apk that should work, i totally forgot to say that...send me private messages to help me help you
  6. jgraves12

    jgraves12 Well-Known Member

    I used the M7_Offline.zip and followed the steps provided and it worked perfectly! Thank's so much for the useful info!
    superboy4444 likes this.
  7. superboy4444

    superboy4444 Well-Known Member Developer

    You are very welcome...tell your friends! I am so proud of figuring this out...i sat in my car for an hour and a half just doing trial and error until it worked
  8. superboy4444

    superboy4444 Well-Known Member Developer

    I have been using for almost one week and i can confidently say that the battery life issue is not actually an issue, it does use battery a tiny bit faster, but not enough to really damper your experience with the phone...you probably lose less than an hour of battery life
    KOAM likes this.
  9. superboy4444

    superboy4444 Well-Known Member Developer

    you cannot exit app with back key, sorry
  10. jgraves12

    jgraves12 Well-Known Member

    Think there's anyway for us to update with the play store? I read on other methods that you could.
  11. superboy4444

    superboy4444 Well-Known Member Developer

    private message me
  12. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    If there's other methods, post it up for everyone to benefit from. No need to do it via pm.
    sanjuro77 likes this.
  13. superboy4444

    superboy4444 Well-Known Member Developer

    if you have a custom recovery you can flash it to device...i don't so this is the only method for me
    sanjuro77 likes this.
  14. Jimmy422

    Jimmy422 Well-Known Member

    I flashed it and now Google Now just closes. No error message, just closes.
  15. superboy4444

    superboy4444 Well-Known Member Developer

    use the offline zip
  16. Jimmy422

    Jimmy422 Well-Known Member

  17. superboy4444

    superboy4444 Well-Known Member Developer

    Sorry man, i really don't know what to tell you...did you mod anything else before?
  18. sanjuro77

    sanjuro77 Well-Known Member

    I flashed the offline zip using CWM and had no problems!

    Works well so far

    Thanks! Honestly I wasn't even aware of Google Now before I read this thread
    Rxpert83 likes this.
  19. dobbs69

    dobbs69 Well-Known Member

    Ok, I flashed the offline mk7 zip and everything works great. One problem I've come across, there is a notice that there is an update on the play store, however, when I get to the play store it says my device is incompatible, my question ,"Is there away to get the update?"

    fyi: I didn't use the steps in the op other than flashing the m7_offline.zip with cwm. I wonder if I did step 4( change ro.build sdk=15 to ro.build=16) and then went to the playstore if that would work? Just wondering if anyone else has found a solution.
  20. superboy4444

    superboy4444 Well-Known Member Developer

    We need cm10 or 10.1 or someone can grab an updated Google now from a jelly bean device and port it over
    dobbs69 likes this.

Share This Page