Google Play App Problems. Cannot access Google Play or Market. Stuck on Policies page


If you are having the Policies page issue, what model phone?

  1. HTC Desire HD

    7.7%
  2. HTC Desire - Other

    30.8%
  3. HTC - Other

    7.7%
  4. LG

    0 vote(s)
    0.0%
  5. Motorola

    0 vote(s)
    0.0%
  6. Samsung

    23.1%
  7. Sony

    0 vote(s)
    0.0%
  8. Google Galaxy Nexus

    0 vote(s)
    0.0%
  9. Google - Other

    0 vote(s)
    0.0%
  10. Acer

    0 vote(s)
    0.0%
  11. Dell

    0 vote(s)
    0.0%
  12. Other

    0 vote(s)
    0.0%
  13. Not having this issue

    30.8%
  1. redfox05

    redfox05 Member

    Summary: Problems with Google Play, can only see a Market App, and no Google play. Market app misbehaves as shown below.

    I can see a Market app but no Google Play app, searching through the entire installed apps list. Loading the market app results in a policies page for Google Play being shown, and nothing else, no Accept or Decline buttons to continue further. See below for detailed explanation of the problem.

    I have a HTC Desire HD
    Android 2.3.5
    Market App Version: 2.3.6 (From Manage Apps)

    Steps to recreate:
    1) Turn on phone.
    2) Press Home button to show home screen
    3) Press Menu, then All Apps.
    4) Click on Market.

    Expected results user should see ( i am guessing here, as it hasnt worked for me):
    Market App loads, and then should display some sort of welcome to Google Play, and shows Accept and Decline buttonts to Google Play terms and conditions.

    Actual Results that the user sees
    Market app loads, and very briefly shows a screen with "Loading..." and two buttons, "Accept" and "Decline."
    HOWEVER, This screen then disappears in a split second, when a browser window is loaded, showing the "Google Play Business and Program Policies."

    Scrolling through the page, there is no link or button to Accept or Decline the terms or go anywhere else. The only links at the bottom are the page footer links including Google copyright, Privacy and Terms, and Help.

    Resolutions steps attempted
    HTC and the help on the Web suggested the following, with no luck.
    - Restart the phone.
    - Restart the phone by pulling out the battery while phone is on. Wait 12 seconds, then replace battery and start phone.
    - Go to manage applications, and Clear Cache and Clear Data.
    - Reset phone to factory settings.
    - Reset phone to factory settings, and setup Google account, then try Market app again. Stil same problem.
    - Reset phone to factory settings, and SKIP Google account login/linking to phone. Clicking on Market now asks to login to Google but still loads the web page with the terms and no accept/decline button.
    - THEN (getting more frustrated, can you tell?) I reset phone to factory settings, logged in with another Google Acccount (as i thought maybe a settings flag has been corrupted in my account, causing Market/Play not to work. STILL no luck, and results in same problem.

    I have emailed Google, will see what happens with that, I have scoured the web and Google Help for anyone else having these problems, but could not find anything, apart from some issues with Motorola I which seem unrelated.

    I called Vodafone, who tried their best to help, but it seems to be more a Google problem. They did however find this forum post, which is great, as its the first one ive seen that shows that someone else is having this issue, and that its not something specific to me.

    Is there anywhere I can post this defect report officially?

    Advertisement
    :
    Googleplaycrap likes this.
  2. jerofld

    jerofld Fixing stuff is not easy VIP Member

    Have you tried clearing data/cache on the new market? Settings > Applications > Manage Applications > All tab > Play Store > Clear data.
  3. redfox05

    redfox05 Member

    The new Market (Google Play) does not show up. You can only see the old one, which results in the behaviour show above, for which i have tried the clear data/cache. Still no luck.
  4. jerofld

    jerofld Fixing stuff is not easy VIP Member

    I had this problem with my tablet. I think I had to reboot it a few times to get the new market to take over. It was a pain, regardless. If you use the web market (play.google.com) it'll still work for your phone.
  5. redfox05

    redfox05 Member

    I have tried restarting it a few times. Will try again though.
    Did you have the same problem where upon loading the Market App, a webpage was opened showing Google Play terms and nothing else?
  6. phantom848

    phantom848 Member

    same problem here...got the market app, no google play app
    and keep getting stuck on a policies page.
    done reboots,factory resets and everything and still not working.
    getting sick of the HTC now....never had so many problems on
    a phone before.
  7. jerofld

    jerofld Fixing stuff is not easy VIP Member

    For awhile, I wouldn't even get the policy page. The market just wouldn't load. My tablet was rooted so I was about to make a back up and manually uninstall the normal market and install the new play market manually when it started working. Once I got the policy page, I had to delete the data and reboot and it worked.
  8. phantom848

    phantom848 Member

    Googleplaycrap likes this.
  9. hootnow

    hootnow New Member

    Exactly the same problem with my htc desire. Unfortunately because it is a very recently fixed phone, I have no file manager whatsoever on it (and obviously can't access the market now to install one!) so can't install the apk file I put on my sd card from the link above.

    Has anyone got any more suggestions? :(
  10. mrsbelpit

    mrsbelpit Well-Known Member

    So bizarre. I had the Play Store icon for about 2 days, clicked it just now and nothing. Then I go to my apps and there's the Play Store but it has the old market icon, i can get to the play store from it. Also, this was right after I had exited the store, and my lookout scanned "google play store" again, meaning there was an update to it. So are they changing the icon back to the old one with the new name?
  11. tyler79durdan

    tyler79durdan Well-Known Member

    Sometimes apps REQUIRE a wifi connection for a solid merge. Google play is a rebranding of market and would therefor require a merge. Maybe try using a wifi connection and retry your flashing steps with wifi enabled and streaming.
  12. phantom848

    phantom848 Member

    did you download it via the internet on your phone?
    if so then open the net again,
    press menu,
    then press more,
    now scroll down to downloads.
    when you click on the APK file it
    will pop up do you want to install the file.
    it sometimes takes two tries to get it to install
    as the first time opens a agreement pop up
    but doenst install.second time installs properly
    and also removes any old versions of market.
  13. redfox05

    redfox05 Member

    ITS FIXED!!!! :D

    Just to let you know, I turned on my phone yesterday, and the Market logo for the shortcut on my home screen has mysteriously changed, and 'Play Shop' now appears in my Apps Menu. (Market has now disappeared).

    It appears that I have now been successfully changed over to the new Play Shop, and my old market shortcut on the homescreen now loads Google Play.

    The first time I loaded this new app, I was asked to agree to some terms and conditions (Looked different to the one that flashed up for a split second when attempting to load the Market app during the problems. But it all seems to work fine now, and looks very similar to the old Market app layout to be honest.

    I would suggest to people to wait it out, and restart your phone every so often, connect to the internet maybe, and magically your phone will hopefully be updated? Thats what happened to me :)

    Good luck all!
  14. redfox05

    redfox05 Member

  15. saptech

    saptech Well-Known Member

    I'm not sure if I had the problem or not. It seems maybe a week or so ago I noticed it was showing Google Play when it wanted to be updated, but I didn't know it, so I kept closing it out. All the while I wanted the Market.

    Later that day I noticed the Market icon missing on my home screen, and I guess reading on AF about the new Play for market, I was able to add the Play icon to my home screen.

    No problems since having it.

    Thnx.
  16. cocktailmaster

    cocktailmaster New Member

    Hello!

    Recently I have bought a new SD card for my HTC desire. I managed to make everything work as it should. But suddenly I have discovered that my Google Play application doesn't work.

    The Google Play app actually opens up and I see the windows where app pictures should be, but there is only text and no pictures. I can search through the apps and select them, however there are no images. Furthermore, when I try to download the app, Google Play cannot download the app.

    I have also discovered, that I cannot sign in to Google through android internet browser. It's funny, however, that my Gmail app works and I can receive emails. And when I try to access any of the google services this page shows up:

    Web page not available The web page might be temporarily down or it may have moved permanently to a new web address.

    I have already tried cleaning all cache and cookies in the Internet browser and cleaning data and cache from the Google Play app.

    Does anyone have an idea what is happenning?

    Please help!
  17. Lizbuppers

    Lizbuppers New Member

    Not sure if this is the right place to post this, but I am a smartphone noob and this is driving me crazy. I have a Mesmerize (i500) through US Cellular, and I can access the App Market fine, but when I go on the internet to the Play site, I keep getting warnings about the certificate not matching something or other, and anything I've tried to install gets denied as not being compatible with my device. No app for Play, and apparently no apps from Play either. Any (easy) suggestions??
  18. abdosagor

    abdosagor New Member

    Hello Cannot access Google Play or Market although i have an activated google account when i tab upon google play apps i receive the following message ( Authentication is required. you need to sign into your google account )
Loading...

Share This Page