Google Play - Force Close and Error (905)Support

Last Updated:

  1. jimbo78255

    jimbo78255 Active Member

    For the last 3 days, Play will often Force Close instead of running, or if it runs, it refuses to Update or Download - each time with a "xxx could not be downloaded due to an error. (905)"

    I have cleared data and cache, but to no avail. Any thoughts or advice?


  2. doogald

    doogald Guides Guide

    One thing that I would try: from home, settings->applications->manage applications. Find the Google Play Store, tap it, and tap the button "uninstall updates". The first time that you run the store, it may update to the new store again. It may be that the last update installed incorrectly.
    tvharen likes this.
  3. archie102

    archie102 New Member

    I have galaxy s plus and have gotten the same problem, I used the other guys help and it worked with market, but it re updates, so everytime you have to update something or instal something uninstall updates of store and install
  4. Clementine_3

    Clementine_3 Well-Known Member

    My phone just updated Play to version is 3.7.13. Maybe Google fixed it?
    I have a D3 as well but had no issues with Play.
  5. nolles078

    nolles078 New Member

    I also got sgs plus and seem to have the same problem with the play store (error 905), obviously deleting the store updates everytime you need to update is a silly way to solve the issue so im hoping somebody will fix this issue soon!

    Google may have fixed it for your version clementine_3, but im still not able to update or download anything :(
  6. gloccy

    gloccy New Member

    I also have a SG S plus with this problem.. There might be singeing up with how the hardware of the phones react to the update from play? I've also heard of other SgS plus'ers who have the upside-down problem on their front face camera on instagram
  7. sandra86

    sandra86 New Member

    I have a SG S plus too and I had this problem but I solved.

    Folow this steps:
    - First uninstall updates of play store.
    - Second reboot your phone.
    - Open your app market, the program will ask you if you want to install a play store. Say yes.
    - After you install a play store the problem will be solved.
    dianaibiza likes this.
  8. Ahrol

    Ahrol New Member

    The solution Sandra posted, worked like a charm on sgs+.

    Turns out the whole market needed to be upgraded to a new UI...
  9. rwba

    rwba New Member

    I tried Sandra's approach and it seems to be working. Many thanks to Sandra.
    It is interesting that after all of the problems S+ users have expressed, Google chooses to ignore the problem.
  10. fulk

    fulk New Member

    Thank you Sandra, your solution works perfectly !
  11. itzxburgrking

    itzxburgrking New Member

    what do you have to uninstall and how?
  12. doogald

    doogald Guides Guide


  13. FarbrorJoakim

    FarbrorJoakim New Member

    Thanks a lot doogald & Sandra - it works perfectly well!!!:)
  14. ftnzstr

    ftnzstr New Member


Share This Page