Google Play, no connection retry, can't downloadSupport


  1. Barlisk84

    Barlisk84 Member

    So I've got the common issue of Google Play store telling me "no connection, retry". Only mine is not so common as I can not find a solution. Google play will work but it randomly does the no connection, won't let me rate or leave comments, and sometimes wont download apps. If I keep retying over and over again it will work.

    With Amazon app it does the same thing. As well as Facebook. It happens all the time on data but has only happened once on wifi.

    I've tried....
    Clearing cashes of apps and the phone itself.
    Reinstalling Google Play.
    Deleting account and readding.
    Signing into YouTube first before readding my account to the phone.
    Checking the date and time.
    Factory reset
    New SIM card
    Reset APNs
    New rom, tried CM.

    My phone 2 months old and is a stock root, galaxy s4 on T-Mobile.

    I'm curious as if maybe I debloated something I wasn't supposed to? But wouldnt flashing an entirely new rom fix that? I only deleted Samsung bloat apps, YouTube, and gmail.

    I've also tried unfreezing those apps. And no luck. What else is left?

    Something else that might be worth mentioning is that my browsers, anyone I use, will sometimes load my pages to 90% and then hang for 30 seconds, then finish loading. That issue actually happens on wifi as well, but the rest is mainly on data. Any help at all would be greatly appreciated. Thanks.

    Advertisement
  2. Barlisk84

    Barlisk84 Member

    Also called T-Mobile and had them reset my data connection. Just for the chance that I was out of sync with them. But still no luck.

    Also scanned for malicious apps and anything that might be interfering. No antivirus while testing and sync on everything is off.

    I also failed to mention that I've also tried deleting the Host file like some recommended but still no luck. Anything at this point is worth trying. Thanks.
  3. jhawkkw

    jhawkkw Chinchillin' Moderator

    Does it only happen over mobile data or does it happen on wifi as well?
    Edit: reread and answered my own question.

    It's probably a bad radio firmware update. In which case you could try downgrading the radio firmware if your bootloader will let you. If not, then you may have to wait for another update.
  4. Barlisk84

    Barlisk84 Member

    Would that not be fixed with a new rom? I've done a "downgrade" when switching roms. And then upgraded back when I reverted to stock rom.

    Is there a way to full wipe? Not factory. Like.. everything right down to nothing but the recovery. Rather than just replacing one rom with another? And then use a PC to reinstall stock rom?

    I guess a better question would be... how would you go about replacing the internal SD card. And would that fix my issue? (I've read that it could be a memory issue with the internal SD but memory tests come out OK) Thanks again.
  5. Barlisk84

    Barlisk84 Member

    I ask about the full rom wipe/replace because even factory reset does not clear everything. It even leaves empty folders from apps installed pre factory reset.

    And forgot to mention, got a new SIM last week. Still not running proper so that's one less thing to try.
  6. stargazertony

    stargazertony Well-Known Member

    Well, the phone is only two months old. Take it back to t mobile. I don't really understand why you've disabled the bloat. It takes up very little space and causes no harm. If you look back at people who are having issues with their phones, it's because they've messed with them.
  7. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

    Nahhh its not only you and can I ask how do u access the play store . with your WiFi on with the data . I was told to do it in airplane with the settings to update over WiFi on it fixed and never had a problem knock on wood
  8. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

    So what you are going to do is turn data off turn on air plane mode go to the play store and now open the app and go straight to the settings and select update apps while on WiFi its the last selection of the three that's there. Back out to main page . power off device just a quick reboot and leave WiFi on . when it powers up let settle for about 10 minutes and open the play store . once all app have updated u should be cool .
  9. Barlisk84

    Barlisk84 Member

    I've messed with some settings and have now gotten Amazon to work and have now gotten Play Store to produce an error... it goes away to quickly to read so Ill have to come post it when I can get it written down. Its something like "RCHP:3somethingsomethingsimething". Its only on screen for half a second and is never expected and doesn't always produce the error.
  10. Barlisk84

    Barlisk84 Member

    Ill try that later when I get around wifi. I access Play Store through wifi and data. I'm pretty sure this will not fix my issue but its worth a shot I guess. Its definitely a Google Account sync issue.

    Anyone think that maybe my old phone still being linked to my account would be causing an issue? Even though its factory reset and no longer in my possession? Google still has it listed in my devices.
  11. Barlisk84

    Barlisk84 Member

    The "bloat" I removed is all Samsung account apps that aren't needed. They eat battery life(15% over 24hours) and ram(over 325mb). Continually running in the background. So not exactly harmless. The apps I have removed have nothing to do with my issue. I mentioned them because the more info given on forums, the better.
  12. Barlisk84

    Barlisk84 Member

    Worked for about 2 hours. Thanks though. You're the only person so far with an actual suggestion on a fix.
    BRAINZ2013 likes this.
  13. stargazertony

    stargazertony Well-Known Member

    300+MB and 15% over 24 hours is minor and not going to make any difference.
  14. Barlisk84

    Barlisk84 Member

    300mb is not minor when its over a 1/3 of your available ram tied to apps that you don't use. At any given time I need 800mb free to run my apps side by side smoothly. Its all about preference. Its actually a huge difference in performance.
  15. stargazertony

    stargazertony Well-Known Member

    Um, OK.
  16. Muilisx

    Muilisx Well-Known Member

    ^^^^ This!

    The S4's bloatware is only roughly around 228MB, the S4 has like 9GB available to the user. There's no reason to remove or disable the bloatware when you have SO MUCH ROOM. Chances are, he disabled something that the store needed to operate.
  17. stargazertony

    stargazertony Well-Known Member

    Thank you NY. My point exactly.
    Muilisx likes this.
  18. Barlisk84

    Barlisk84 Member

    Not storage... not the SD card... ram. 2gb of ram... 800mb of it is used by the OS. 1.2gb of ram left for apps to run with.
  19. Barlisk84

    Barlisk84 Member

    Ram. Not storage. Not SD card. Do you not know what ram is? How ignorant are you? You can stop now. You've already shown it enough
  20. Muilisx

    Muilisx Well-Known Member

    RAM and Storage are two different things. RAM is the phones memory, not the phones storage. Computer memory doesn't store things. Well, it technically can, but not files, and it's wiped upon reboot. Storage is where stuff is stored, as in apps, pics, music etc.

    I don't understand why people think phone RAM is a form of storage. It boggles my mind. If memory was storage, then you would not need a HDD, or any other form of storage.

    When your phone yells at you saying it has no memory when you're trying to download a app or update an app, it's not referring to the RAM, it's referring to the storage space. It's just the way android words it. My S3 has 2GB of RAM, but also has 16GB of internal storage. RAM is memory for processing, not for storing. There is NO WAY you would eat 2GB of RAM resources to where the S4 would yell at you. Your store issue has NOTHING to do with either.
  21. lotus49

    lotus49 Well-Known Member

    There is no point in worrying about the amount of RAM in use on an Android device except in very rare circumstances. 300MB is not significant on an Android device with 2GB. Android does a very good job of managing memory and, in the unlikely event that there is too much in use, the OS selectively kills off applications to free more memory.
    agentc13 and Muilisx like this.
  22. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    Things are getting a little over the top here. :(

    /thread closed pending mod review..
    ocnbrze, scary alien, D-U-R-X and 5 others like this.
  23. lunatic59

    lunatic59 Moderati ergo sum Moderator

    Thread reviewed and re-opened.


    Holy Moly! I worked up a sweat editing this thread. C'mon fellas (and ladies, if there be any present) let's take it down a notch and stop the playground posturing.

    Here's how it's going to go from this point forward ... OP asks, you answer. Both will be done politely, respectfully and without sardonic commentary. If you see something that is insulting, unhelpful, rude or just smells funny, use the report button /!\ and move on. If you can't handle that, then we have a nifty little infraction system to "educate" you. :)

    Now, back to the OP's original question ...

    I am in agreement with those who suggest that memory, ram, bloat etc. have little or nothing to do with your situation. Since you've been able to connect to the play store since removing/disabling Samsung apps, then I doubt it's anything you did, either.

    I had a somewhat similar situation with my N4 when it was new. The play store would throw errors when trying to update or download apps over WiFi but was fine using mobile data. And, it wasn't consistent. Sometimes I could get an app to update over WiFi after several tries or smaller apps would go through but larger apps would fail. I'm sorry to say there wasn't a "fix" for this as I never really did figure it out. It just sort of cleared up on its own. I know I did clear the cache and data from the play store and forget and reconnect to the WiFi networks, but it wasn't a definitive solution. Like I said, over the course of a few weeks it just seemed to clear itself up. Perhaps it was an update to the store itself, or maybe the device cache on Google's servers had to flush before a reliable connection could be established. Maybe it was just gremlins.

    Point is, if it's not a common problem and hasn't had a lot of exposure, it's going to be a matter of common-sense troubleshooting rather than "follow these steps to fix it." We're all willing to help so let's move forward and get this resolved to the best of our abilities.
  24. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

    Try to do my best look at the name speaks for its self BRAINZ. now did u get it fixed
  25. dynomot

    dynomot VIP Member VIP Member

    You need to unlearn what you think you know about RAM. The adage "Unused RAM is wasted RAM" holds very true in Android. It is not a Windows computer, it uses and handles RAM very differently. Repeatedly "killing" apps and processes to save RAM and/or battery is not only futile and frustrating it is actually counter productive. Leave Android to do is own thing and you'll definitely notice a change for the better.

    As for your Play store problems it may be that in removing "bloat" (always better to freeze it using something like Titanium Backup) you may have removed something that is perhaps not vital, but useful for Play Store to work correctly.

    Reinstalling your stock ROM from scratch, freezing "bloatware" on an individual basis, checking to see if what you want works correctly afterwards before going on to freeze the next item may well solve your issues.

    Here's a link explaining RAM usage in Android, in fact Google "Unused RAM is wasted RAM" and you'll get a myriad of hits showing why Android, Linux and Unix handle RAM usage very differently from Windows.


    https://www.google.com/url?sa=t&sou...cQFjAA&usg=AFQjCNFJscffmVr31i3xDhWICbkTeWbbIg

Share This Page