Google play store app force closes on opening

Discussion in 'Android Apps & Games' started by lord lucan, Nov 3, 2012.

  1. lord lucan

    lord lucan Well-Known Member
    16

    Jun 9, 2010
    70
    1
    16
    Hi guys,

    The play store crashes on opening on the wife's htc desire. Any ideas what could be causing this? I doesn't even open the app.

    Ive tried rebooting the phone and clearing the cache but to no avail
     

    Advertisement

  2. jimeller

    jimeller Well-Known Member
    38

    Aug 6, 2009
    409
    23
    38
    East Riding
    Try clearing the Google Play Store data in applications. This has worked for me on a couple of occasions.
     
  3. lord lucan

    lord lucan Well-Known Member
    16

    Jun 9, 2010
    70
    1
    16
    Will I have to reinstall the store if I clear data?
     
  4. lord lucan

    lord lucan Well-Known Member
    16

    Jun 9, 2010
    70
    1
    16
    Sorry to bump this but any ideas if I will need to reinstall?
     
  5. jenny milton

    jenny milton New Member
    5

    Nov 6, 2012
    3
    0
    5
    I have the same problem... did you try this? Did it work?
     
  6. Hadron

    Hadron VIP Member
    VIP Member
    2,118

    Aug 9, 2010
    18,398
    11,382
    2,118
    Spacecorp Test Pilot
    Dimension Jumping
    @lord lucan: No, clear data just clears the app's data, does not uninstall the app. You will have to re-accept terms & conditions (as if you were using it for the first time).
     
  7. lord lucan

    lord lucan Well-Known Member
    16

    Jun 9, 2010
    70
    1
    16
    Did this and it didn't work. It did uninstall the app by the way so had to reinstall the apk file
     
  8. Petrah

    Petrah Psychotic Female
    323

    Jun 13, 2011
    4,085
    1,439
    323
    Female
    Annoying my X-Husband
    Hanover Park, IL

    Clearing the data isn't supposed to uninstall an app, so something really wonky happened there. Even when you uninstall, it should only uninstall the updates and not the entire app... unless the phone is rooted. And then the only way to reinstall it would be to boot into recovery and flash Gapps. Did you flash Gapps to get it reinstalled?
     
  9. lord lucan

    lord lucan Well-Known Member
    16

    Jun 9, 2010
    70
    1
    16
    Phone is not rooted. I have no idea what flashing gapps means lol. Sorry.
     
  10. Petrah

    Petrah Psychotic Female
    323

    Jun 13, 2011
    4,085
    1,439
    323
    Female
    Annoying my X-Husband
    Hanover Park, IL
    No need to apologize. :) I'm going to guess that the app didn't completely uninstall though. Sounds like it was just the updates to the app that got uninstalled, but that's not supposed to happen when clearing data. Clearing the data simply reverts it back to default like it was never used, so you have to go back in and redo all of the settings etc. for the app.
     
  11. lord lucan

    lord lucan Well-Known Member
    16

    Jun 9, 2010
    70
    1
    16
    Ok I'll give it another go and report back
     
  12. lord lucan

    lord lucan Well-Known Member
    16

    Jun 9, 2010
    70
    1
    16
    Tried clearing data and it made no difference. I'm really not sure what the problem could be. It's play store version 3.9.17 if that makes any difference
     
  13. Petrah

    Petrah Psychotic Female
    323

    Jun 13, 2011
    4,085
    1,439
    323
    Female
    Annoying my X-Husband
    Hanover Park, IL
    I'm not finding much in my Google searches other than clearing the data, cache, and uninstalling the updates.

    Settings > Apps > Swipe to the left till you see All up top. Swipe up and locate Google Play Store. Tap on it. Tap Force Stop, tap Clear Data, tap Clear Cache. Reboot the phone.

    If that doesn't work and since you've already uninstalled all of it's updates, your only solution might be to factory reset from the settings menu (as long as you're not rooted). Factory resetting will wipe everything except what's on the internal SD.
     

Share This Page

Loading...