Google Play Store Broken on Samsung Galaxy S2


  1. StetsonGirl

    StetsonGirl New Member

    Hi,

    Firstly I would like to say thank you in advance to anyone who is able to help me, and apologise in case I have put this thread in the wrong place. I'm at my wits' end with this problem and seem to be going round in circles so any advice would be greatly appreciated.

    The Google Play store icon on my Samsung Galaxy S2 (Orange network) had changed from the normal triangular image to a generic Android one and the name under the icon has gone all funny; it has changed to some rectangles with an 'E', a '3' and some 'L's.

    When I try to run the app, it gives me an error saying "Sorry!" at the top, followed by a load of text that seems to be more rectangles, a few letters and what look like Chinese symbols. At the end it says "(process com.android.vending) has stopped unexpectedly. Please try again" and there is a "Force Close" button.

    I also cannot find the Play Store app in my "Manage Applications" list. There is something there which I think might be it, but again the text of the name is all gibberish.

    I have been to the Play Store website on my PC and tried to download apps from there. It says they will be installed on my phone shortly; my phone starts to download them but part way through I am given the same error message as above.

    I've tried restarting my phone etc.

    Does anyone have any suggestions?

    Thanks :eek:

    P.S. I do have some screenshots but cannot post links yet as I'm a newbie :eek:

    Advertisement
    :
  2. Unforgiven

    Unforgiven What does this button do? Moderator

    breadnatty08 likes this.
  3. StetsonGirl

    StetsonGirl New Member

    Thanks so much for your reply :)

    I started looking through my app list to see if I could find adroid.vending, then I came across the one with a gibberish name that I thought might be my messed up Play Store. I noticed the "Unistall Updates" button, which I'd not noticed before, and tried that then restarted my phone.

    It has now gone back to the factory installed Android Market and it seems to work! Yey! I guess it will update to the most recent Play Store in due course but I'm not too worried about that any time soon; at least it works now.

    Thanks again :)
  4. Unforgiven

    Unforgiven What does this button do? Moderator

    Glad your all set. Don't hesitate to ask again if you have any other problems or questions.:)
  5. StetsonGirl

    StetsonGirl New Member

    Thank you :)

    What a friendly forum :D
  6. Unforgiven

    Unforgiven What does this button do? Moderator

Loading...

Share This Page