Google play store connection timed outSupport


Last Updated:

  1. blackepoxy

    blackepoxy Well-Known Member This Topic's Starter

    Joined:
    Jan 14, 2011
    Messages:
    1,086
    Likes Received:
    247
    Most of the time when I open the Google play store on my one x, it does not connect. It just stays on loading and shows connection timed out, retry.
    This is aggravating me.
    Is this happening to anyone else?
    Is there a quick fix?

    TIA :confused:
     

    Advertisement
  2. razvan06

    razvan06 Well-Known Member

    Joined:
    Jun 5, 2010
    Messages:
    696
    Likes Received:
    89
    Try clearing data and cache from the app ..
    Menu>Settings>Apps>All Apps>Play Store
     
  3. yeseanul

    yeseanul Member

    Joined:
    Mar 31, 2012
    Messages:
    7
    Likes Received:
    0
    Same problem here. Nothing worked. Not even resetting to factory settings.
    [Issue only when using data (not WiFi). Some apps work OK (e.g., Chrome), others just don't (e.g., Google Play Store, Google Maps]
     
  4. androidfan321

    androidfan321 New Member

    Joined:
    Feb 15, 2013
    Messages:
    1
    Likes Received:
    0
    I just got my LG Nexus 4 today and I am having the same problem. Play store just times out and I can not access Google chrome either. I've already cleared cache and that did not work. Anyone that could help me with this?
     
  5. Lenka197

    Lenka197 New Member

    Joined:
    Feb 20, 2013
    Messages:
    1
    Likes Received:
    0
    It seems that there is a non compatibility mode between android jelly bean and google play store. Somehow after the update of google store, the settings of APN gets "screwed up" and android stops to keep the APN settings constant, and changes it from time to time. That lack of stability of the APN settings makes the store not to work. Internet connection works, email can be checked, however with google store the answer from the system is "the connection has been timed out".
    The temporary sollution is as follows (for samsung phones):
    each time when a person has a problem with connection to the google store through the data transfer - no WIFI, that person has to go to the settings, communication, more settings, net, access points, and click on "restore default settings".
    That fixes the connection to google store temporary. When the problem appears again, that procedure has to be done again
    Hope it helps
     
  6. Metroid Prime

    Metroid Prime Oil Can!!! Oil Can!!! VIP Member

    Joined:
    Feb 15, 2012
    Messages:
    9,109
    Likes Received:
    2,920
    Same thing happened to me, but on a different device. I was on WIFI and when I switched to Data it worked.
     
  7. pitnon

    pitnon New Member

    Joined:
    Oct 13, 2013
    Messages:
    1
    Likes Received:
    0
    you can uninstall it's update and try open it later

    for me galaxy trend it's working
     
  8. Ketaki

    Ketaki New Member

    Joined:
    Oct 19, 2013
    Messages:
    1
    Likes Received:
    0
    I use LG optimus L7 II and m facing the same problem
    can you help??
     

Share This Page

Loading...