Google Services Sucking Power AgainSupport


  1. Goodspike

    Goodspike Well-Known Member

    I'm having a problem with my phone where the battery is drained and it even runs warm. I tried rebooting already.

    The culprit is again Google Services. I did recently update Google Maps.

    Anyone else having this issue recently?

    Advertisement
  2. joesixpack

    joesixpack Well-Known Member

    Count me in! I hardly use my phone at all during the day (it sits on my desk) and it was down to 75% with Google Services accounting for 50% of battery use (tops on the list). I tried reverting GS back to its former state before updates, but then apps like Weather Channel and Redbox won't work (says GS needs to be updated). I think it has a lot to do with GS wanting to use gps to determine my location even when the apps aren't running. If you find a good solution, I'm all ears!
  3. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    It could be running a backup in the background. What do you have set to sync?
  4. Goodspike

    Goodspike Well-Known Member

    Just my contacts. I do have some Verizon backup thing that runs daily, without issue.

    A second reboot didn't stop it, so I ran Task Manager and did the "clear memory" under Ram, and also closed all the active apps there. That seemingly fixed it.

    Then I started up all the typical apps, one by one at about 15 minute intervals. Still no problems.

    In the past though I've found this Google Services issue does just seem to come and go. I've had it happen about 2x during the almost a year I've owned the phone. So I'm not sure if what I did fixed it, or if it was just going to fix itself.
  5. Bhollywood

    Bhollywood Member

    if I leave access to my location check box off under location services. . If I turn it on the battery is dead about 4 hours sooner.
    You can leave GPS on for the weather app if you want as it burns way less battery I find
  6. Goodspike

    Goodspike Well-Known Member

    This problem kept reoccurring, but has not since I uninstalled the updates to Google Maps. Not sure if it affected my wife's identical S4, because we use manual updates and I don't know if we were using the same version.
Loading...

Share This Page