Google talk service running at startSupport


Last Updated:

  1. rsjet

    rsjet Well-Known Member This Topic's Starter

    Joined:
    Apr 8, 2010
    Messages:
    69
    Likes Received:
    11
    Google talk service starts running as soon as the phone is on, even though the app is closed (with ATK). Anyone know how to prevent it from starting up with the phone? I dont really use gchat on the phone so I dont want it to run unless i open up the app.

    The same occurs with google voice (which i only have set up for voicemail). This one I dont care too much if its on since at least its useful for voicemail.
     

    Advertisement
  2. sanfrandroid

    sanfrandroid Member

    Joined:
    Apr 29, 2010
    Messages:
    14
    Likes Received:
    0
    I have the same issue. I don't use gtalk or GV much so I don't want them to run at start. I would love to find an answer too. Thanks in advance.
     
  3. Trooper

    Trooper Well-Known Member

    Joined:
    Apr 11, 2010
    Messages:
    3,715
    Likes Received:
    541
    Same issue here.
     
  4. russell5

    russell5 Well-Known Member

    Joined:
    Nov 7, 2009
    Messages:
    206
    Likes Received:
    19
    i use a paid app called startup auditor.

    You can turn off apps from starting up automatically.

    Well worth it.
     
  5. rsjet

    rsjet Well-Known Member This Topic's Starter

    Joined:
    Apr 8, 2010
    Messages:
    69
    Likes Received:
    11
    Well the thing is, the app wasn't even running. Just the service is. So i dont know if startup auditor would help at all.
     
  6. russell5

    russell5 Well-Known Member

    Joined:
    Nov 7, 2009
    Messages:
    206
    Likes Received:
    19
    I look in my startup auditor and what shows up for google talk is "gogole talk service"

    I think it will work perfectly.
     
  7. Howie

    Howie Well-Known Member

    Joined:
    Oct 28, 2009
    Messages:
    1,412
    Likes Received:
    71
    Google Talk -- Menu -- .... (the dots options) - Settings - uncheck Automatic sign in
     
  8. russell5

    russell5 Well-Known Member

    Joined:
    Nov 7, 2009
    Messages:
    206
    Likes Received:
    19
    I forgot about that option lol im an idiot
     
  9. rsjet

    rsjet Well-Known Member This Topic's Starter

    Joined:
    Apr 8, 2010
    Messages:
    69
    Likes Received:
    11
    Actually that was already unchecked. Thats why I was surprised when I started up my phone and it was a running process.
     
  10. Trooper

    Trooper Well-Known Member

    Joined:
    Apr 11, 2010
    Messages:
    3,715
    Likes Received:
    541
    Same issue here. I may try out this app.
     
  11. Jayziac

    Jayziac Well-Known Member

    Joined:
    Jun 18, 2009
    Messages:
    166
    Likes Received:
    8
    might have to root your device and unininstall it. by removing /system/app/gtalkservice.apk
     
  12. howarmat

    howarmat Well-Known Member

    Joined:
    Apr 8, 2010
    Messages:
    1,580
    Likes Received:
    229
    it shows as an inactive/cachced app using 'System' so its not taking up battery or cpu cycles unless you are actually using it basically. The service has to run to show you online and look for the incoming messages though. either way it doesnt drain the battery by anything measurable
     
    wannainc likes this.
  13. Trooper

    Trooper Well-Known Member

    Joined:
    Apr 11, 2010
    Messages:
    3,715
    Likes Received:
    541
    Well if its not draining things, I suppose its ok. Weird thing is I was able to get it to stop running for a few days by unchecking the option to automatically sign in. But alas, it only lasted for a few days and always runs when I turn the phone on in the morning.
     
  14. wannainc

    wannainc Well-Known Member

    Joined:
    Apr 24, 2010
    Messages:
    74
    Likes Received:
    2

    Was wondering what it was for anyhow because I dont have Google Voice and never installed it..thx!
     
  15. Mr.Slave

    Mr.Slave Well-Known Member

    Joined:
    Mar 4, 2010
    Messages:
    271
    Likes Received:
    85
    You need Gtalk to run for the market and other sync's to function properly. It is kinda like you auto ID pusher.
     
  16. raceruser

    raceruser New Member

    Joined:
    Nov 9, 2010
    Messages:
    1
    Likes Received:
    0
    i got frustrated eveytime gtalk would fire everytime
    1. phone wakes up or
    2. switch between wifi and 3G
    Got rid from my ZTE Racer by
    1. rooting the phone with Universal AndRoot(got it from bit.ly/aa4jxJ) to get superuser access
    2. Used SystemAppremover from android market to remove Gtalk from the phone
    it took 3minutes and a dollar in all to get rid of this frustration
     
  17. caeserts

    caeserts New Member

    Joined:
    Nov 18, 2010
    Messages:
    3
    Likes Received:
    0
    but i don't have this service in android startup???

     
  18. perryinjax

    perryinjax Member

    Joined:
    Oct 12, 2011
    Messages:
    21
    Likes Received:
    0
    Google Talk -- Menu -- .... (the dots options) - Settings - uncheck Automatic sign in
    That was the answer i have needed to know about for months.
    Everytime i peek at the "running services" it is always having "google messeging service" running and I get tired of having to turn it off or stop the process from running in background.
    I am so glad I found this thread and Howie's answer!
    Yay!
    thanks again both Poster and Howie,
    perryinjax youtube channel thanks you :)
     

Share This Page

Loading...