Google Talk Will Not Quit No Matter What


Last Updated:

  1. Barats

    Barats Well-Known Member This Topic's Starter

    Joined:
    Jun 7, 2010
    Messages:
    470
    Likes Received:
    37
    It seemed after the update, Google Talk will not quit running at all. No matter if I sign out and stop the service. It will be back and running in about 5 minutes and say it has been running since the phone has been awake, like it was never turned off to begin with or the time running would be real low. What apps and other stuff use this service?

    It seemed before the update, once I killed it, it would NEVER be running.
     

    Advertisement
  2. Covert_Death

    Covert_Death Well-Known Member

    Joined:
    Feb 2, 2010
    Messages:
    2,091
    Likes Received:
    665
    same i'm having it come back up now too, it would die before
     
  3. dgeezer

    dgeezer Member

    Joined:
    May 6, 2010
    Messages:
    21
    Likes Received:
    3
    I've noticed this too. Plus my battery life seems worse since the update.
     
  4. firemedic1343

    firemedic1343 Well-Known Member

    Joined:
    May 15, 2010
    Messages:
    50
    Likes Received:
    10
    Root and run a custom rom, the phone is crippled by Sprint and HTC...I don't trust any updates until testing and cleaned by the android dev community.
     
  5. musikat

    musikat Well-Known Member

    Joined:
    May 17, 2010
    Messages:
    145
    Likes Received:
    3
    There is another thread about this subject below. Someone on that thread suggested Startup Cleaner 2.0. I downloaded it and so far so good. It ONLY works on startup, but the weird thing is I still had to kill it in running services. So far (one hour) it has stayed off. :)
     
  6. pgus13

    pgus13 Well-Known Member

    Joined:
    Jun 3, 2010
    Messages:
    165
    Likes Received:
    7
    I don't even use it and it starts up for some reason and drained my battery over night from full charge to 69%!! I also use Startup Cleaner as well!
     
  7. Swollen Pingus

    Swollen Pingus Member

    Joined:
    Jun 5, 2010
    Messages:
    11
    Likes Received:
    0
    If you just go to menu, settings, applications, running services. You can turn it and othee annoying apps off and they never come back on till you reset.
     
  8. musikat

    musikat Well-Known Member

    Joined:
    May 17, 2010
    Messages:
    145
    Likes Received:
    3
    Not true with this one. Google talk keeps coming back no matter how many times you "stop" it in running services.

    Update to earlier post: It did come back twice so far. It seems to be less frequent but that's all I can say for startup cleaner 2.0. Any other ideas out there?
     
  9. probinson

    probinson Well-Known Member

    Joined:
    May 14, 2010
    Messages:
    123
    Likes Received:
    47
    Try Startup Auditor. It works for me.
     
  10. musikat

    musikat Well-Known Member

    Joined:
    May 17, 2010
    Messages:
    145
    Likes Received:
    3
    Trying Startup Auditor now. It says you can't get to the market without google talk. Will using appbrain and syncing get around that without starting it?
     
  11. musikat

    musikat Well-Known Member

    Joined:
    May 17, 2010
    Messages:
    145
    Likes Received:
    3
    That didn't work either. Google talk reappeared again and won't stay off. Weird.
     
  12. mrvirginia

    mrvirginia Well-Known Member

    Joined:
    May 13, 2010
    Messages:
    1,493
    Likes Received:
    228
    gtalk shouldn't be disabled...
    it's what's used to sync gmail.
    other users have reported you also need it for syncing with the market.
    &gtalk is not the source of draining power...
     
  13. mtrajano00

    mtrajano00 Well-Known Member

    Joined:
    Jun 13, 2010
    Messages:
    57
    Likes Received:
    0
    This is true I agree Gtalk does not need to be disabled. Just make sure your a signed off from it so it does not take battery power.


     
  14. Husker Z

    Husker Z Member

    Joined:
    May 31, 2010
    Messages:
    15
    Likes Received:
    3
    Yup, you actually need gtalk for quite a few other things.

    The thing you need to make sure is turned off is in Talk, make sure you are signed out and make sure you aren't "logging in automatically". The normal gtalk you see in "running services" won't do anything, leave it alone.
     
  15. pgus13

    pgus13 Well-Known Member

    Joined:
    Jun 3, 2010
    Messages:
    165
    Likes Received:
    7
    Been there, done that!!
     
  16. durtdawg

    durtdawg Member

    Joined:
    Dec 18, 2009
    Messages:
    19
    Likes Received:
    3
    I have tried all kinds of methods that I saw here on the forum for closing GTalk but it always comes back. Prior to the update it would only come up after I power it up. I would close it and it would remain closed. Now, I will close it, sign out,kill it from running services, turn background data off and a host of others things...it still comes back. Does anyone have any absolute way to stop this from happening? My battery life went from bad to worse since this began to occur.
     
  17. Dose

    Dose Well-Known Member

    Joined:
    Nov 29, 2009
    Messages:
    93
    Likes Received:
    3
    +1 this thing is like herpes on my Evo..... it just keeps flaring up and never goes away
     
  18. ShaneV

    ShaneV Active Member

    Joined:
    May 25, 2010
    Messages:
    34
    Likes Received:
    21
    Do you use Gmail? It requires GTalk service for notifications. The market also uses it for notifications of updates to apps.
     
  19. Vincent Law

    Vincent Law Well-Known Member

    Joined:
    Jun 4, 2010
    Messages:
    396
    Likes Received:
    64
    Second part is incorrect. I receive notifications without it running.
     
  20. Dose

    Dose Well-Known Member

    Joined:
    Nov 29, 2009
    Messages:
    93
    Likes Received:
    3
    Yeah I do. And last time I said gtalk was needed for gmail people started throwing fruit at me and accused me of witchcraft.... so I was right.... it was the fact that I was killing gtalk that stopped my emails from coming in
     
  21. Wifi-Naught Odin

    Wifi-Naught Odin Well-Known Member

    Joined:
    Jun 18, 2010
    Messages:
    74
    Likes Received:
    21
    Not certain how you kill it, but here's how I close it when done...

    Talk->Menu->More->Close all chats
     
  22. RedWingsFan

    RedWingsFan Well-Known Member

    Joined:
    May 10, 2010
    Messages:
    365
    Likes Received:
    108
    I killed it by using startup auditor. Problem is i stopped receiving my gmail.

    If its such a battery hog, couldnt we just use the mail client instead of the gmail client. Or is there negatives to using the native mail.client with gmail?
     
  23. myriam

    myriam Well-Known Member

    Joined:
    May 17, 2010
    Messages:
    63
    Likes Received:
    7
    As far as I know Gtalk is mostly for IM. I also use startup editor and Gtalk never came back.
     
  24. ShaneV

    ShaneV Active Member

    Joined:
    May 25, 2010
    Messages:
    34
    Likes Received:
    21
    Is it the GTalk service thats the battery hog, or the GTalk App? I noticed better battery life when unchecking automatic login with GTalk, but didnt notice any change when trying to kill the service.

    You can use the Mail app for your gmail account, but I would expect it might use more battery as it has to go out and check for mail, where the gmail app gets pushed to it.
     
  25. Brent Pierce

    Brent Pierce Well-Known Member

    Joined:
    Jun 10, 2010
    Messages:
    197
    Likes Received:
    69
    so, the Google Talk app helps get your email? Even if you're NOT signed in? I am signed out and unchecked auto-sign in. But I still get mail.

    EDIT: I just did an email test. Google Talk completely OFF. (Settings>Running Services>Google Talk[touch to stop]) I sent an email from my computer via my work email. Received it on my phone instantly. Therefore I guess you don't need Talk to get your email.
     

Share This Page

Loading...