1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Google Voice on AT&T Nexus One counts as Texting?


Last Updated:

  1. Vegeta

    Vegeta Member This Topic's Starter

    Joined:
    May 22, 2010
    Messages:
    6
    Likes Received:
    1
    Hello Android fans, here is my situation.

    I bought two Nexus One phones of the AT&T flavor, so I can use their 3G network. As with all Nexus One's from Google, the phones are unlocked.

    The plan I enrolled in was for $119.00 for two smartphones with 550 minutes and unlimited data, but with no texting (as it costs like an extra $30 a month).

    I decided to use Google Voice app, under the assumption that it transmits the messages via the data network, as I can use it under Wi-Fi just fine.

    Well I got charged for sending 15 messages on my phone, and my girlfriend's phone (the other Nexus One) got charged 15 messages for receiving it. I checked my usage and it showed my Google number and listed the action as being "Text/Instant Message". So I owed about $6.00 in texts for just one week.

    It isn't the price that bothers me, I already paid it, but I thought the point of data is we could use it for whatever we wanted as long as it didn't break the ToS. I haven't done it, but the fact that my GV messages were listed as "Text/Instant Message" does that mean using an AIM app would also charge me? Even though I paid for unlimited data?

    As usual, the AT&T reps didn't know anything about Google Voice, or Android. Today I put a block on both my phones so that neither of them can receive text messages (I didn't know it was one of the few services that was offered for free). However, I was able to send and receive two Google Voice messages even after the block was enabled, so does this mean I will be charged again? Or perhaps the SMS block will block the portion of Google Voice considered as "text"?

    I have heard people in the past use Google Voice successfully without a text plan, and would like to know if AT&T has found a way to charge for it.

    Any thoughts would be appreciated.
     

    Advertisement
  2. labwizard

    labwizard Active Member

    Joined:
    Mar 10, 2010
    Messages:
    42
    Likes Received:
    2
    Make sure the notification by SMS is turned off in the app or VZ is still being used for that and you will get dinged.
     
  3. Tre Lawrence

    Tre Lawrence Well-Known Member

    Joined:
    May 24, 2010
    Messages:
    1,527
    Likes Received:
    259
    AFAIK, this is correct.

    Turn that setting off; every time you get a GV text, you are probably getting a text on your phone informing you of the received text.
     
  4. takeshi

    takeshi Well-Known Member

    Joined:
    Dec 6, 2009
    Messages:
    3,354
    Likes Received:
    281
    Turn off not only the SMS voicemail notifications (if on) but SMS forwarding as well. Most people seem to miss one or the other. Hit the full GV site and check under the Phones tab as well as the Voicemail tab in Settings.

    Make sure you're only texting via the GV app.
     
  5. Vegeta

    Vegeta Member This Topic's Starter

    Joined:
    May 22, 2010
    Messages:
    6
    Likes Received:
    1
    I just checked my settings and they appear to have been correct, but I could be missing something.

    Voicemail is set to E-mail me a notification, but the SMS notification is NOT checked. However the transcribe option is checked (as it is very useful), but from what I understand that the transcribe option uses the notifications of what you previously selected above it for voicemail notification, which is still just E-mail.

    As far as SMS forwarding goes of Google Voice text messages, I don't see the option in the GV app to forward or turn off forwarding. I message my girlfriend's GV number (not the actual cell) and she does the same for me. We both only message using the GV app itself.

    If any of you have a Nexus One, could you tell me how to check the SMS forwarding of the phone itself? I go the GV app and press the menu button>settings, but there is nothing there about it.

    I'm not how other Android phones work, but when you setup the Nexus One, you can set your phone so that you can make calls or texts from your Google Voice number, without having to dial the special number, or text a friend's special number. I'm not sure if that has anything to do with it though, because again, we used the GV app itself, not the default texting/messaging app.

    I went to my messaging app when I first got the service and turned off the option to "auto-retrieve messages", but apparently that didn't matter.

    I am hoping though that even there is an option I am missing and it is sending some SMS message behind the scenes, this text block will stop me from incurring 20 cent charges a message, unless they actually do charge for instant messages (which people at the AT&T forums say they do).

    In the mean time, I think I will try out the neglected Google Talk app, to see if that fares any better, at least until I figure this out.
     
  6. Tre Lawrence

    Tre Lawrence Well-Known Member

    Joined:
    May 24, 2010
    Messages:
    1,527
    Likes Received:
    259
    Interesting. Forgive me if I missed it, but do you use an IM program?
     
  7. subsynth

    subsynth Active Member

    Joined:
    May 20, 2010
    Messages:
    25
    Likes Received:
    2
    The SMS Notifications is under
    Menu>Settings>Synch and notifications

    make sure notifications via SMS is NOT checked
     
  8. Vegeta

    Vegeta Member This Topic's Starter

    Joined:
    May 22, 2010
    Messages:
    6
    Likes Received:
    1
    @Tre Lawrence Nope, I have been using Google Voice, which actually should be like a regular IM client, but since I'll be using Google Talk temporarily, that is an IM client.
     
  9. Vegeta

    Vegeta Member This Topic's Starter

    Joined:
    May 22, 2010
    Messages:
    6
    Likes Received:
    1
    @subsynth Those exact options are not available to me.

    If I am on the home screen, press the menu button and select settings, here are my options:

    Wireless & networks
    Call settings
    Sound & display
    Location & security
    Applications
    Accounts & sync
    SD card & phone storage
    Privacy
    Search
    Language & keyboard
    Dock
    Accessibility
    Text-to-speech
    Date & time
    About phone

    The closest one is Accounts & sync, however that only have two options which are already enabled.

    Background data: Applications can sync, send, and retrieve data at any time.

    Auto-sync: Applications-sync data automatically

    The latter then shows twitter, facebook, gmail, and Last.FM as applications that are currently using the auto-sync. It would appear that this only has to do with the data network, no options or anything about SMS, not even the default messaging app is listed here, so that rules out that even if that reason/option was the case, the app isn't listed.

    But thanks, it was worth a shot.
     
  10. Racerx2oo3

    Racerx2oo3 Member

    Joined:
    May 6, 2010
    Messages:
    19
    Likes Received:
    5
    You're looking in the wrong area. Open Google Voice, then press Menu which should bring up the menu for GV. Settings >> Sync and Notifications.
     
  11. warren2781

    warren2781 New Member

    Joined:
    May 28, 2010
    Messages:
    1
    Likes Received:
    0
    what happened is this. when you recive a sms on google voice it pushes it to you by email or sms to your real phone number, you can change this option from the app.

    google voice --> settings --> sync and notifications --> notifications via sms (uncheck)
     
  12. 0sync0

    0sync0 Well-Known Member

    Joined:
    May 22, 2010
    Messages:
    107
    Likes Received:
    0
    On my N1 I have 'refresh & notification' but there is nothing about sms in there.
     
  13. applejosh

    applejosh Active Member

    Joined:
    May 23, 2010
    Messages:
    30
    Likes Received:
    3
    Have you checked the marketplace to see if there is an update? I seem to recall one lately. I have the option mentioned earlier. Also, could be that google voice checks to see if it can actually send you an SMS, and if it can't, the option might not appear. Don't know if that's part of its logic or not. Just guessing. Also, I think you can use a computer to go to your google voice account and turn off SMS notifications there.

    As far as IM counting as a text message, it depends on the app and the phone. "Dumb" phones kind of fake AIM, Yahoo Messenger, etc. by using text messages to and from some sort of proxy, IIRC. So those do count. Smartphones generally just use data, but again, it would depend on the app (although I don't recall seeing anything in recent memory that uses SMS). Being new to Android, I could be completely incorrect on this. My experience is mainly with BlackBerry and iPhone.
     
  14. DrScrubs

    DrScrubs Well-Known Member

    Joined:
    Apr 12, 2010
    Messages:
    126
    Likes Received:
    11
    Are you getting a duplicate text message when someone texts your GV number?

    Sign into the GV website. Go to settings in upper right corner. Under phone tab (should be the default tab showing) click edit. Uncheck the box next to "Text Settings" that says "Receive text messages on this phone (mobile phones only)"

    That solved the problem for me.
     
    applejosh likes this.
  15. Tre Lawrence

    Tre Lawrence Well-Known Member

    Joined:
    May 24, 2010
    Messages:
    1,527
    Likes Received:
    259
    Well said.

    Completely forgot about this tweak... it was so well hidden when I was having the issue.
     

Share This Page

Loading...