Google Wallet Secure Element Not RespondingGeneral


  1. Extract0r

    Extract0r Well-Known Member

    [​IMG]

    My 2 day old phone started acting up this morning. It got turned off and died while being charged overnight. I couldn't revive it with the power switch and had to pull the battery to reset. Then I noticed that the GMail notification wasn't working for some reason. After trying different tweaks for a few minutes, I decided to do a factory reset of the device.

    After the reset and registration, I ran the Google Wallet app and was treated to the "Secure Element Not Responding" error. I called Google Wallet support team and was told that there is no fix and I need to get a replacement phone through Samsung or return the device for refund.

    WTF is up with this? After returning the first unit with a orientation sensor that got messed up which couldn't be recalibrated, now my second phone has to be returned again.

    I am almost ready to quit this Android experiment and go back to the Dark Side.

    Advertisement
    :
  2. forumandroid

    forumandroid New Member

    hey. did you try the droidhive post ?
  3. forumandroid

    forumandroid New Member

    drbugsmn likes this.
  4. drdoom

    drdoom Well-Known Member

    I'm sorry to tell you that despite multiple attempts from the development community, I'm not aware of a fix for the "Secure element not responding" error. It is a security measure to ensure that no one tamper with the NFC chip on the phone and gains access to your money. You will have to get a new phone for the problem to be resolved.
  5. WOW! I can't wait to try davy917's solution! I had given up hope long ago for this. :( Have we gotten feedback about this method working for other people?

    (Finally: the reason I've been needing to root!)
  6. Extract0r

    Extract0r Well-Known Member

    My phone with the self-destructed secure element is back to Google for refund.
    If I buy another one, I'll just disable the NFC antenna and never use Google Wallet.

    I still can't understand why these companies are spending billions of dollars for mobile wallet solutions. It is far more convenient for me to just take out my credit card and swipe it than having to worry about potential security breach or self destruction of my phone.

    They are trying to fix what is not broken. Maybe they are just preparing for the days when the NWO require that everyone gets RFID chips implanted by law.
  7. gregs887

    gregs887 Well-Known Member

    I have only heard of that happening when flashing new ROM's without wiping the Google Wallet information first. Are you rooted and unlocked?
  8. Extract0r

    Extract0r Well-Known Member

    I bought the unlocked version direct from Google. The phone was never rooted and never tempered with in any way.

    The only thing I did was factory reset. I ran the Google Wallet app after the reset but before the Wallet s/w update. Maybe running the older version of the program is what confused the phone and triggered the self-destruction of the secure element.
  9. gregs887

    gregs887 Well-Known Member

    Did you wipe the google wallet information in app before you did the reset? Maybe that borked it? That's a bummer man :(
  10. Extract0r

    Extract0r Well-Known Member

    No I didn't wipe the wallet before the factory reset. Real bummer...
Loading...

Share This Page