1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Got a new Market app, now I cant install anythingSupport


  1. Esp_McLee

    Esp_McLee Member

    Phone: i7500
    ROM: Galaxo 1.6.3.4
    Baseband: JC6

    With that out of the way, let me explain: A few weeks ago it seems my Market app had been updated, because I got a new and more glossy icon for it. Then, a week or so later, I and everyone else in Norway was able to finally buy and download paid apps, so far so good. But then a few days ago, all of a sudden I am able to set apps to auto update and "Update all" on the Downloads screen, so apparently I have received a new update for the Market app.

    However, since this last update (if that is what it is), every time I try to update or download a new app it "Starting download..." for a bit, then fails with the message "Download was unsuccessful, please try again."

    But no matter what I try i just wont do it whether it's on 3G or wifi.

    Any ideas? :(

    Advertisement
    :
  2. Shorrack

    Shorrack Well-Known Member

    I got that issue too, not sure what did the trick but I cleared market's cache and also fixed perms/filesystem in recovery
  3. Esp_McLee

    Esp_McLee Member

    Update: Seems I can install paid apps as normal. Just not the free ones. I'll try to clear cache and maybe fix permissions.
  4. Esp_McLee

    Esp_McLee Member

    Clearing the cache didn't help, neither did "check /data filesystem" (or something like that) and fixing package permissions. Did you clear any other cache than the one on "Google Market"? Seems there's a ton of apps related to the market, but very few with cache.
  5. Shorrack

    Shorrack Well-Known Member

    can't honestly remember, got couple apps stuck on "starting download" atm :p
  6. Esp_McLee

    Esp_McLee Member

    I found the problem after a bit of research around the Google support forum where there is a sh*tload of users reporting the same issue. It was indeed the latest (silent) update that caused it and I was able to uninstall that update from the same place that I can empty the cache. Problem solved, although it would be nice to have that "update all"-button :)
  7. loopyjump

    loopyjump Member

    hi i have samsung galaxy and have the same problem. Right from the off I haven't been able to download apps. ( only had phone for 4 days!!!!)

    Not much of a techie person. Please can ou explain where I will find this 'cache' so taht I can uninstall whatever it is that is stopping the downloads.

    Ta muchly!!
  8. Esp_McLee

    Esp_McLee Member

    Go to Settings -> Applications -> Manage applications, then find "Market" in the list and tap it. In there you'll have a "Clear cache" button and possibly an "Uninstall update" button. Try the cache first. If that doesn't do the trick, try to uninstall the update. That certainly fixed it for me.
  9. loopyjump

    loopyjump Member

    hi thanks for the laymans version. Given it a go (several times!) but does not seem to make any difference. Can't find an update to install. There is an option to force stop, but a little hestitant to try that as I have no idea what it will do.

    Thanks for your help so far - any other advice gratefully received!!
  10. Esp_McLee

    Esp_McLee Member

    Force stop just terminates the process. Handy if it's completely locked up for some reason (although if that happens you usually get a dialog telling you it has done so). Mostly harmless.

    Is the problem that the download fails with an "unable to download" error or that it just stalls at "Starting download" and never moves on?
  11. MichaelW

    MichaelW Well-Known Member

    Is there anyway to update to the new market manually?
  12. loopyjump

    loopyjump Member

    It stalls at, "starting to download" and never seems to move on.
  13. Esp_McLee

    Esp_McLee Member

    Dont think do, but I just noticed I've been updated to the new one yet again, but this time it worked nicely with free apps as well :)

    Yeah, I (and I suspect most others) have that problem now and then. Have you tried using both 3G and wifi?
  14. maurinet

    maurinet Well-Known Member

    I had the same problem and I had to do the following to "solve" it:

    -Disconnect phone from wifi and 3G
    -Uninstall market update
    -Clear market cache
    -Force stop market
    -Connect to the internet
    -Start market again

    I tried a bunch of other things but that's the method that worked for me. I'm back to the old version of the market and I've also read in different forums that there's no way of manually updating, but that it will silently update the market version again... some time in the near future (still have the old app after 2 days.)

    Hope this helps you out,
  15. Willd

    Willd Member

    Uninstalling the update worked fine for me :)
  16. Hok

    Hok Member

    I did it, bud it doesn't work. It stalls at "starting download" again :(
  17. maurinet

    maurinet Well-Known Member

    Try this:

    Connect your phone to the charger
    Go to Settings, Applications, Development and check "Stay awake"
    Make sure your phone is connected to wifi or 3G,
    Then go to the market, go to "Downloads", click on the app that you're trying to download and click on "Cancel download", then click on "Download update" and let it run, be patient, sometimes it takes up to 5 minutes for the download to start.

    I hope this works for you,
  18. Frojd

    Frojd Well-Known Member

    I got a new market update today which has been working flawlessly so far (uninstalled the previous update).
  19. Hok

    Hok Member

    I did it and after 15 minutes there is still "starting download". I tried few wifi networks and it works only on school wifi :(
  20. maurinet

    maurinet Well-Known Member

    Have you tried to download applications through 3g? If it does work on your school wifi, it could be something I read about a while ago in a forum post. It said something about the Galaxy having problems connecting to b, h or n wifi routers... i really can't remember which.

    Can you browse the internet? Can you access the internet using other apps (like twitter, facebook, foursquare, etc.)?
  21. Hok

    Hok Member

    I don't have 3g. All apps works fine and it's not problem with b, h, n connection, because I changed it and it still doesn't work
  22. maurinet

    maurinet Well-Known Member

    It seems like the problem is in your market app.... hard to tell what to do next, perhaps you can try using yaam (yet another android market), or getjar, or applanet... those are alternative markets for Android.
  23. Hok

    Hok Member

    I also use yaam and it works, but there is only few apps :(
  24. r3dpuma

    r3dpuma Well-Known Member

    ok the solve is to unistall the market update, but the problem is that it silently updates by itself everyytime i start it :| its annoying to keep uninstalling the updates everytime.
  25. Hok

    Hok Member

    it may be good solution, but it updates faster then I can find anything to download :D
Loading...

Share This Page