1. Tablet future looks bright! Read more about: Alcatel Xess | Samsung Galaxy View
    New Forums: Alcatel Xess | Samsung Galaxy View
    Dismiss Notice

[GPL] LG Ally Kernel 2.6.29.6_GNM_OC


Last Updated:

  1. icon123

    icon123 Well-Known Member

    What version of .3 would I want to install using this kernel. The normal download link with the Gridlock kernel or one of these that are listed on the Velocity page:

    -GNM Overclock Kernel:
    Information
    Download Version Adapted for Velocity V0.3

    -GNM Turbo 4:
    Information
    Download Version Adapted for Velocity V0.3 (with kernel)
    Download Version Adapted for Velocity V0.3 (without kernel)

    I'm assusming I would want to install the Turbo 4 without kernel and then install this new kernel afterwards.

    Advertisement
  2. kicker07cvr12

    kicker07cvr12 Active Member

    I got a question bout over clocking... I installed the kernel and then used overclockwidget. I have it set on 729 and i keep getting kernel panic.. could this be from using the widget and not setcpu?
  3. motorsport226

    motorsport226 Well-Known Member

    Correct.
    icon123 likes this.
  4. motorsport226

    motorsport226 Well-Known Member

    Possible but unlikely. It's most likely that your phone cannot handle the overclock.

    Overclocking is unique to each phone. Some can handle 787 with no problems, some cant OC at all.

    But it's worth giving setcpu a shot, if it doesn't work you can always get a refund.
  5. kicker07cvr12

    kicker07cvr12 Active Member


    That is a gooood idea... Thanks! I had it set at 729 for a few hours and it seemed to work good there but i still dont seem to be gettin any performance boost.

    Maybe setcpu will help out.
  6. motorsport226

    motorsport226 Well-Known Member

    Glad I could help, let me know how it works.
  7. Trident

    Trident VIP Member VIP Member

    Nice job! :D

    This thing is super fast and great on battery.

    Thinking of including this in Velocity V0.4..
  8. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    In my turbo4 kernel i had a modified ramdisk that had the low mem killer levels upped very much from stock around 60mb floor I believe. Its done in init.rc btw. This one had no ramdisk so you have it at stock empty app floor of 24mb as per your ramdisk. Thats how well its holding its lower limit with .32 kernels low mem killer. And as to performance turbo4 pushed the ally all the way to its current limit. I do agree performance is a little down in quadrant but this kernel addresses some other things the ally needed like battery and memory usage while still having a noticable gain from stock performance to more round out the device in other areas too.
  9. kicker07cvr12

    kicker07cvr12 Active Member

    It is doing better and still trying out the different scaling options. If i clock it over 729 it panics within minutes. Seems to be helping the battery some. Any suggestions on what kind of profiles/governors to set?

    Best setup so far was Max 729 Min 320 with ondemand. Ive tried some of the other scaling options but havent figured out what to do with the advance settings. It always seems to work for awhile but then i will notice lag eventually. What has been working for everyone? Just curious to see how other people are tweaking and what works and doesnt.... Thanks for helping a nooob.
  10. dumbteentarget

    dumbteentarget Well-Known Member

    i flashed the new kernel but forgot to wipe both dalvik cache and cache. i ran the kernal all day and it seemed slower than the turbo4 adapted for velocity. would that problem be because i forgot to wipe the caches?
  11. darkxsun

    darkxsun Well-Known Member

    You can always go back to recovery and wipe them and find out...
  12. dumbteentarget

    dumbteentarget Well-Known Member


    well i already put the other kernel back on so i thot id ask on here instead of going through the trouble again but it seems like ill just do that and find out.
  13. motorsport226

    motorsport226 Well-Known Member

    I completely agree. Responsiveness is definitely up, and I have noticed an increase in battery life as well; and I was already getting around 40 hours average on a full charge with moderate to heavy use.

    Also, the interactive governor in setcpu is performing very well, it's doing everything that you said it would, most notably being the the increased ui responsiveness.

    Another amazing job drell, I appreciate all of your hard work, donation will be sent soon.
  14. motorsport226

    motorsport226 Well-Known Member

    I've been using the interactive gov that's new for this kernel. Haven't tweaked any advanced settings yet, just kinda been letting it do its own thing and see how it goes for the first few days.

    I did notice a performance increase switching from ondemand to interactive, even with a stable 787oc, give it a shot and see if it calms things down at all. And if not then stick with 729 on interactive. I mean, it still linpacks around what, low-mid 7's on 729? Not too shabby at all. :cool:
  15. dumbteentarget

    dumbteentarget Well-Known Member


    how are you getting 40 hours???? we are talking about the same phone right? LG ally? im lucky if i get 15.
  16. mxc1090

    mxc1090 Active Member

    lol I get 8 with heavy use and 15 with moderate. Unless he has the extended battery and dosen't use GPS, E-mail, Maps, texting, talking, chatting, then I don't know how that is possible.
  17. motorsport226

    motorsport226 Well-Known Member

    Yep, my longest time since unplugged was around 52 hours.

    You probably have the 50% bug. Go to settings>about phone>battery use>cell standby. Check what the time without a signal percentage is, if it's over 50% then its the bug.

    What this means is that your phone is searching for a signal even when you already have one. This wreaks havoc on your battery.

    There is a quick fix that has worked well for me: turn airplane mode on for a few minutes and turn it back off, see if the percentage starts to go down. If not, turn on airplane mode, reboot the phone and turn airplane mode off. It might take a couple tries but its never failed to work for me.
  18. warttack

    warttack Well-Known Member

    Sorry to say this drellisdee but freezes a lot here. I dont know whats the problem. I'll try reinstalling again and see what happens.

    VZB deodex'd, Turbo 4 no kernel and 2.6.29.6_GNM kernel.

    I will check and see if anything changes
  19. dumbteentarget

    dumbteentarget Well-Known Member


    Ok thanks. I'm gonna look into that right now

    EDIT: I did what you said, airplane mode then restarted the phone and now its been running almost an hour and the time without a signal is around 25%. before i restarted it, it was at 85%. What is it typically at cus it seems like its just going to creep back up there. How often do u have to do the airplane mode thing to get rid of it? it doesnt seem like a one time fix.
  20. icon123

    icon123 Well-Known Member

    Anyone else having a problem with the calcualtor? Using Velocity .3, Turbo 4 - no kernel and the kernel in this thread. I remember we had a similar problem with this before.
  21. dumbteentarget

    dumbteentarget Well-Known Member


    I was having calculator problems before with velocity3 and turbo4 with kernel so I just deleted the calculator.apk file. There are other calculators u can download from the market.
  22. darkxsun

    darkxsun Well-Known Member

    Calculator works for me on vB with JIT4 (this one comes with a recompiled calculator.apk).

    Try flashing the JIT library again (turbo4)
  23. warttack

    warttack Well-Known Member

    ok so i changed the turbo4 ramdisk with the normal vzb app2sd and flashed the 2.6.29.6_GNM and now its working fast, no freezing. I will keep testing, if anyone knows why turbo4 ramdisk and 2.6.29.6_GNM was freezing let me know.
  24. motorsport226

    motorsport226 Well-Known Member

    Mine usually stays down as long as the phone is on the same boot. If my battery dies or I have to reboot for any reason it might start the bug again.

    Just keep an eye on it and try the airplane trick until it sticks. Of course, if you live in an area with a bad signal then there might not be a fix.
  25. dumbteentarget

    dumbteentarget Well-Known Member


    yeah, reception isnt the best at my house. I also tried this:

    How to Fix the 50% dreaded bug on LG Ally - LG Cell Phones Blog

    which has seemed to work but ill find out for sure in the next few days.

Share This Page