GPS (and Wifi) not working? Here's the fixTips


  1. bigbadwulff

    bigbadwulff Well-Known Member

    Stick with me because this is gonna sound like voodoo!

    - Get 'GPS Test' app (this does not fix anything but allows diagnosis of signal quick and easily).
    - Go outside
    - Turn on app
    - Press on the top left of the battery cover(looking at the back of the phone).
    - watch for signal to magically start working when you press at the right spot with the right amount of force.

    After much trial and error I duplicated the place and the amount of pressure it took to make things work by placing one small, square 3M foam strip on the OUTSIDE of the battery cover or inside a phone cover. Now, when you place a tight-fitting cover over the phone things will work.

    I tried all sorts of fixes by trying to put things INSIDE the battery cover and nothing worked(for me).

    I find it amazing this phone has a bad physical connection somewhere that this fixes the problem. Oh well. After 9 months of no GPS, I have it again. Saved me from buying a new phone.
    P.S.: It will help WiFi signal also.

    My nasty old phone cover, complete with it's 'GPS/WiFi fixer':
    [​IMG]

    Advertisement
    :
    jroc, iron_city and javamann like this.
  2. jsbeagle

    jsbeagle New Member

    I had this exact same problem. When my wifi stopped working as well is when I decided to do something about it. I too could squeeze on a corner to get it back working.

    I googled all over and finally found the suggestion that some of the screws may be loose. I found a disassembly video on youtube and some small torx drivers. It was a little nerve wracking having my DX in pieces, but I did find some screws loose. After I put it back together, its worked perfectly ever since.
    iron_city likes this.
  3. TommyVee

    TommyVee Active Member

    I was referred to this post and I was about to get a new phone.(Droid X) The squeeze worked!

    I found the right spot, right under the red battery pull flap. I stacked three pieces of the stiff page divider tape and cut out a small piece that fits just under the flap. Bingo! My GPS is back. Thanks Wulff!
  4. bigbadwulff

    bigbadwulff Well-Known Member

    Glad I could help. I tightened all my torx screws and it did not help. Bent the connection tabs and maybe a little help. The foam strip is still there doing it's job....lol.
  5. puchecobubu

    puchecobubu New Member

    how I can unlock my verizon motorala droid,,,would like to use as just the gps, it will work from home opening my home wireless internet,,,but when get where I'm going and try to come back,,,,gps won't work,,,looking for a service it will show up and nothing will come up,,,I guess is looking for verizon service to work. anyone HELP!!
  6. bigbadwulff

    bigbadwulff Well-Known Member

    Try fiddling with what I did. Sounds like the phone connections are losing connection periodically. Mine will still do it even with my little 3M pad in there. But now that I have continued to mess with it, that is a rare event.
  7. Missinyous

    Missinyous New Member

    My droid X wifi had ben driving me crazy! I live in a no service zone and wifi is important.. My phone would cut in and out not to mention I have to be in the same room as the router for it to work. I tried your trick and it works beautifully! I was ready to get a new phone out of frustration but I love my x. My husband had one and had no issues with wifi so I knew it was my phone... Anyway to shorten my thank you... Well, thank you times a million. Saved me a ton of money and it was fast and easy. Who knew?
  8. bigbadwulff

    bigbadwulff Well-Known Member

    Just trying to help out fellow DXers. Glad it worked for you. BTW my pad is still on the same, nasty cover and working beautifully.
  9. PaulaSM

    PaulaSM New Member

    Unbelievable!... I went to Verizon for help and they somehow fixed my problem, but then it got back to what it was... My Droidx now has its patch and is working fine... Man oh man... It took me 3 weeks to get this solved... Thanks so much!
Loading...

Share This Page