GPS Apps Not Working ProperlySupport


Last Updated:

  1. bblanchette007

    bblanchette007 Member This Topic's Starter

    Joined:
    Apr 7, 2012
    Messages:
    5
    Likes Received:
    1
    Having troible with my Motorola RAZR MAXX. All of my GPS related apps don't work right and freeze intermittently - Google Navigation and All Sport GPS to name two in particular. I get a lock in most apps in 3-5 seconds. However, the app doesn't seem to maintain my location.

    There is a bike path I ride that I track with AllSport GPS. My old phone (original Motorola Droid) holds signal fine and very accurately tracks my location, distance, speed, etc. On the RAZR MAXX I lose the tracking very soon in ride and it never re-locks and tracks. Google Navigation does same thing. I get my directions and start driving fine but the the program just stops working.

    I don't know if it is coincidence or not but I noticed these areas fluctuate between 3G and 4G. I tried turning off CDMA/LTE to CDMA only, turning off WiFi, etc and none of these things seems to work.

    Anyone have any thoughts on a setting that may be causing this? Old DROID was fine with all of this stuff. Wasn't expecting this problem with aa new, up to date phone. Frustrating.
     

    Advertisement
    PeninaD likes this.
  2. naskron

    naskron Member

    Joined:
    Apr 3, 2012
    Messages:
    7
    Likes Received:
    0
    I am having this same problem, in for answers.
     
  3. jmack356

    jmack356 Active Member

    Joined:
    Jun 27, 2010
    Messages:
    25
    Likes Received:
    1
    There's a couple of really good GPS apps, GPS Status & GPS Test Plus, that will calibrate your GPS and make it much faster and more accurate...
     
  4. BillArf

    BillArf Well-Known Member

    Joined:
    Aug 7, 2010
    Messages:
    198
    Likes Received:
    83
    I have 3 Razr Maxx's in the immediate family. Since the Ice Cream Sandwich (ICS) update all three Maxx's have issues when you try to turn on the GPS. You activate the GPS and the GPS turns on and sees satellites and will not acquire them until you toggle Bluetooth on and off until finally, finally the GPS will acquire those satellites and you can use the GPS. A real pain in the neck ....

    Anyway, I installed an app call GPS TEST and once installed I then went to its menu and selected upgrade. Was charged $3.99 for the upgrade to "GPS Test Plus" . After the upgrade, I had to delete the free version of GPS Test that remained on the phone. Anyway, low and behold my GPS started working perfectly. Acquires satellites quickly, just like it did before the ICS update. I did this same regimen on the other 2 Maxx's in the family and the app fixed those GPS also.. Just figured I would report this here. Again, fixed all three Razr Maxx's so I'd say it should be almost a sure thing it will fix your Maxx also. Remember, install free GPS Test app first and then upgrade from within the app and then delete the free GPS Test. This is the regimen that I did and I know that doing this works. I do not know if you just install the paid version GPS Test Plus, first whether it will fix the GPS.

    If other here try this, report back here your results. I know I am really really happy the app fixed the three Maxx's we have as we all use the GPS lots..
     
  5. bblanchette007

    bblanchette007 Member This Topic's Starter

    Joined:
    Apr 7, 2012
    Messages:
    5
    Likes Received:
    1
    My issue is not getting a lock or the accuracy of the lock. I get a very fast and accurate lock. However, 4-5 minutes into the ride or navigation the app stops recording/updating. I'm wondering if something with the screen time out is the issue or if the phone stops the process to save battery life thinking the app is no longer being used.

    I turned off 4G the other day and the apps get an excellent lock but still stop working after awhile. When 4G is on the weather widget on my home page doesn't update, Google Navigator takes forever to download directions and AllSport GPS still stops working.

    No one has any ideas??
     
  6. natemail

    natemail New Member

    Joined:
    Apr 14, 2012
    Messages:
    1
    Likes Received:
    0
    Hey Guys, Just got my Maxx came up from the original droid. Same issues!!! Things I used my droid for constantly seem to have trouble on the Maxx, sometimes I cannot receive a lock at all and have to reboot for my Google Nav to work. I'll be trying those apps suggested above. Anyone also having issues with network connection? On several occasions I get network connection airs when full bars 4g, need to reboot to solve as well.
     
  7. strouja

    strouja Member

    Joined:
    Apr 14, 2012
    Messages:
    5
    Likes Received:
    0
    I have the same issue with the navigation it just stops working in the middle of navigating to a location. It simply gets stuck. If I exit and re-enter navigation it starts working again but only for a few minutes before it stops again. It used to work just fine, this issue has come up in the last 2 months or so I have no clue. I have the motorola razr max as well, running droid 2.3.6, google maps version is 6.5.0 and I'm using verizon wireless
     
  8. jag164

    jag164 New Member

    Joined:
    Aug 26, 2010
    Messages:
    2
    Likes Received:
    0
    It's might not be GPS that is your underlying problem. Pay attention to your bars when navigation 'locks up'. If they go from blue to white, then you've got cell signal but not a "handshake" with you carrier so your data connection will drop and you navigation app will stop updating. Other threads have indicated this is affecting a handful of people and the causes have ranged from bad sim cards, typical 4G drop outs, and bad phones.
     
  9. bblanchette007

    bblanchette007 Member This Topic's Starter

    Joined:
    Apr 7, 2012
    Messages:
    5
    Likes Received:
    1
    If the issue is simply flipping back and forth from 3G to 4G if I switch data mode to CDMA only (as was suggested in another post) will that fix the problem provided the SIM card/phone is not bad?? I've tried every other thing I can think of to fix (turning off security lock, screen time out, WiFi, etc). If I am not in a 4G area (which) I am not most of the time should I be getting this problem??
     
  10. Sharondippity

    Sharondippity Dismember VIP Member

    Joined:
    Apr 25, 2010
    Messages:
    999
    Likes Received:
    493
    This happened to me in February also, I lost my signal in the middle of nowhere, boy was I nervous. I took a road trip to Scottsdale from San Jose, I was way out in farmland when my GPS failed. Had three to four bars on phone.
     
  11. bblanchette007

    bblanchette007 Member This Topic's Starter

    Joined:
    Apr 7, 2012
    Messages:
    5
    Likes Received:
    1
    I was a passenger for several hours in car today so I messed around with just about every setting this phone has during the drive. About a week after I bought the phone I added the weather widget to my start page. It serves up forecast, etc using GPS for current location.

    I dragged the widget to the recycle icon and the problem is gone. Used AllSport GPS several times today and it is totally fine again. Took a mountain bike ride tonight and it tracked flawlessly for the 27 minute ride. Going to try Google Navigation again on another drive but I am confident this solved my problem.

    If you have the weather widget on your phone try getting rid of it and see if that takes care of it. Hopefully it does.
     
  12. AndroidPhinatic

    AndroidPhinatic Member

    Joined:
    Jan 24, 2012
    Messages:
    19
    Likes Received:
    1
    If I use Google location services the Google Navigation works fine, I went to several locations with it and it was fine. When I had previously used GPS navigation I had the same problems as the users mentioned. Eventually with GPS location services on and Google Navigation the phone got very hot and rebooted. I got to the first site fine, but then it could not relocate again to leave.

    So my suggestion is don't use the GPS but use Google Location services instead.
     
  13. strouja

    strouja Member

    Joined:
    Apr 14, 2012
    Messages:
    5
    Likes Received:
    0
    It's been a month and I still have the problem. It makes it not practical to use the phone navigation (which I used to love to do). I noticed I have Google Location Services checked already (under Settings .. Locations & security services ...). So for me checking that won't remedy the problem as AndroidPhinatic suggested. I will attempt to change my phone to only use CDMA data when I use GPS.

    This type of problem is exactly why I recommend the iPhone to folks. I doubt iPhone users would have as many headaches like this or ones that last as long.

    Since I posted about a month ago I had a major update to the phone from Motorola I believe, and an update to google maps but this did not solve the problem

    Currently my versions are:
    Google Maps 6.6.0 (#6060015) gmm-androd-motorola
    Android version 2.3.6
    System version 6.12.181.XT912.Verizon.en.US
    Webtop version WT-2.0.0-139
    Kernel version - 2.6.35.7-g65de91dqgd748@il93nxdroid10 #1
    Build number 6.5.2-267_DHD-14_M3-8
    Build Date Thu Mar 8 12:33:02 CST 2012
    ERI version 5
    PRL version 15109
     
  14. daren01

    daren01 New Member

    Joined:
    May 21, 2012
    Messages:
    1
    Likes Received:
    0
    Hi,

    I have had the same problem with my navigator freezing on me constantly. I already had google location services enabled and I decided to try disabling it. I previously had VZW location service disabled and I enabled that (provides tower triangulation to determine your location). I'Ve always had the GPS standalone service enabled and I left that as is. So now I am three days post doing this (having only GPS and VZW location services enabled) and I have had not had any problems whatsoever and I have been trying to use navigation every time I get in my car. This could be coincidence but I am also noticing that I am staying locked into 4G much better! actually I have yet to see a switch to 3G, which used to happen a couple times a day, and no outright data drops which seem to happen when I'm using a data intensive app while on 4G and my signal is week.

    Hope this helps others, let me know if does

    Regards,
    Daren
     
  15. Neocyberdude

    Neocyberdude New Member

    Joined:
    May 30, 2012
    Messages:
    1
    Likes Received:
    0
    I'm having the same exact problem. I'm going to try Daren's suggestion and turn off Google Location Services. I'll post again when I've tested it. I hope this works--I'm deploying about 20 of these devices at the company I work for and I'm one of the people they'll come to with problems.
     
  16. ckali7

    ckali7 Well-Known Member

    Joined:
    Jan 12, 2010
    Messages:
    124
    Likes Received:
    8
    Having the exact same problem, hoping someone solves it soon. Just took my first long trip with my maxx and this GPS issue drove me crazy! Anyone found a fix?
     
  17. vanderjdm

    vanderjdm New Member

    Joined:
    Jun 11, 2012
    Messages:
    1
    Likes Received:
    0
    I did the same today (removed the weather widget) and my GPS works fine now too. Google Navigator would freeze up after a minute or two while that widget was still setup on my phone. It must really mess with the GPS tracking.
     
  18. JamesSJ

    JamesSJ Well-Known Member

    Joined:
    Sep 15, 2011
    Messages:
    131
    Likes Received:
    13
    Which weather widget?
     
  19. zork2112

    zork2112 New Member

    Joined:
    Jun 14, 2012
    Messages:
    1
    Likes Received:
    0
    About a month ago I started having the same problem on a Razr Maxx. I was using CardioTracker pro and it kept locking up the GPS. I uninstalled that and it worked fine until a few days ago when I installed BeWeather widget. Again it locked up. I've uninstalled it and will try again. I read somewhere that some older apps/widgets use a kind of "hack" for accessing GPS and that it might not work with the newer systems.
     
  20. strouja

    strouja Member

    Joined:
    Apr 14, 2012
    Messages:
    5
    Likes Received:
    0
    I tried everything I can think of. I uninstalled whatever weather apps i bought, and downloaded for free. I just kept WeatherBug elite on my phone. I put in the trash the weather widget that was on my homescreen. Nothing works. I even tried uninstalling google maps but was not able to, I just un-installed the latest updates of google maps. I was going to uninstall google maps and re-install it to see if that would help. Still that My next move is to bring phone to verizon and ask for the Samsung Galaxy as a replacement.

    After driving a few miles the navigation freezes. Very frustrating.
     
  21. strouja

    strouja Member

    Joined:
    Apr 14, 2012
    Messages:
    5
    Likes Received:
    0
    Finally this got fixed. Well after my Android update to 4.0.4 (Ice Cream Sandwich) my GPS navigation issue was resolved. I've tested it pretty thoroughly and even put my weather widgets back on my phone and home page. I've driven hundreds of miles and gps navigation keeps working, just like it did when I first got my phone.

    So I never switched phones and kept this w/ a broken navigation for about 6 months till it got "fixed" James
     
  22. dkittell

    dkittell New Member

    Joined:
    Aug 21, 2012
    Messages:
    1
    Likes Received:
    0
    As weird as it is I tried this and like said, I was able get GPS signal again.

    I was using The Weather Channel widget, as soon as I removed it from my screen I was able to get satellites showing in GPS Status.
     
  23. JamesSJ

    JamesSJ Well-Known Member

    Joined:
    Sep 15, 2011
    Messages:
    131
    Likes Received:
    13
    I really like the 3D Digital Weather app. GPS works fine.
     
  24. nsabba

    nsabba New Member

    Joined:
    Sep 26, 2012
    Messages:
    1
    Likes Received:
    0
    :rolleyes:Thanks for that - it worked instantly! But now I have no weather.....
     

Share This Page

Loading...