GPS cache problem workaround, tested, workingSupport


  1. Aero1

    Aero1 Well-Known Member

    Note1: user boomerbubba was extremely helpful in thinking this through
    Note2: Engadet finally posted a link to this workaround after three separate articles in which they completely botched testing of the Epics GPS and showed a total lack of knowledge of GPS systems. Thankfully their otherwise unfortunate readers of their poor "journalism" can at least now get a workaround as well.


    I have three epics and have been testing GPS functionality for two weeks with quite a number of controlled tests.

    As we know there is a problem with old "assistance" (the "a" in aGPS) ephemeris and almanac data in cache. this data can start expiring in a few hours and ephemeris will fully expire in about 8 hours.

    The result is that sometimes users will experience the following symptoms in a GPS fail: the Epic will "see" sufficient satellites (4 to 11) but doesn't "use" them (expired ephemeris) or will see no satellites while under clear skies (expired almanac, rarer).

    Although some user actions or program identified (eg reboot),and unidentified, can apparently flush the old data out of cache so that the network renews it with valid data, this isn't programmed by Samsung correctly and users intermittently are stuck with bad data in cache preventing lock. I have tested a workaround and it works

    TESTED AND FUNCTIONING WORKAROUND:

    Enter GPS debug/settings application by typing *#1472365#
    click "Setup" tab
    click "position mode"
    Click "starting mode
    Enable "Cold Start"
    Back out.

    Epic GPS will now call on data network for fresh valid ephemeris and almanac at every programing invocation of GPS and aGPS fixes will be very fast (usually less than 10 seconds).

    There one downside. while cold start will be effectively warm start in aGPS mode (good). That is it will work very nicely in the presence of a 3G or 4g data connection. But absent data connection, ie in Standalone GPS mode, you will be always cold starting (starting with empty cache), meaning fixes will be 5 to 14 minutes if you are not on the network. If you are going to be off the network for a while you can simply set to warm start from same menu.

    Advertisement
    :
    USN02, Thai, Stringyquark and 5 others like this.
  2. Aero1

    Aero1 Well-Known Member

    please do report your 24 and 48 hour findings here
  3. DILands

    DILands Well-Known Member Contributor

    Where do you start this:


    Enter GPS debug/settings application by typing *#1472365#
  4. redandblack1287

    redandblack1287 Well-Known Member

    Probably in the dialer. I'll try this tomorrow when I'm at my computer and post back.
  5. badankles

    badankles Well-Known Member

    have you tested GPS with latest firmware update?

    the sprint community forum site have updated the list of fixes and it does include GPS, how much, don't know. time will tell.

    Samsung Epic:9/16 - Samsung Epic Maintenance Release...
    Fixes:
    4G de-registration when activating Mobile Hotspot
    Won't maintain Exchange credentials (emails stuck in outbox and disappearing email accounts)
    GPS performance enhancement
    HotSpot 3G Idle Battery Issues
    32GB SD Card Fix - previously when formatting the card, it wouldn't be recognized
  6. jfenton

    jfenton Well-Known Member

    Personally, I think the GPS is no different at all after the D107 update.

    In fact, for the first time ever yesterday, I had issues with GPStest and Sprint NAV even making contact.

    Google MAPS absolutely could not find me (actually had me in TX and I was in MA) even after a battery pull / restart.
  7. Aero1

    Aero1 Well-Known Member

    Yes, I did test it indeed I was lucky as I have three and one updated to new baseline as soon as the baseline came out and one updated 48 hours later. the new baseline (Di07))does still have the sticking cache.

    Also device team indicated to me that they were still testing cache problems after the di07 was first sent to out 10 days ago. (it was sent to test devices a week before)
  8. DILands

    DILands Well-Known Member Contributor

    ugggggggg - I have 3 Bars of service inside my house. GPS and Wireless Networks on - it couldn't find me. Tried Google Maps and Nav - and Sprint NAV!
  9. Aero1

    Aero1 Well-Known Member

    I have a lot of wireless network location/tower triangualtion fail inside my house as well. I dont want to address that in depth in this thread because although it is related, samsung and sprint have confused people a lot with there bogus "fix" of turning on wireless network location which doesn't affect GPS. But GPS can affect wireless networking since a stuck GPS may not fall back as it should to tower triangulation causing your symptom.

    but I will ask you what occurs in that situation if you turn GPS off, and restart Epic, and if you have applied this cold start workaround. also do you or a close neighbor have an airave?
  10. DILands

    DILands Well-Known Member Contributor

    I haven't done it - because I don't know "where to" enter *#1472365#

    I don't have airave - not sure about the neighbors - but - we're in single houses - hopefully, that wouldn't be an issue.
  11. boomerbubba

    boomerbubba Well-Known Member

    In the phone dialer.
  12. DILands

    DILands Well-Known Member Contributor

    DOH - I didn't see the * - thanks!
  13. Flaspeneer

    Flaspeneer Well-Known Member

    People keep saying to enter the text in the dialer because it works. Enter the sequence, including the star and number signs, exactly as you would a phone number. Follow the prompts and then hit the back softkey until you're back to home view. Incredibly simple. Aero1 deserves thanks for his research and help. I'm testing his GPS fix now.
  14. rsage

    rsage Active Member

    Aero1, you are the man. My GPS problems weren't too bad until the D107 update (ironically enough), but your "cold start" fix has cured my GPS (at least in terms of achieving solid lock with satellites-only every time). Perfect lock, perfect nav, My Tracks accuracy seems much better (is this possible from your fix?). I tested your fix under some circumstances that would give my GPS fits before, so far all's well.
  15. Flaspeneer

    Flaspeneer Well-Known Member

    Also: users who are having a problem with their GPS after the fix should remember to switch to warm restart when 3 and 4G networks are off. I mention this because people seem to be speed-reading Aero1's OP and he's made the fix's limitation clear: it doesn't work with wifi-only enabled.
  16. DILands

    DILands Well-Known Member Contributor

    Unless there are naysayers - the mods should sticky this.
    iwillfearnoevil likes this.
  17. rsage

    rsage Active Member

    What are the consequences of setting to "warm start" when on 3G/4G?
  18. J3ff

    J3ff New Member

    I have tested his fix all day - only had the phone a week - however today is the FIRST day that it locks on REAL gps satellites within 30 seconds, EVERY TIME.

    I'd say that samsung owes him some money because he has single handedly fixed the gps problems for me.

    Just FYI- I did not ever reboot the phone, I read this post early this morning and tried using it with my marine nav program at various times during the day, with the longest time of no activity at 6 hours.

    So far so good. Gps was non-functional for me (because I dont reboot my phone) until today.
  19. Aero1

    Aero1 Well-Known Member

    I found warm start inadequate in some cases in flushing all the bad assistance data out of the cache. It helps with some of the stickiness, but cold start dumps the cache totally as far as I can tell and triggers download of all new data. that download only takes less than a few seconds os there is now downside to setting it for cold start as long as you have either 2g, 3g, 4g (0r I presume, but have not tested, wifi).

    So I cannot tell you exactly. You are welcome to test it further. REmember setting things back to normal is simple, jsut do the same steps. Default was hot, you can alos try warm, but I now cold works. I would prefer to spend any more time on aGPS/GPS in looking at the xtra data settings in the same debug menu. xtra is a specific implementation of assistance data.
    rsage likes this.
  20. Aero1

    Aero1 Well-Known Member

    note: user boomerbubba was extremely helpful in thinking this through
  21. Adrift

    Adrift Well-Known Member

    Moving to "Tips and Tricks"

    Will post a link to this as a possible fix for GPS Locating problem, in the "Epic 4G Guide"

    *Edit* Moved to "Support and Troubleshooting" better suited to this sub-forum.
  22. nickw511

    nickw511 Active Member

    So after applying Aero's fix is it ok to leave the check on "Use wireless networks"? Or does this not have any real bearing on efficiency of the GPS lock?
    Thanks in advance.
  23. redandblack1287

    redandblack1287 Well-Known Member

    Fix works, thanks so much!
  24. Aero1

    Aero1 Well-Known Member

    Use wireless networks has no affect whatsoever on the function or lock or accuracy of either standalone GPS or aGPS.

    "use wireless networks" is an alternate method of location. It can also send location data to applications that want or need location (called LBAs or Location based applications). Usually navigation apparitions require GPS/aGPS, but plain google maps, weather programs etc can use the estimates provided by Use wireless networks.

    Essentially the differnce on what you shoudl use depends on your RF situation. In short if you are under a roof, use wireless location, and if you have good view of >35% of sky use GPS. . I was asking one person to turn it off to test soemthing t. There seems to be no harm in leaving both on. I haven't fully tested if the preferences and way it attmpts each, waits to see, tries the other is perfectly tuned. Even within eitehr mode the device should be occassional attempting more precise refinement. eg within GPS, more sats. Within use wirless networks stepping from tower location, tower plus signal strength, triangualtion, hybrid, and occasional looking for sats.
    nickw511 likes this.
  25. jim2point0

    jim2point0 Well-Known Member

    Has this been posted anywhere on XDA? Methinks this fix needs a lot of exposure. It would help a lot of people.
Loading...

Share This Page