GPS causes Spectrum to rebootSupport


Last Updated: 2012-12-13 05:58:34
  1. androidslam

    androidslam Member

    Hi,

    I'm hoping someone has an idea on how to solve this issue. I can turn on the LG Spectrum's GPS in location settings or the status bar pull down without a problem. But when it is actually called by a program such as google maps or any other program that uses location, I will see the target icon for a second in the status bar and then it will almost immediately reboot the phone. It works fine using the google location service option. Another thing that may affect it is I am using the phone without a sim in it. I don't know if there is a gps setup script that is not run because of this? I have factory reset several times along with keeping the sd card out and formatting the sd card. It was on the V6 firmware and I did the OTA update to the V7 prior to rooting hoping it would resolve it. After rooting, I installed the debloated ICS stock rom I found on one of the other threads here. None of this had any affect. This phone was an ebay purchase, so I'm not aware of the history. I tried using CatLog and aLogCat to see if something stood out but could not see anything obvious. Any ideas?

    Thanks!

    Advertisement
  2. PrinceCorwin

    PrinceCorwin Well-Known Member

    My phone is brand new, ICS OTA, rooted with no custom ROM and I am having the same problem.
  3. androidslam

    androidslam Member

    Thanks for making me feel I'm not alone on this one! :) Was trying to see if I could get into the hidden LG menus to see if that could make a difference. Got the idea from this thread about the Optimus 2x:

    How to fix LG Optimus 2X GPS Issue - LG Cell Phones Blog

    Apparently there is one hidden menu called GPS Test. I found it on my Spectrum by installing ADW launcher and trying to create a custom shortcut on the phone's main screen to the GPS Test activity. But, when I click on it, it tells me that the application is not installed on my phone. There are several other activities out there that do nothing, but a couple of them do. Was hoping there was maybe a setting that was wrong that I could clear? One other thing I noticed was when I rooted the phone using the script by the awesome devs in this forum, there was a line that said "rm failed for /data/gpscfg/*, No such file or directory". That would make me think the gps was never set up in the first place from the name of the directory that it was trying to clear. So maybe there was a gps initialization that didn't run? I'm currently using it without a LTE sim in the phone. So maybe there was a Verizon activation script that initialized GPS that I missed? I'm at the point of grasping at straws now. No idea where to look next. I'm going to have to get a logcat of the full problem in action and post it here when I can.
  4. Neph81

    Neph81 Well-Known Member

    I would honestly try re-pushing the v7 update with the .cab method. You will not lose your data as long as you don't factory reset. I'm on stock, rooted, unlocked, and gmaps will work just fine. I suspect that something in your OTA update did not take hold correctly.
  5. androidslam

    androidslam Member

    Hi Neph! Thanks for the response. I'll try it again. The can method failed on me several times I think because of the computer I was using.

    In the mean time I was poking around and found what looks like the Verizon hidden menu. dialing ##program920 with a service code of 000000. it has a gpsone option in there. do you happen to know what that does?
  6. Neph81

    Neph81 Well-Known Member

    I haven't done much digging in the service menu, but I will look a bit today as I have the day off.
  7. androidslam

    androidslam Member

    Ok I guess somehow GPS is toast on my phone, unless someone has some other tricks to try. I pushed both the v6 and v7 cabs and master reset before each and same result on both. As soon as the on device GPS kicks in on google maps or any other gps or location based app, the phone freezes for about two to three seconds and then reboots.

    Thanks for trying to help Neph. Wish it would have worked.
  8. stef7

    stef7 Well-Known Member

    Download 1Tap Cache Cleaner and clean all cache all history?
  9. IMUcarmen

    IMUcarmen Well-Known Member

    well you havent had the phone a year obviously so just use the one year manufactures warranty and get a replacement. Sounds like a defective device to me.
  10. androidslam

    androidslam Member

    @IMUcarmen: Thanks for the suggestion but the phone was an ebay purchase so I don't think the original warranty applies. I could be wrong...

    @stef7: Thanks. I'll check out the app. I usually wipe the cache and dalvik cache (and factory reset when necessary) when flashing roms and in this case pushing the cabs. So I think that most likely isn't a cache problem.

    At this point I'm pretty sure it's a hardware issue. I've seen in other threads/forums about similar GPS causing reboot issues and people using the LG Hidden GPS menu to resolve it. While the Hidden Menu shows up as an activity on the phone I don't believe we actually have it installed on the Spectrum. If I have time I might just try and push the v3 and v4 cabs and see if that changes anything.
  11. stef7

    stef7 Well-Known Member

    OK, well then try this.
    Go into Menu Settings and Choose Date and Time.
    Make sure "automatic date& time" is selected.
    Also make sure "automatic time zone" is selected.

    In settings choose Location Services.
    Select Standalone GPS Services (I have the other three checked as well).

    Download GPS Test by Mike Lockwood from the PlayStore. Don't download some other GPS Test program. Get that specific one.
    Launch that program. Press the Menu Key.

    Press Clear Aiding Data, then Menu
    Press Inject Time, then Menu
    Press Inject XTRA Data
    Then press Start.
  12. androidslam

    androidslam Member

    Wow. Thanks stef7! That actually did something different! :) I at least got a "searching for GPS" and the little GPS target icon blinked for a few seconds before rebooting the phone. That is the farthest I have been when trying to resolve this. Within the app I didn't get any data on any of the screens while i was in it. But then I exited the app and unchecked the other three location settings boxes and just left the "Standalone GPS" checked. That was the point when the "searching" message appeared.

    Some other things I have come across while going looking into this: Dialing ##33284 with a service code of 000000 brings you into some gps and mms testing menu. Also, holding down the menu key when the "4G LTE" boot animation comes up puts the phone into safe mode where none of the downloaded apps from the play store will be active on your phone.

    Another thing is, it looks like my phone may be in what i've seen called test mode, where the PRL is showing as 40000. I'm guessing this is because I am running the phone without a SIM card in it. I don't know if this affects how the GPS will behave.
  13. stef7

    stef7 Well-Known Member

    I'm guessing this is because I am running the phone without a SIM card in it. I don't know if this affects how the GPS will behave.

    Ahh, err, you know A-GPS stands for Assisted GPS. It needs to be able to contact the network. Without a SIM card, you can't contact the internet via the cell tower network can you? Throw a SIM card in your phone and I bet you a dollar or donut it works.
  14. androidslam

    androidslam Member

    Technically it shouldn't need to connect to the network to use the "Standalone GPS Services" option. That is the option I am having problems with. The "Verizon Location Services" should be the A-GPS ability. I'm connecting to the internet with wifi and do not have a Verizon contract. Essentially just using the phone as a nice media player. Other phones I have used do work fine using just the phone's GPS without the sim or being connected to cell towers. I would be surprised to find out this one is any different (unless LG did something very odd). As far as not having the SIM affecting GPS, what I believe may be happening is when I bypass the Verizon service setup screen after a factory reset using the Up, Down, Back method, that may be putting the phone in what i've seen described as "test mode". This test mode seems to cause rebooting problems on other LG phones like the G2x and the Optimus 2x. And according to the other forums and threads they have mentioned the same GPS rebooting issue in connection with this test mode also. I would like to try it with a SIM but haven't been to a Verizon store yet to test it out. I have gone to the Testing menu (*#*#4636#*#*) and tried using the GPS + Verizon Services with different preferred network types like CDMA only. That hasn't made a difference because I don't believe it will connect with the tower if I don't have service. Just wish LG would have done a better job with the software on this phone. Can't believe they have such a problem across multiple types phones.
  15. androidslam

    androidslam Member

    Well I was able to get a logcat while I reproduced the problem. I attached only a partial logcat up to the reboot. I had only the "Standalone GPS Services" checked in the Location Services menu. I switched over to Google Maps and hit the button in the upper right of Google Maps to locate my position. It then showed the GPS Target icon in the upper left on the status bar, froze everything and then rebooted. I can't make out what exactly did it but the file ends when the reboot happened. The last line has: "Start proc com.google.android.apps.maps:NetworkLocationService". So maybe it's still trying to force AGPS using the Verizon network?
  16. androidslam

    androidslam Member

    Another logcat of a second try at enabling GPS on Google Maps.
  17. stef7

    stef7 Well-Known Member

  18. androidslam

    androidslam Member

    Yep. There's a good amount of options out there for offline mapping. There's even a couple apps that do offline navigation, though I haven't come across a good free one yet (U-turns on the freeway aren't a good idea). The offline google maps is pretty but unfortunately doesn't do some of the things things the others do. For example Mapdroyd can download by continent, country or state. Google maps makes you select an area instead but on the phones I've used it won't go over an 81mb map download. Plus, I think at one point they put a one month time limit on the download.

    Anyways, that's why I was hoping to get the GPS working. I miss using those apps. But, even non-mapping apps like Facebook and Meetup will cause a freeze+reboot as soon as they access location services when I have the "Standalone GPS" option on. That little GPS target icon with the solid blinking circle is my nemesis. :)
  19. androidslam

    androidslam Member

    Well, I've flashed the v3, v6 and v7 cab's nothing made a difference in how the standalone gps behaved. Everytime it's accessed another reboot happens.

    I did flash tdm's CM10, so far that is the only one that DOES NOT reboot when standalone gps is active. But, google maps and other gps apps just act like there is no gps hardware. Looks like the reboots may have been tied to some of the verizon navigation libraries maybe? i would see a VZWNavigation message around the time of the reboot in the logcats.

    So, I'm guessing the hardware is fried somehow. Anyone know if there is a cable or something that can come loose that will affect GPS? If not I guess this thing is getting ebay'ed.

Share This Page