GPS is not workingSupport

Last Updated:

  1. sayginjedi

    sayginjedi Member


    On my i7500 GPS is not working. The problem has been mentioned on different places on the internet but I could not find an exact solution.

    As far as I understand the problem may be about the baseband firmware, I am running II5 firmware and living in Turkey (maybe an activation problem may occur with an unproper firmware). Also my OS is Froyo (GAOSP).

    Can anyone suggest a solution? And an additional question, if I update the firmware, do I need to reinstall (or restore) OS?


  2. Lelouch

    Lelouch Well-Known Member

    Easy my friend.

    Regarding your GPS problem.
    Did you look in Location & security> if Use wireless networks is checked and also Use GPS satellites? If it is, then you're one of the unlucky ones (on my phone GPS does work), but there is hope (issue is known by Drakaz team) bukington already fixed it. So wait for the next nightly build (0.70) or go back to Galaxo
    Nightly build is a prebeta software, in this situation ROM so if it doesn't work go back to previous nightly or the one which worked or back to Galaxo

    Now regarding your update firmware.
    Why would you do that? You can just do an update of baseband.
    If you do an update of firmware (Sam*censored stock ROM), you would need to reinstall the custom ROM. But if you update just firmware, the reinstall of ROM is not necessary.
  3. sayginjedi

    sayginjedi Member

    thanks, by firmware I was actually referring to baseband update. as a new android user, I am still confused about the terminology :)
  4. Lelouch

    Lelouch Well-Known Member

    In ODIN you have the option to install only baseband (I think, it's been a while).
    And by flashing(full) firmware you're flashing baseband, putting/returning Sam*censored stock ROM, it's recovery...

Share This Page