GPS issues, unsure if it's ROM or something else?


  1. crackface

    crackface Well-Known Member

    I'm using Eclipse 3.0 ROM from TeamHaters over in droidforums. I did post this question in their ROM thread but not seeing any responses so I figured I'd ask others here that are on different ROMs.

    This ROM works near perfect for me, except for the GPS. I've verified this happens with both Google Navigation and CoPilot:

    • At seemingly random times (though usually when I first go to use gps for first time in a day/week), regardless of current location, it'll take ~3-5 mins to obtain gps lock. If I try at that point to recreate the issue with multiple reboots and relaunching GPS, it always gets lock immediately. But I try 2 days later and issue would usually hit again.
    • At also seemingly random times, when I'm driving I will lose the gps signal for the same 3-5 mins. This rarely, if ever, happens in the same area of road twice, and many times is down an open highway with clear view of sky. This sucks when it happens where I have NO clue where I am, or if I knew I was coming up on some intersections.
    • At less frequent, but random times the gps will show me on a side road off the highway. These aren't always close parallel roads where I can understand this happening. These are perpendicular roads and not necessarily close to highway. And as I drive, it will continue placing me on all the side roads, constantly recalculating. At brief times it has me back on highway, but will quickly go off route again. This issue does not auto resolve by waiting. I need to reboot phone, but I think some of the time even a reboot didn't help.
    Has anyone else experienced issues like this on whatever flavor D3 they're using? Any suggestions if there's something I could try or if I should switch ROMs?



    Thanks in advance for any feedback.....

    Advertisement
    :
  2. Digital Controller

    Digital Controller The Real Bass Creator Guide

    I would suggest to make a backup of that ROM and then either switch back to stock or go to another ROM just to see if the problem is all over....because if so you might want to go have your phone looked at because it definitely should not be doing that.
  3. doogald

    doogald Guides Guide

    The big question is what are your location settings in what should be (from home) menu->settings->location & security? Which location services do you have turned on?

    I've seen that jumping around on stock just last weekend (not critical because I wasn't navigating but trying to use the map to find a fast food place on our route) and it was jumping a bit. I wonder if it was having problems with Google location services (which uses WiFi network triangulation?)

    Anyway, you can try turning off Google location if you have that turned on, leaving on GPS and VZW location services (if they are there - I haven't run Eclipse in a long time). If that wasn't it, you can try turning off VZW navigation services and see if just GPS works best (though it is the most power hungry location service.)

    I stopped using Eclipse - I can't remember why I didn't like it, but right now I am now using a ROM called Minimoto which I really, really like. See here: http://forum.xda-developers.com/showthread.php?t=1978304
Loading...

Share This Page