GPS issues?Support


  1. Sleuth

    Sleuth Active Member

    Have been very pleased with my Galaxy S in the few days I've had it so far (apart from being unable to mount it on my Mac without turning on USB debugging mode, but I digress).

    My real problem, the only real problem I have, is that the GPS appears to be, well, rubbish. I do a lot of hiking in the country side around London. On my old G1 I had been using the excellent MyTracks application to keep track of my journeys. It always did a terrific job, but battery life was a problem - part of the reason I chose the Galaxy S as it's replacement. So the very first app I installed on Thursday was MyTracks.

    Yesterday I walked along the North Downs Way from Guildford to Dorking/Box Hill. A 13mile/20km walk. But according to MyTracks I'd just walked 30km!!!

    You can see why it get the distance wrong if you zoom in the google map it generated. The GPS readings are jumping all over the place.

    Here's the walk on my new Galaxy S
    NDW Guildford To Boxhill - Google Maps

    And here's the walk from Farnham to Guildford the weekend before, as recorded by my old G1. As you can see it's *much* more accurate. No jumping about. It follows the path precisely. And the distance travelled is much more realistic.
    North Downs Way - Farnham To Guildford - Google Maps

    Is it just my phone with the issue or is it a general problem? Has anyone else taken their Galaxy S for a GPS test?

    Advertisement
    :
  2. NZtechfreak

    NZtechfreak Well-Known Member

    Was GPS actually on? Sounds like like you haven't enabled it in Settings, Android phones default to using cell tower based locations, which are always out by miles...
  3. Sleuth

    Sleuth Active Member

    No, it was on. In fact the phone was in Flight Mode to preserve the batteries (GPS is battery heavy), so it wouldn't have been able to talk to any phone towers.
  4. yakboy

    yakboy Well-Known Member

    Interesting (and slightly worrying), I don't at the moment use GPS for tracking my running but I would like to and will definitely be using it for Car navigation. Considering these are all A-GPS chips I'd love it if you could perform a (slightly shorter) re-test with the radio on. It could be some peculiarity of the GPS chip in the SGS when it's operating in it's non-assisted mode.

    Has anyone else experience of using GPS on the SGS for any reason?
  5. NZtechfreak

    NZtechfreak Well-Known Member

    I'll have mine tomorrow, will post up my findings.
  6. zafonic

    zafonic Well-Known Member

    Are you getting it sim free? If you don't mind also can you give your feedback on wether the phone lags or not, as i am hearing conflicting reports.
    souravbasak7 likes this.
  7. NZtechfreak

    NZtechfreak Well-Known Member

    Of course, I'll post up a fairly thorough review.
  8. DopedAngel

    DopedAngel Member

    I have the same problem the gps signal is weak. Trying to use cardio trainer the route was jumping up and down. Plus the signal bar was showing only one bar. I have disabled use wireless networks so its only the gps working.
    I will turn it on and use it to see if it increases accuracy or not later.
    Hopefully its just a software driver glitch and can be fixed.
  9. paul_73_uk

    paul_73_uk New Member

    I too am seeing poor performance with the GPS.

    I did a test over the weekend comparing my Galaxy S with a friend's HTC Desire. Using one of the many GPS utilities the Desire was consistently seeing and locking more satellites when stood in an open area outside. When running Google maps and showing the current location I found that the "accuracy circle" (for want of a better description) was growing and shrinking several times a minute causing the map to zoom in and out.

    I've also noticed that the compass is almost unusable and showing a much lower signal compared to the Desire. I did perform the figure of 8 calibration several times.
  10. yakboy

    yakboy Well-Known Member

    All quite alarming! The issues seen could be caused by the error correction algorithms for both for the GPS and Compass units. I hope so anyway!

    Why don't they test these things with review units!!!???
  11. tonyjj

    tonyjj Member

    Any update on this guys? I was all ready to go out and order one of these phones until it looks above like the GPS just doesn't work! Is this an early firmware bug type thing that will be fixed? Or is there any workaround at all? It seems like a huge fault with a phone supporting the GPS feature...almost makes me think back to my law subjects at uni that the phone does not meet the advertised claims!
  12. NZtechfreak

    NZtechfreak Well-Known Member

    Sadly I can't be of help till later in the week, waiting on second unit as my first one appeared to have a corrupt market in the ROM that factory resets/new google accounts/clearing all caches etc etc couldn't fix - wouldn't let me install apps sadly so a bit tough to really test the GPS...
  13. tonyjj

    tonyjj Member

    Thanks mate. Please do update us all on how you go. The hardware in this phone looks great, but I am very worried about the quality of the software and these bugs and issues that keep getting reported. It's what makes me nervous about buying a Samsung.
  14. Ferdimage

    Ferdimage Member

    have you guys tried Igo8 with the S yet?
    that was a very good GPS software for my Omnia II, i know it has a diff hardware and OS, but that app worked well... please post anything if you guys have tried it..
    thanks
  15. Evil Peter

    Evil Peter Well-Known Member

    I tried out the GPS a little today and asked it to find my location (using both satellites and 3G network), which is at my summer house which is located a bit from the cities and not with the best 3G connection possible. It located me with an error of 5m and as far as I could judge I definitely agreed with that positioning so that part worked very well in my view.

    I'll try it out for movement later.
  16. DopedAngel

    DopedAngel Member

    Please try with gps test and tell me what kind of reception you are getting
    My phone can detect only 4-5 satellites and none of them show a signal of more than quater bar.

    [​IMG]
  17. Evil Peter

    Evil Peter Well-Known Member

    I went out, started the test and gave it 1 minute. I got 10 satellites with an average bar of 40.
    DopedAngel likes this.
  18. DopedAngel

    DopedAngel Member

    Thanks I will try with my phone again in while once it gets charged.
    Maybe the problem is with my phone and I should ask for a replacement.
    By the way what firmware build are you using
  19. Evil Peter

    Evil Peter Well-Known Member

    I'm using 2.1-update1, kernel version 2.6.29.
  20. binche

    binche Member

    Someone else could make some test with the GPS and compare it with HTC Desire or Nexus One ?
  21. n4nick

    n4nick New Member

    I've had no issues with sports tracking:

    See here for a track taken with a Huawei U8230 (Pulse)
    Short Loop Greenhithe (Running) | Auckland 0632, New Zealand - Trailguru

    See here for a track taken with a Nokia 5800
    Short Loop Greenhithe (Running) | Auckland 0632, New Zealand - Trailguru

    See here for a track taken with the Galaxy S
    Partial track from Galaxy S (Running) | Auckland 0632, New Zealand - Trailguru

    All over the same territory. I think there may be some differences in altitude reading, but I understand that altitude is not that accurate from GPS anyway.

    The Galaxy S was with WiFi on, I think, and location using wireless networks. Having said that, its a semi rural suburb with houses some distance from the road so probably not much wifi compared to some areas [​IMG]
  22. sjdean

    sjdean Well-Known Member

    If you guys download GPS Test from ChartCross, can you let me know if you get any Satellite locks on Satellites in the 10 to 20 SnR range?

    Unlike the HTC Desire, Samsung Galaxy S appears to not even be allowing these Satellites to be used:

    Picasa Web Albums - sjdean - Shared

    As you can see on my Galaxy S, it wouldn't even lock on to Satellite strengths of 32, 27, and 25, but locks on to Satellites of 23!
  23. cdmag

    cdmag Member

    I have a Samsung Moment and I basically have no GPS on that phone. It is very discouraging. I had understood, prior to reading this thread, that this is a limitation of Android (I am on Firmware 2.1-update 1 and Kernel Version 2.6.29). Based on this thread I'm beginning to wonder if it is a limitation of my phones GPS receiver. Any thoughts would be appreciated.
  24. yakboy

    yakboy Well-Known Member

    Subjective opinion for now but I promise to do a proper test as soon as I can using GPSTest:

    Only used it for Navigation in the car. Generally OK but when horizon is very limited (say by trees or tall buildings) I'm finding that I more frequently lose lock and the circle goes all big (50M I guess?). It doesn't happen all the time, but it isn't as good as my Nexus one was, definitely not.
  25. sjdean

    sjdean Well-Known Member

    Just compared a friends HTC G1. He gets a full signal lock INSIDE a building, with all ten satellites.

    I don't. :-(
Loading...

Share This Page