GPS issuesGeneral


  1. skunis1

    skunis1 Well-Known Member

    I just got my wife this phone a week or so ago. Yesterday we tried the GPS and eventhough all the location settings were on the Google Nav app kept saying "Searching for GPS". I sat for like 10 minutes inside the house and then walked outside and still nothing. I even tried using my Rezound to see if there was a GPS issue and it found the GPS right away.

    I read using GPS Status & Toolbox can help fix the situation. I am going to try that tonight.

    I just wanted to see if anyone else was having this issue with the Lucid. We are in NJ if that helps.

    Thanks.

    Advertisement
    :
    kenzet likes this.
  2. commbubba19

    commbubba19 Member

    yes. I have as well, before and after root.

    I downloaded an app called GPS Test from the Google Play Store. While traveling it would find my location via cell tower but never lock on via GPS. Run Google Nav and would sit there forever searching for GPS. I downloaded the above app and the phone could see the satellites but would never lock on. Did the Clear AGPS and wham, locked on 2 seconds later.

    Bad news is that after GPS is turned back off or unused for a little while, I have the same problem and have to clear the AGPS settings again.

    Very annoying.
    sambena likes this.
  3. skunis1

    skunis1 Well-Known Member

    Thanks for the quick reply. This is VERY annoying. You would think this would be caught in testing. I am guessing it was a bug they figured they could live with until their first software update.

    At least the GPS Test app will fix it. I will install it and see if it works. If so, I will show my wife how to use it if the GPS won't connect in the future.
  4. grandamn

    grandamn Member

    Have you enabled the Verizon GPS? I had the 911 and Google turned on but I realized there are a lot of apps that use the Verizon GPS including the camera for Geotagging photos.
  5. skunis1

    skunis1 Well-Known Member

    I have all the GPS settings enabled. Problem is the phone cannot lock onto the GPS signal. Clearing the AGPS with the app mentioned prior is supposed to do the trick. I haven't tried it on my wife's phone yet.

    Hopefully, LG will fix this issue.

    Update: Looks like there is a new software update coming soon as the change log is showing on the VZW site. One of the updates is with the GPS. I am going to try to update my wife's phone tonight to see if it is available.
  6. bkrahmer

    bkrahmer New Member

    I'm having issues with GPS as well. I am not using verizon location services, as I want to only utilize the satellites. Last night's update did not address the issue. I may be replacing this phone tomorrow because of this. So annoying.
  7. JJPR97

    JJPR97 Well-Known Member

    I've got my LG Lucid running CyanogenMod 10 and I get the same issue.
Loading...
Similar Threads
  1. Blitzkri3g
    Replies:
    11
    Views:
    2,307
  2. RunamuckRez
    Replies:
    9
    Views:
    532
  3. Sleuth
    Replies:
    841
    Views:
    151,015
  4. wmshub
    Replies:
    1
    Views:
    483

Share This Page