GPS Lock ProblemsGeneral


  1. stringfiend

    stringfiend Well-Known Member

    After upgrading to ICS I've been having a lot of trouble getting a GPS lock. I looked this issue up and quite a few people have been having similar issues. Some people have suggested rebooting the device or toggling the gps on and off to get a lock. This has only worked once for me.

    Anyone have a better solution?

    Advertisement
    :
  2. SirAir

    SirAir New Member

    I have been going thru the same issues since GB and even after the ICS upgrade... Any suggestions???? Love this phone minus the gps issues...
  3. Talderon

    Talderon Well-Known Member

    This is the same issue as the last leak. Unless you are rooted to try and flash a couple of fixes, the only way I have been able to resolve the issue was to wipe/reset. Now I get GPS lock almost instantly. I have a lock before the map even shows up.

    Hope this helps!
  4. stringfiend

    stringfiend Well-Known Member

    I don't know if it is a coincidence or if something I did actually fixed it but I'm not having the problem right now. I loaded GPS Status and just left it running while I drove around the metroplex. After about an hour it found a lock. When I got home I toggled gps off and on and then it couldn't find a lock again. I rebooted the phone opened GPS Status, told it to reset all gps data and do an agps download; it found a lock within 20 seconds. Now, it is locking even faster every time.

    I really don't have any explanation for this. There was a definite problem: It was taking hours to get a lock. Now it appears to be fixed...hopefully it stays fixed!

    I was trying to avoid wiping or reseting the phone. I will update this thread if the problem persists.
  5. stringfiend

    stringfiend Well-Known Member

    Ok, so a strange update to this gps problem.

    Apparently the problem might have something to do with G-maps/navigation. I got in the car and loaded up gmaps for a destination...no gps...Opened up GPS Status...10 seconds later I have a lock. Now, went back to gmaps/navigation...10 seconds later have a lock and route to destination.

    Now the interesting part: In my hour long drive, every time that Navigation was the foreground process I would lose GPS signal in about 10 seconds. Then I would switch over to GPS Status, low and behold the satellite fix had dropped down to 2 or 3 and sometimes 0. After waiting for about 5 seconds, the fixed sats would climb up to 7 or 8 at which point I would switch back to Navigation and GPS has been restored and the route would resume.

    Conversely, when I would make GPS Status my foreground app and let Navigation run in the background I never loss the signal (i.e., voice commands continued routing me to my destination) for a solid 30 minutes.

    Hence, Gmaps/navigation is running in the foreground: I lose gps signal in about 10 seconds or will continue "searching for GPS" indefinitely. GPS Status is running in the foreground and Gmaps/navigation is in background: I maintain stable lock and am routed to my destination without hiccup.

    Any ideas what's going on here? I uninstalled and reinstalled gmaps for the ride home and nothing changed.
  6. nisssmo

    nisssmo Member

    Anyone else? Same issue
  7. tigersharkdude

    tigersharkdude Well-Known Member


    Im having the same problem as everybody else...Just yesterday I did two complete wipe/resets...my problem still continues. Im going to AT&T today because its starting to PO me


    Same issue here..Have tried wipe/reset twice...the problem continues
  8. stringfiend

    stringfiend Well-Known Member

    Well, thanks for letting me know that a wipe/reset doesn't fix the problem. The GPS capabilities combined with navigation on a huge display was one of my favorite features of the Note. If this doesn't get fixed soon I will probably take it in on warranty. If it is an issue with all Notes after update I might consider exchanging for the S3...but I love my note!
  9. tigersharkdude

    tigersharkdude Well-Known Member


    Samsung is sending me a new phone as we speak. The guy at AT&T said a number of Note owners have been complaining about it


    When the new phone gets here...its staying on gingerbread (if thats what it ships on)
  10. NeoGrandizer

    NeoGrandizer Well-Known Member

    I don't have any issues with the GPS. Yes, it will take a while to lock if I'm constantly moving, but if I am stationary it is quick. I haven't seen any real issues with it. I just loaded Google maps, Navigation and NDrive. GPS works as it should.

    However, I did a clean install of ICS. Hard wipe to factory defaults, upgrade to ICS and then hard wipe to factory defaults again. Played with it a bit and hard wiped it twice more while fooling around before finally restoring my personal data and redownloading apps. I haven't experienced any real major problems.
  11. stringfiend

    stringfiend Well-Known Member

    I'm new to Android. If I do a backup on Kies then wipe, then restore from backup will I keep all my settings and contacts? I had read it is best to re-download all your apps instead of restoring them. Any other tips for what to leave out of a backup/restore? Also, will it revert to Gb, and if so will it be simple to upgrade again to ics?
  12. LittleRedDot

    LittleRedDot Well-Known Member

    If you are running ICS when you do the backup through Kies then that's what will restore after the wipe. And yes, it will restore system settings (via Kies). There are easier (imo) ways to backup-wipe-restore other than Kies, but if that is the program you're used to then there's no need to confuse you with another method right now.

    As far as what apps to restore and how you restore them, it really depends on how you backed up. Again, through Kies it should restore whatever you asked it to backup without issue. It's better to re-download vs restore sometimes with Titanium Backup or My Backup Pro.
  13. NeoGrandizer

    NeoGrandizer Well-Known Member

    LittlrRedDot is correct. It's is best practice to always re-download than restore because old system files may find their way in and cause problems. Never restore system files (that is an absolute). Data backup files (ie. contacts, appointments) are generally fine to restore. But if you're using google already, just resync the data.

    This is also my first Android, but I am not new to flashing a new OS. I've done quite a bit during my Windows Mobile days. It's always standard/best practice to prep a device prior to an upgrade and then do a clean install. This always minimizes the chance of bugs and other adverse problems rearing their ugly heads after the install.

    Is it possible to do a firmware recovery via Kies? Maybe try a hard wipe, then recovery and then another hard wipe to see if anything gets fixed? :confused:

    I know my Symbian (Vivaz Pro) allowed firmware recovery and I needed to do it once a month to get the phone to work properly.
  14. stringfiend

    stringfiend Well-Known Member

    Did a wipe/reset yesterday and then reloaded select items instead of restoring. The GPS was working like a charm last night. I was getting a quick fix and it was staying locked indefinitely. Put it on the charger in airplane mode over night. Checked GPS this morning and it can't get a fix or anything.

    This is getting frustrating. I would take it in for a warranty replacement but I'm starting to think it has something to do with my settings or usage.
  15. NeoGrandizer

    NeoGrandizer Well-Known Member

    Was airplane mode disabled? There was no plane icon in notifications? Sorry, I know that's pretty obvious, but might be an oversight...

    I'm in my basement and just activated airplane mode. I can turn GPS on with airplane mode active and it will not lock. Turn it off and it takes quite a bit to time to lock on. But then again, it's probably because I'm testing in the basement (not the best place to get any GPS lock). I fluctutate between 0-5 satellites locking on with NDrive. So GPS is still working for me.

    :confused:
  16. stringfiend

    stringfiend Well-Known Member

    Neo--Yeah, Airplane mode was off. I mentioned it because I had heard that sometimes you can have radio problems after having airplane mode on for a long time. I usually let Llama (a tasker app) turn my phone to airplane mode when I'm sleeping or when I am in a meeting to save battery power. If airplane mode does keep the gps from locking quickly I can just stop enabling it.

    Any one else experiment with this?
  17. TeeX

    TeeX Active Member

    just a thought:
    I have a Galaxy S3, and just in the last couple days have experienced the same issues with gps lock. Maybe it has somethig to do with the satellites themselves or Google/Maps/Nav?

    The two weeks prior that I've had my S3 its been instant gps lock and I've done nothing to my phone, so I don't think its a device issue.
  18. Evil.Bonsai

    Evil.Bonsai Well-Known Member

    Awesome. Now my Note isn't getting a gps lock. Worked great previously, would get a lock in moments. I've just tried several different apps (gps test, gps status, google maps/navigation, allsport gps) and nothing seems to be working. Might have to make a trip to ATT myself.

    Update: did a factory reset and gps is now working. I wonder if the agps isn't updating even if you force it (only way I know to force it is using one of the above gps apps), whereas factory reset DOES update the agps. All I know is it really didn't work at all but does now after factory reset.

    Sigh...now to go back through and re-setup everything.

    AND...it's back to not-working. Yay.
  19. Evil.Bonsai

    Evil.Bonsai Well-Known Member

    Will someone please post their Samsung/At&T ICS build number?

    I've been having issues with my gps since updating to ICS. I finally went in to the warranty store and had an interesting experience. The tech asked me to clarify that gps was fine before ICS, which it was, and that I started having issues AFTER ICS, which I did. She then tells me that they had found bugs in the original ICS update, several in fact, and have corrected them. She said she would install the fixed version, which took about 15mins. I walked outside, downloaded 'gps status', opened it and had lock within seconds!

    Now I"m wondering if it's going to be temporary for some reason or it's actually fixed.

    I still have ICS 4.04 but the build number is IMM76D.UCLF6. Is this the same as everyone else? I didn't write it down beforehand, so I can't compare. The gps IS working, and working well, at the moment, so we'll see how long that lasts.
  20. dean128

    dean128 Member

    I have the same 4.04 version and IMM76D.UCLF6 build number as your phone.

    Did you ask the tech exactly what the fix was? Like many people, I have an inaccurate GPS.
  21. Evil.Bonsai

    Evil.Bonsai Well-Known Member

    Per her comments, 'we found the original ics had bugs with the gps code, several other bugs too.'

    I REALLY would have thought the build number would have been different. That being said, I have factory reset my phone a couple times and did a hard reset (hold pwr switch/volume buttons to get to base android code, reset from there; though it seemed to do exactly the same thing as 'factory reset'), with no improvement.

    After she did whatever she did, gps worked very well (using app 'gps status' 5-6 locked satellites within seconds). I checked again in my apt parking area and it did the same. I will keep checking, and as long as it keeps working, I"ll be happy. But as soon it as it starts hesitating, I'm going back.
    dean128 likes this.
  22. dean128

    dean128 Member

    Thanks for sharing.

    I'll be taking my phone to at&t.
  23. stringfiend

    stringfiend Well-Known Member

    I took mine in for warranty because I got tired of the gps lock problems. Worked like a charm for a whole day... now back to square one, i.e., random lock occasionally but no lock for hours at other times. This is becoming frustrating. I don't even use gps very often but I'd like it to work the way it did before the update! The gps on this thing (when it was on GB) blew all other phones and most standalone gps units away.
  24. Evil.Bonsai

    Evil.Bonsai Well-Known Member

    As it turns out, this is exactly how my 'warranty work' turned out. Worked awesome for a day or so. Today? Got lock after about 15mins of driving. 40mins later, followed same route back home, no lock at all.

    Guess I will be visiting the warranty store again.
  25. NeoGrandizer

    NeoGrandizer Well-Known Member

    stringfiend, do you still have airplane mode on overnight. Did you see if leaving it off made any difference? Just a thought, maybe you already tried that.

    I remember you said it worked after a factory reset, but after a day GPS went awol again with airplane mode left on overnight. Not sure if llama may be a small culprit? Not sure, maybe auto settings may be messing around with it?
Loading...
Similar Threads
  1. suttoc
    Replies:
    11
    Views:
    1,828
  2. Woosh
    Replies:
    5
    Views:
    1,266
  3. falcon26
    Replies:
    4
    Views:
    991
  4. jdmba
    Replies:
    0
    Views:
    297
  5. jdmba
    Replies:
    0
    Views:
    350

Share This Page