GPS, phone, or Google Maps bugs?


  1. Archon810

    Archon810 Well-Known Member

    A couple of times now I've had this problem on my Hero, and today it was a huge pain in the ass, as I was looking for the place I was headed to but couldn't find it.

    The problem is my Google Maps couldn't lock onto my signal - it was jumping all over the state - at first told me I was in Sacramento (one of the turn directions next to it had a misspelling "Socramento", wtf?), then Santa Rosa, then as I kept driving and pressing My Location, it switched to a random street about a mile away, then dumped me in the ocean :-/

    During this time, the GPS icon kept blinking and didn't stay solid. Also, once it picked up a location, it didn't continue to update it as it should do.

    I had to restart the phone and I think it's working OK now but this is at least the 2nd time it's happened to me.

    Anyone else? Who do you think is to blame? I updated PRL to see if it helps for now.

    Advertisement
  2. justjimjpc

    justjimjpc Premium Member VIP Member


    This is not a google maps issue ... if anything you have a poor location in your car for GPS signals ... or the GPS radio in your phone is marginal ...

    GPS can have problems with area where there is no clear sky and at least 4 or more Sat locked onto ...

    try an app like GPS Status 2 to see how that reports for you ...
  3. Archon810

    Archon810 Well-Known Member

    That's not it. Until I rebooted my phone, I couldn't get location anywhere, for a few days. After I rebooted, it hasn't happened since.

  4. satinkzo

    satinkzo Well-Known Member

    I have noticed and recreated a few times a weird location lock issue with Google maps and sprint nav on my hero. It seems that if under Location Services you have Use Wireless Networks checked, the apps don't seem to care if you have GPS enabled. Unchecking Use Wirless Networks immediately allowed the apps use the GPS signals. Then rechecking wireless networks and everything is fine.

    Don't know if it's a bug in the phone or the apps though.
  5. Archon810

    Archon810 Well-Known Member

    Just happened to me again today. It seems to occur during the times I need my location the most - i.e. driving. Restart fixed it again. I think it's a bug, as you said. I'll try to turn off wifi location altogether - GPS should be good enough.

Loading...

Share This Page