GPS Satellite Aquisition/Lock very slow on MilestoneSupport


Last Updated:

  1. WirelessGuy

    WirelessGuy Well-Known Member

    I have a Telus Milestone (IHDP56KC5) that I am running on AT&T. When using the GPS it seems like it always takes 3-5 minutes to get a lock on the satellites and start navigating. Using GPS Status, I get satellite signal within 15-20 seconds of activating the GPS, but do not get a nav lock for 3-5 minutes, this seems excessively long. On my Motorola Q9h Global I had prior, I could start navigating with the GPS within about 30-45 seconds after turning on the GPS. Would this have anything to do with AT&T not having my IMEI for this phone (since from what I understand aGPS helps for a faster lock using the cell network and if they don't have my IMEI my phone possibly isn't using aGPS???). Under Location & Security settings I do have "Use Wireless Networks" checked.

    Any help would be appreciated as this is an aggrivating issue as I'd like to use the GPS often.

    Advertisement
    iscandium likes this.
  2. fejker

    fejker Well-Known Member

    I also have this problem and mine also looses the GPS signal very often.

    Flashing my phone to the unofficial 2.1 update seams to have helped with the slow GPS locks but there are other issues I'm having with the unofficial update (not GPS related but keyboard related).
  3. WirelessGuy

    WirelessGuy Well-Known Member

    I am wondering if the network you are using aGPS on needs your IMEI number to properly use aGPS... Does anyone know if this is the case???
  4. imac

    imac Member

    I created an application for Android which is using GPS & Wifi/network signal to locate your phone, so, I know a thing or two.
    All navigation software needs more precise location & from many satellites, to locate you on the map. If I remember well, they start working after the get constant updates from 4 satellites.
    The software that locate you on the map (like Google Map), can give you the location from 1 or 2 satellites.
    The Wifi/network location, does not need you credential to work. They simply calculate your location, based on the cell towers (network antenna) signal, and Wifi signal.
    The GPS reception can be altered by cloudy sky or bad weather (snow...), high buildings near you...
    Try starting your GPS Navigation software, in a different area - more open, and see if you have better results.
    On my Milestone, Navigon is functioning after 30/40 seconds.
  5. WirelessGuy

    WirelessGuy Well-Known Member

    I've tried my GPS in many different (wide open) locations in several different parts of the US, same result, no navigation for 3-5 minutes. I have several friends with the same phone on AT&T and have the same issue.

    Using GPS Status, you can see that the phone starts "seeing" multiple satellites within 10-20 seconds, but it takes 3-5 minutes for it to lock a position and begin navigating. It is very frustrating as it almost appears to be a problem with this phone on AT&Ts network (almost like the phone isn't getting the proper info for aGPS to work from AT&Ts network).

    The GPS appears to be doing a stand alone "Cold Start" (unassisted) based on the time it is taking for it to calculate a position.
  6. Brendanmurphy

    Brendanmurphy Well-Known Member

    Im using mine on Telus and sometimes it can be slow to acquire (especially when in a car moving) but it does connect eventually sometimes within seconds
  7. dieKatze88

    dieKatze88 Member

    Its really not that bad. I get GPS lock within 2 minutes in the rain, 20 seconds in daylight, but I *NEVER* turn GPS off fully, so the battery hit is probably keeping a relatively decent location in memory.

    Its not nearly as bad as my old touch pro, which would take 20 minutes standing in a field on clear day to get a GPS location.
  8. fejker

    fejker Well-Known Member

    Running the default 2.0 or 2.0.1 OS mine is definitely slower at finding a GPS lock than my previous Nokia E71. Even with aGPS turned off the Nokia is faster. BUT with the unofficial 2.1 update (the update is not yet available for my region) the GPS gets a lock within seconds as stated a few posts back by Brendanmurphy.
  9. WirelessGuy

    WirelessGuy Well-Known Member

    Hopefully the "official" 2.1 update makes the GPS work better!
  10. dmo580

    dmo580 Active Member

    slow for me as we.. Telus on AT&T. What a joke. When I'm outdoors my N-series would lock insanely fast. I couldn't even Google Maps for crap yesterday in the daylight. Ugh.
  11. Agatsya

    Agatsya Member

    All folks running using Telus milestone with ATT sim card will only be able to get autonomous GPS and not Assisted GPS location fixes. The problem is that the server that delivers assistance data to the phone is tied to Telus and you can't access that server from ATT network or via wifi because it is behind Telus's firewall. That is why sometimes milestone may have issues getting fixes. I have my milestone from Latin America and have not had any problems with GPS.
  12. WirelessGuy

    WirelessGuy Well-Known Member

    Is there a setting somewhere that can be changed so the aGPS looks to AT&Ts server vs. Telus's server for the aGPS data? A line of code in a file, etc???
  13. Agatsya

    Agatsya Member

    Have you already rooted your phone? Can you modify files on the file system?
  14. WirelessGuy

    WirelessGuy Well-Known Member

    I have not, but with Astro File Manager it appears I can access at least some of the system config files...

    Which file needs to be modified? What is the new settings?

    Any help you can provide would be greatly appreciated!
  15. lanoisullid

    lanoisullid New Member

    I don't have a data plan to test if assisted GPS would help, but one issue may be that the assisted GPS is set up to search for supl.telusmobility.com.

    If you open \etc\location.cfg, and scroll down halfway, you'll notice two entries with supl.telusmobility.com. I believe you can only access that server on the Telus network.

    To change this entry, you'll need to have root access and remount the system partition to gain write access.

    Root access:
    [HOW TO] Root Telus Milestone without wiping or losing Telus firmware

    Modifying \etc\location.cfg:
    Turn on USB debugging and connect the USB cable and launch "adb shell" from the android SDK tools folder.

    Code (Text):
    1. su
    2. mount -o remount,rw /dev/mtd/mtdblock6 /system
    Make the change in \etc\location.cfg to something like supl.google.com:7276
    Then remount as read only
    Code (Text):
    1. mount -o remount,ro /dev/mtd/mtdblock6 /system
    iscandium likes this.
  16. Agatsya

    Agatsya Member

    lanoisullid - That was really very cool. You almost figured it out :).

    However, the file that needs to be changed is /data/location/location.cfg. For going to google supl server for assistance, it's a 2 step process. You would have to modify hslp_address = supl.google.com:7276 for both the telus entries in /data/location/location.cfg and you would have to set the line with security = 0 in /system/etc/location.cfg.

    For going to ATT assistance server (which seems to be down for the last few days ) just modify /data/location/location.cfg and have nothing in hslp_address line. e.g.
    hslp_address =

    This should work for you.
  17. WirelessGuy

    WirelessGuy Well-Known Member

    Is there any way to modify these files on a non-rooted phone?

    What would be the exact steps to do this?
  18. lanoisullid

    lanoisullid New Member

    Ah...I should have known that /data directory required root user access to view the contents; I was being lazy and just browsing files using ES File Explorer.

    On my Milestone, the /etc/location.cfg and /data/location/location.cfg were both identical except for:

    DL_DB_FEATURE_ID_LOCATION_STATE = 0
    IS_VALID_LAST_DRV_TCXO = 1
    LAST_DRV_TCXO = -747

    where these above values were set to 0 in /etc/location.cfg.

    So for both these files, I set the following
    DL_LCS_SUPL_SECURITY_ON = 0
    hslp_address = supl.google.com:7276
    default_hslp_address = supl.google.com:7276

    Sounds about right to you Agatsya?

    I really should get a data plan one day to try this out :)


    iscandium likes this.
  19. lanoisullid

    lanoisullid New Member

    Unless I'm mistaken, only the root user has access to the files in /data. So you'll need to root your phone following the steps at [HOW TO] Root Telus Milestone without wiping or losing Telus firmware

    It's a two step process where you first flash the recovery with a rootable SBF, and then apply an update.zip to gain root access. The translation in the link was a bit off, and I found the more legible instructions on the second page which is as follows:

    1. Download zip, rename it update.zip and copy it to the root of the sd card
    2. Switch off phone
    3. Keep holding the camera button pressed until you see /!\ on your screen
    4. Press volume up and then (while keep pressing the volume up) the camera button
    5. Use the dpad to select update.zip from sd card


  20. Agatsya

    Agatsya Member

    lanoisullid - You are all set, Give it a shot :). You would notice that your DL_DB_FEATURE_ID_LOCATION_STATE is 1 when you turn "Use GPS Satellites" on from the settings menu. Oh, and you need to reset the phone for your file changes to take into effect.
  21. WirelessGuy

    WirelessGuy Well-Known Member

    What are your settings in your "Location.cfg" file for the two lines that contain "telusmobility" in the Telus phone?
  22. Agatsya

    Agatsya Member

    My hslp_address is set to blank. Like i said, the ATT assistance server seems to be down right now, and it takes me about 60 seconds or so for a GPS fix otherwise it used to take me < 15 seconds to obtain a GPS fix.
  23. WirelessGuy

    WirelessGuy Well-Known Member

    So if mine was blank, by default it would use AT&T's Assistance Server but because it has some Telus info in there it won't???
  24. Agatsya

    Agatsya Member

    HSLP Address is the ip address that the phone would connect to obtain assistance data. For telus phones, the ip address that supl.telusmobility.com resolves to an ip address that is behind the firewall of Telus network which can't be accessed using ATT's sim card. Just leave it blank and then when you start any kind of GPS test application, you would see the up and down arrows blink in the data indication on the status bar, meaning there is some data activity due to GPS.
  25. justajason

    justajason Active Member

    Ok, im in ADB and keep getting an invalid arguement when trying to mount. Any suggestions?

Share This Page