GPS sometimes stops workingSupport


  1. ragnarkar

    ragnarkar Well-Known Member

    I frequently use the GPS apps on my Samsung intercept and found that I cannot get a GPS signal sometimes. Even restarting the phone doesn't work.. the GPS will get a signal for maybe for a minute before it stops working again.

    When my GPS stops, I go into the "GPS Test" app and it says 0 satellites visible.

    I don't know if it's a coincidence but it seems to happen more often in the afternoon when my phone's battery is slightly below 50% capacity. The GPS simply refuses to work consistently.

    Advertisement
    :
  2. Darkseas

    Darkseas Well-Known Member

    The Intercept seems to do better with GPS when "use wireless networks" (under location and security settings) is on, and when mobile data is on. They are supposed to help get the initial fix.

    You might also try turning the phone off and pulling the battery.

    However, this sounds suspiciously like a hardware GPS problem to me.
  3. Hooligan77

    Hooligan77 Well-Known Member

    I agree with hardware issue, mine always locks on quickly and I have yet to have a problem with it, even after dropping it multiple times, and stepping on it once.
  4. ragnarkar

    ragnarkar Well-Known Member

    I've had this exact same problem on 2 separate Intercept units.. the first one was sent back to Virgin Mobile due to an unrelated but even more severe problem. I don't think it's simply a hardware abnormality.
  5. Darkseas

    Darkseas Well-Known Member

    Well, let's indulge you then.

    First, we need to know where you're from in the world.

    Second, are you rooted?
  6. arnould

    arnould Well-Known Member

    It may not work correctly indoors, you need a clear view of the sky. Also, are you able to determine your location through GPS in the Maps app?? (open Maps > press Menu > My Location)

    Java Programming
  7. ragnarkar

    ragnarkar Well-Known Member

    It still doesn't work correctly despite having a clear view of the sky! When this happens, Maps tries to estimate my location but cannot give any precise location.
  8. ragnarkar

    ragnarkar Well-Known Member


    1) Orange County, CA (USA)

    2) Not rooted but considering it (esp if it might help fix this.)
  9. arnould

    arnould Well-Known Member

    It's seems like a hardware problem :eek:. I would suggest to reset the Maps app; from your Home screen then Menu > Settings > Applications > Manage Applications > Filters. then press "All". Scroll through the list of applications and select the Maps app. From this screen, press "Clear cache" and "Force stop". This will reset the application. After you've done this, fire up Maps again and see if you can get a GPS fix.
    hope this works :)
  10. Darkseas

    Darkseas Well-Known Member

    I'll suggest two other things you might try based on these answers.

    Because Android devices tend to be international in their markets, the devices are often set up with a file of GPS servers that is also international. What that means is your GPS is working with all sorts of servers instead of the U.S. servers or North America servers. This is true of my Toshiba Thrive. Some of the Thrive experts have discovered that restricting servers to the user's country or region and making other minor tweaks to the gps.conf file fixes lock or slow fix problems. But you need to be rooted to fix the file. I'd guess this applies to the Intercept too, but I'm only guessing.

    Second, did you know that the GPS system learns each time you use it? I very much like the app GPS Status and Toolbox that allows you to delete all the data stored in the GPS chip and reset the GPS. There's also a tool in the app to upload orbital data for the satellites that's good for about four days. I've found these two tools to speed up things for me on both the Intercept and the Thrive. And you don't need to be rooted.

    So I'd try the app as a minimum, but I still think you may have a hardware issue.
  11. ragnarkar

    ragnarkar Well-Known Member

    I tried the GPS Status and Toolbox app.. the next time my GPS "froze" with no explanation, I reset it with that app and it came back to life! I'm not sure if this will work consistently in the future but I'll report back..

  12. ragnarkar

    ragnarkar Well-Known Member

    Ok, I've rooted my phone and it still does nothing to solve this GPS problem..

    Although the GPS toolbox app works as a bandaid.. it may be a bit inconvenient using it while driving.. exiting the navigation app, firing up GPS toolbox to reset GPS, going back to navigation app.
  13. ragnarkar

    ragnarkar Well-Known Member

    Seems I no longer have this problem once I installed the latest BROM and Crappy Kernel..
Loading...

Share This Page