Support GPS stopped working

Discussion in 'Android Devices' started by 7thgear, Jun 25, 2012.

  1. 7thgear

    7thgear Member
    25

    Jan 17, 2011
    7
    0
    25
    My GPS has saved me plenty of times. It has worked great over the last 1.5 years. All of a sudden last week I could not get a signal and again yesterday the gps would not "fix" even after 1 hour of trying. I have searched online and found some solutions but they don't seem to apply to the mesmerize, only other galaxy s phones.

    Can anyone help me out with this?
     

    Advertisement

  2. pastafarian

    pastafarian Pâtes avec votre foie
    VIP Member
    523

    Nov 4, 2009
    5,622
    4,625
    523
    Sales
    The Sea of Tranquility
    For it to have worked for so long and then suddenly stopped, either there's a software glitch (most likely) possible from an app recently installed? Or a hardware failure (unlikely). I'm assuming you've tried rebooting the phone? If not, that's a good first step. Is the phone rooted? If so, have you flashed anything recently? Have you installed any apps that might have access to the radio/gps lately? If so, try uninstalling them and rebooting. If you're phone is stock (or rooted and you've eliminated any recent flash) and you can't find a guilty app, it might be time to bite the bullet and do a hard reset.

    menu > settings > sd & phone storage > factory data reset

    Before this, make sure you've sync'd successfully with the Google mother ship. Also, if you are rooted, check to make sure how to reset your particular rom. Some need to be reset via recovery.

    If the issue persists after a factory reset, you're probably looking at some sort of hardware failure. FWIW, I like many other US based owners have had nothing but problems with Samsung's GPS implementation. This includes the Moment, Intercept, Epic and Epic 4g Touch. Poor/no signal, loss of signal and slow lock. The only major difference is that they didn't work right from the get go.

    Good luck!
     
  3. 7thgear

    7thgear Member
    25

    Jan 17, 2011
    7
    0
    25
    Thank you pastafarian,

    I will be trying the hard reset right now.
     
  4. 7thgear

    7thgear Member
    25

    Jan 17, 2011
    7
    0
    25
    Hmm well now the navigator delux seems to work but I prefer using google maps/navigation and that application still doesn't work.

    On a side note, all my contacts were erased. I synched the account with google so can i still import my contacts somehow?
     
  5. pastafarian

    pastafarian Pâtes avec votre foie
    VIP Member
    523

    Nov 4, 2009
    5,622
    4,625
    523
    Sales
    The Sea of Tranquility
    Your contacts should be sync'd with Google and will be downloaded once you put your re enter your account. Sometimes it can take a little while to download, hopefully everything is good by now! As for Google maps not working while the other app works? Could it be possible that the navigator deluxe app is grabbing control of the gps? I'm not familiar with that particular app. You can check the status of your gps with free apps like
    https://play.google.com/store/apps/details?id=com.eclipsim.gpsstatus2&feature=nav_result
    or
    https://play.google.com/store/apps/details?id=com.chartcross.gpstest&feature=nav_other
     
  6. LaTuFu

    LaTuFu Well-Known Member
    173

    Nov 10, 2009
    1,286
    257
    173
    Project Manager
    Virginia
    Unless all of your contacts were "phone" contacts and you forgot to export them to vcard. If you didn't do that, all phone contacts were erased from the phone when you did the factory wipe.

    If they were all stored in your phone as "google" contacts to your google account, then yes, they will download to your phone as soon as you link your account to your phone.
     

Share This Page

Loading...