1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

gps sucks why does GPS Test fix it?General


  1. josh4

    josh4 Active Member

    I run google maps and try to find my location. For 10 minutes it says "can not determine" "can not determine" "can not determine" blah blah. When I load GPS Test and wait for a few satellites to be "In Use" I try Google Maps again and it immediately finds my location.

    Why can't Google Maps do this on it's own? Why does GPS Test fix the problem?

    This is an easily reproduced issue. This is not a result of waiting long enough for Google Maps to work. Google Maps does not find the location no matter how long I wait until I run GPS Test.

    Advertisement
    :
  2. fratermus

    fratermus Well-Known Member

    Perhaps gmaps does not turn on the GPS and GPSTest does? Do you see the CPS icon running in the notification bar when gmaps is running?

    I wonder if turning off Location privs in Settings could stop gmap from seeing a running GPSr?
  3. josh4

    josh4 Active Member

    Yes when I load maps I get the icon in notification bar. Same icon that loads for other GPS apps, including GPS Test.

    By Location Privacy do you mean "Share With Google"? I have that turned off, use wireless networks is also turned off. After running GPS Test and I get a few satellites "In Use" then load maps and maps immediately finds me.
  4. fratermus

    fratermus Well-Known Member

    For testing purposes, you might try enabling location sharing with Google and see what happens.
  5. sal2103

    sal2103 Active Member

    sometime it depends on your location.....if you live in a area where there are a lot of tall buildings or a lot of trees it can affect for gps signal
  6. fratermus

    fratermus Well-Known Member

    True, multipath and occluded reception (both problems in urban canyons or other difficult areas) can cause degraded performance. But this should be the same for both applications that are using the same hardware.

    Maybe the dedicated GPS app is using some hook in the GPS that Maps isn't. Dunno.
Loading...

Share This Page