Support GPS takes 20+ mins to load?

Discussion in 'Android Devices' started by LaxHaak, Jul 23, 2011.

  1. LaxHaak

    LaxHaak New Member
    5

    Jul 23, 2011
    2
    0
    5
    My Samsung vibrant was rooted, and the GPS was taking 20+ mins to finally finish saying "searching for GPS". So i unrooted, and it's still the same!

    So.. any idea what I can do? Because by the time it finds the GPS, im already where I needed to be. This is very frustrating. Like, should I wipe everything and do a factory reset? Any ideas?
     

    Advertisement
  2. DrPennington

    DrPennington Well-Known Member
    16

    Sep 12, 2010
    52
    8
    16
    Yeah the gps sucks on these phones! Search samsung gps restore in the market, that seems to have worked for some people. Also using the search feature on this site helps. You're not the first person with this issue.
     
  3. dattack

    dattack Well-Known Member
    16

    Jul 16, 2010
    72
    6
    16
    What Rom were you running?
     
  4. lexluthor

    lexluthor Well-Known Member
    173

    May 15, 2010
    4,161
    402
    173
    Long Island, NY
    Download compass from the market and calibrate. See if that helps.
     
  5. davidtheprof

    davidtheprof Active Member
    16

    Oct 29, 2010
    38
    2
    16
    there are dozens of threads on this topic. My experience is that Samsung's GPS restore followed by a reboot usually fixes it (though never as sensitive as my Garmin GPS, especially in dense cities).

    Occasionally I need to delete the gps aiding data that has accumulated, (use a GPS test app for this).

    the problem is mostly software - sometimes the gps gets signal from 10 satellites without locking on, then they gradually disappear, leaving only one or two.

    Was recently in Europe, and lost the SD card from my Garmin with European maps - the Vibrant was surprisingly good at getting me around!
     
  6. davidtheprof

    davidtheprof Active Member
    16

    Oct 29, 2010
    38
    2
    16
    looks like this forum is dying.. so here is some good GPS news -
    a few months ago, my GPS suddenly started working reliably, locking on within a few minutes to at least 6 or 7 satellites and estimated accuracy around 20-25 ft once it settles down. Still wanders off a bit in city blocks with tall buildings, but generally does the job.
    No idea what fixed it, no changes in settings. I'd already tried the Samsung GPS fix, but it would still hang on occasion and need a reboot. Now it always works.
     

Share This Page

Loading...