1. Good things coming in just a couple hours, stay tuned!
    Dismiss Notice

GPS taking forever to find your location?Support


Last Updated:

  1. MetroPOS

    MetroPOS Well-Known Member

    I noticed on my Indulge that when I enable GPS from the pulldown menu, it usually takes forever for it to finally triangulate my position, and apps that are waiting for the GPS location give up waiting for it.

    Instead of turning on GPS from the pulldown menu, I went to Settings --> Location & security and put a checkmark in the Google location services (which I usually leave disabled since Google collects anonymous location data when you have it turned on), and left the Standalone GPS services button unchecked, and the GPS worked right away and all the apps that use GPS location pulled up where I was instantly.

    So for some reason on my phone, leaving off Standalone and turning on the Google location services makes GPS work immediately.

    I guess it's not a coincidence that when you enable Google's position tracking spyware GPS crap, the GPS on the phone works much better.

    Advertisement
  2. ciper

    ciper Well-Known Member

    Dont disable the GPS. It wont help your battery life in any measurable amount. The GPS is only running when an app is requesting the location. If you dont see the blinking or solid satellite icon in the status bar then the GPS is asleep.

    Your phone should only show a crosshair logo in the status bar when not using a GPS app. If its not a cross hair then some widget you have installed is activating the GPS when it shouldnt
  3. edgchacon

    edgchacon Well-Known Member

    DOes the indulge have the Enable background data?? I mean if you run something like Google Latitude, wouldnt it send data in the background?? to track where you go? Or things like FourSquare?

    I dont have this model(LGMS690), but I turned my GPS off and saw instant results, my battery didnt die out until the evening(9 or 10pm) as opposed to end of my work day(5pm).
  4. fdbryant3

    fdbryant3 Well-Known Member

    Curiously enough I've had the opposite experience. I was having the problem where I couldn't get a GPS lock until I figure out to turn off the Google Location Service. Once I did that I've gotten GPS locks pretty quickly.

    It also seems to kill my battery fast to leave the GPS running when I go indoors, even it is the crosshairs. Have to experiment with it more though.
  5. tiede

    tiede Well-Known Member

    GPS cannot be the culprit. Unless it is being used by an application, the chip uses 0 battery power. I have mine on all the time and it does not affect battery life one bit.
    I'm sure ciper can corroborate my remark...
  6. ciper

    ciper Well-Known Member

    I agree with Tiede.

    I DID notice a battery life decrease when I added a traffic widget to the launcher. It was using GPS and Data at random times without me realizing it
  7. indulge

    indulge Well-Known Member

    still takes a long time to find your location even if it is already on
  8. TRS-80

    TRS-80 Well-Known Member

    Yeah, I don't know what the deal with the GPS is, I have had problems with it ever since I got the phone. Takes forever to get a location, if it ever gets one at all. Horrible. Almost always, Places, etc. is just getting my location from the network (tower).

    It did work for me once, miraculously. We took a trip down to Ft. Lauderdale recently, and it worked like a champ the entire time we were down there traveling around the area. Which was good, because I didn't know my way around down there of course.

    Now, I'm just trying to remember exactly what I did... I believe I cleared some cache settings or something according to some of tiede or someone's instructions in another post... But I try to do that again now, and it doesn't seem to work. :( I am still trying to figure this out, the almost complete lack of GPS loc on this phone is very frustrating...
  9. indulge

    indulge Well-Known Member

    Is it the phones fault for bad GPS? or is this a normal, i have a Garmin and it woks like a charm, of course that's what they are built only to do.
  10. MetroPOS

    MetroPOS Well-Known Member

    I thought this was going to work for everyone...but apparently not. I updated my original post to point out that I don't enable GPS from the pulldown menu anymore and only enable the Google location services from the Locations & settings menu when I want to use GPS (because turning on the Google thing enables GPS anyway). If doing that didn't help you guys then I have no clue what else to suggest. Oh well
  11. MetroPOS

    MetroPOS Well-Known Member

    You just reminded me...on my Indulge I also have both the Background data and Auto-sync options enabled in the Settings --> Accounts & sync menu. Wonder if you guys who are having problems with the GPS have those disabled.
  12. nps531

    nps531 Well-Known Member

    i have a lot of problems with my gps
  13. dsrtegl

    dsrtegl Active Member

    The GPS on mine has never worked properly or reliably. It works seemingly at random and even then maybe once per month or so. My Droid X locks on in seconds and the Indulge will just sit there, blink at you and tell you that you're about two miles away from where you really are.
  14. MetroPOS

    MetroPOS Well-Known Member

    If my suggestions above did not help, then I don't know what to tell you. Take it to store and complain?
  15. tiede

    tiede Well-Known Member

    Try ##GPSCLRX# with your SPC code. Then Gmaps with wifi on until you get lock.
    If it's taking a while before getting a lock still, grasp the phone by the sides and make a figure 8 pattern about three times with it, making sure the actual phone moves face up, face down, top down...
    I.e. don't do it like it's a remote control's laser pointer you're making the 8s with!
    That should reset the internal compass and hopefully help with you getting a lock on.

    This process only needs to be done as described the first time. Subsequent uses should work as normal afterwards.
  16. TRS-80

    TRS-80 Well-Known Member

    How does one go about getting their SPC code?
  17. tiede

    tiede Well-Known Member

    Download MEID converter from the market. Your meid is in the about phone settings option.
    Just copy it down, open the app and follow the instructions from within.
  18. TRS-80

    TRS-80 Well-Known Member

    tiede, thanks man. I ended up finding a converter tool as you said, and found my MEID behind the battery. The number found under "About Phone" is incorrectly called the IMEI, which threw me off for a second. Then I had recalled ciper saying something about those being switched around on our phone and after that I was off to the races. But thanks for getting back all the same! :)

    Well anyway, I am happy to say that my GPS is working awesome now! That was so disappointing, not having the GPS functionality working on this phone, and frustrating trying to get it to work. Well, it took me some fumbling about and following various steps, but I finally got it to work right. So I kind of just wanted to put everything together into a simple, easy to follow step by step guide in hopes of helping out some others out there who may also be having these issues. So, here goes...

    [edit] I have moved everything into a new post here (so if this takes off, it can be stickied / found easier, etc...):

    TRS-80's Guide to Getting GPS to work on teh Samsung Galuxy Indulge!
    T3XAN likes this.
  19. T3XAN

    T3XAN Well-Known Member

    Worked great! Thx TRS-80!
  20. tiede

    tiede Well-Known Member

    The GPSCLRX step alone should fix the issue without the need of all the other fumbling arounds... :)
    Glad to hear it's worked out for most of you folks!
    If it doesn't work for someone, let me know and I'll take a look at it :p

Share This Page