1. In regards to recently combined carrier specific root forums, if your device forum was affected, please see this poll/thread!

GPS/WiFi not allowing phone to sleep?Support


  1. Metfanant

    Metfanant Well-Known Member

    Ok, back with 2.1 there was the issue with GPS, and once it was activated not allowing the phone to "sleep." You could see the results of this in the "Battery History" screen that Spare Parts would give you...

    First of all this does not seem to be fixed with 2.2 unless im missing something in my settings, and actually it seems to have gotten worse...

    Even when i change my WiFi Sleep Policy to turn off when "screen is off" it seems as though the phone cannot go to sleep, and my Wifi is not turning off as it should...

    Has anyone else experienced this? Or can replicate what i'm seeing??

    Advertisement
  2. binary visions

    binary visions Well-Known Member

    I don't have this problem, but the constant turning on and off of the Wifi radio isn't good for your battery life. Leave it on all the time, just turn off Wifi when you're not going to be using it for extended periods.
  3. Brian_83

    Brian_83 Well-Known Member

    There is a difference between Wifi On and Wifi Running. My Wifi On is usually 100%, but Wifi Running is way less. I believe when you turn the screen on and Wifi sleep then it is no longer running but it's still on.

    On another note I'm also having some odd sleep issues with 2.2 and had them with the leaked 2.2 as well. I've yet to figure it out. As far as I can tell it isn't the same GPS bug as before. My phone will sleep fine for several hours or most of a day or so but then it will stop sleeping until the phone is rebooted. The odd part is partial wake shows nothing even though it says it's not sleeping.
  4. Metfanant

    Metfanant Well-Known Member

    Both my wifi on and wifi running are JUST under 100%....it seems as though im having a similar situation with you...sometimes the phone will sleep...but the majority of the time it will not...I have gps turned off...so I know its the wifi causing the problem right now...

    Do you think I should try a factory reset???
  5. Brian_83

    Brian_83 Well-Known Member

    Hmm.. that's a hard one. It can't hurt. So far today my phone is still sleeping, we'll see what happens. It seems like I've made it through a day before but as soon as I charge it tonight and take it off the charger tomorrow it'll probably not sleep at all.
  6. Metfanant

    Metfanant Well-Known Member

    Out of curiosity...when you look into the battery usage screen what percentage of battery dies it say your wifi ia using???
  7. Metfanant

    Metfanant Well-Known Member

    I think I have an update, and am on the right track...tell me if any of this makes sense guys...

    So I went into the "battery history" and looked at network usage and noticed a mysterious "1013" using my network and its bar is completely blue, meaning it has not stopped running...

    Using Android System Info I looked through all the tasks for anything that might be similar...and I come up with these results

    SERVICE/USERID

    Battery Monitor 10131
    XBox Live avatar Widget 1013
    android.process.score 10130 (this seems to be launcher pro? as its package is com.feds.launcher)

    The battery monitor has no permissions so it should not be using the network...however the avatar widgets had full internet access...I deleted them and now im gonna check the usage in a bit to see how its changed...

Share This Page